aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-05-19 00:02:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-05-19 00:02:38 +0800
commit4c14b9684c2e7d18079c645b38e3906b2577b0e3 (patch)
treef0e9ed60756fa5fecbd16318c32fd384bb13a3e3 /devel
parent2975623194c8a9488e63d4bfe6665a7b84629b02 (diff)
downloadfreebsd-ports-gnome-4c14b9684c2e7d18079c645b38e3906b2577b0e3.tar.gz
freebsd-ports-gnome-4c14b9684c2e7d18079c645b38e3906b2577b0e3.tar.zst
freebsd-ports-gnome-4c14b9684c2e7d18079c645b38e3906b2577b0e3.zip
Add py-rwt 2.15.1
RWT (Run With This) provides on-demand dependency resolution. - Allows declaration of dependencies at runtime. - Downloads missing dependencies and makes their packages available for import. - Installs packages to a special staging location such that they're not installed after the process exits. - Relies on pip to cache downloads of such packages for reuse. - Supersedes installed packages when required. - Relies on packages already satisfied. - Re-uses the pip tool chain for package installation and pkg_resources for working set management. WWW: https://pypi.python.org/pypi/rwt WWW: https://github.com/jaraco/rwt
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-rwt/Makefile22
-rw-r--r--devel/py-rwt/distinfo3
-rw-r--r--devel/py-rwt/pkg-descr14
-rw-r--r--devel/py-rwt/pkg-plist28
5 files changed, 68 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dfdfbeb9f4dd..b5b3d89e62c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4696,6 +4696,7 @@
SUBDIR += py-ruamel.yaml
SUBDIR += py-rubymarshal
SUBDIR += py-ruledispatch
+ SUBDIR += py-rwt
SUBDIR += py-sanetime
SUBDIR += py-sarge
SUBDIR += py-scripttest
diff --git a/devel/py-rwt/Makefile b/devel/py-rwt/Makefile
new file mode 100644
index 000000000000..f23e8406ff09
--- /dev/null
+++ b/devel/py-rwt/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rwt
+PORTVERSION= 2.15.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= RWT (Run With This) provides on-demand dependency resolution
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.0:devel/py-setuptools_scm
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>=0:devel/py-pip
+
+NO_ARCH= yes
+USE_PYTHON= distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-rwt/distinfo b/devel/py-rwt/distinfo
new file mode 100644
index 000000000000..b36688b3ff9e
--- /dev/null
+++ b/devel/py-rwt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495052893
+SHA256 (rwt-2.15.1.tar.gz) = b0abb1c3c1621b2bb33483245a4572a109143764176cd0a0156d50b36549760a
+SIZE (rwt-2.15.1.tar.gz) = 13578
diff --git a/devel/py-rwt/pkg-descr b/devel/py-rwt/pkg-descr
new file mode 100644
index 000000000000..c02f6dfe1c0d
--- /dev/null
+++ b/devel/py-rwt/pkg-descr
@@ -0,0 +1,14 @@
+RWT (Run With This) provides on-demand dependency resolution.
+
+- Allows declaration of dependencies at runtime. - Downloads missing
+ dependencies and makes their packages available for import.
+- Installs packages to a special staging location such that they're not
+ installed after the process exits.
+- Relies on pip to cache downloads of such packages for reuse.
+- Supersedes installed packages when required.
+- Relies on packages already satisfied.
+- Re-uses the pip tool chain for package installation and pkg_resources for
+ working set management.
+
+WWW: https://pypi.python.org/pypi/rwt
+WWW: https://github.com/jaraco/rwt
diff --git a/devel/py-rwt/pkg-plist b/devel/py-rwt/pkg-plist
new file mode 100644
index 000000000000..017d42ff0fec
--- /dev/null
+++ b/devel/py-rwt/pkg-plist
@@ -0,0 +1,28 @@
+bin/rwt
+%%PYTHON_SITELIBDIR%%/rwt/__init__.py
+%%PYTHON_SITELIBDIR%%/rwt/__init__.pyc
+%%PYTHON_SITELIBDIR%%/rwt/__init__.pyo
+%%PYTHON_SITELIBDIR%%/rwt/__main__.py
+%%PYTHON_SITELIBDIR%%/rwt/__main__.pyc
+%%PYTHON_SITELIBDIR%%/rwt/__main__.pyo
+%%PYTHON_SITELIBDIR%%/rwt/commands.py
+%%PYTHON_SITELIBDIR%%/rwt/commands.pyc
+%%PYTHON_SITELIBDIR%%/rwt/commands.pyo
+%%PYTHON_SITELIBDIR%%/rwt/deps.py
+%%PYTHON_SITELIBDIR%%/rwt/deps.pyc
+%%PYTHON_SITELIBDIR%%/rwt/deps.pyo
+%%PYTHON_SITELIBDIR%%/rwt/launch.py
+%%PYTHON_SITELIBDIR%%/rwt/launch.pyc
+%%PYTHON_SITELIBDIR%%/rwt/launch.pyo
+%%PYTHON_SITELIBDIR%%/rwt/scripts.py
+%%PYTHON_SITELIBDIR%%/rwt/scripts.pyc
+%%PYTHON_SITELIBDIR%%/rwt/scripts.pyo
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_deps.py
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_deps.pyc
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_deps.pyo
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_launch.py
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_launch.pyc
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_launch.pyo
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_scripts.py
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_scripts.pyc
+%%PYTHON_SITELIBDIR%%/rwt/tests/test_scripts.pyo