aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2015-09-29 22:49:45 +0800
committernovel <novel@FreeBSD.org>2015-09-29 22:49:45 +0800
commit4d1a3e1411dd6028079ea3aba3281f3f0a3bf056 (patch)
treef2e4725a3f737ba9438f3c5c0c4ba002a64e87a7 /devel
parent9fc6b82b436f0bcc1ea82794bf922fb1b81a9b29 (diff)
downloadfreebsd-ports-gnome-4d1a3e1411dd6028079ea3aba3281f3f0a3bf056.tar.gz
freebsd-ports-gnome-4d1a3e1411dd6028079ea3aba3281f3f0a3bf056.tar.zst
freebsd-ports-gnome-4d1a3e1411dd6028079ea3aba3281f3f0a3bf056.zip
Fix plist on non-amd64 archs
When the arch-specific option is defined and OPTIONS_SUB is enabled, PLIST_SUB is populated accordingly on the target arch. However, on other archs PLIST_SUB is not populated and that results in a broken pkg-plist. Fix this by explicitly adding '@comment ' for the option feature if it's not in PLIST_SUB. Reported by: jgh Pointy hat to: novel
Diffstat (limited to 'devel')
-rw-r--r--devel/libvirt/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 8ff35dd00e9d..52c0813d5c50 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -100,6 +100,10 @@ STRIP_FILES+= lib/libvirt/connection-driver/libvirt_driver_bhyve.so
PLIST_FILES+= lib/libvirt/connection-driver/libvirt_driver_bhyve.so
.endif
+.if !${PLIST_SUB:MXEN}
+PLIST_SUB+= XEN="@comment "
+.endif
+
post-patch:
.if ${OSVERSION} < 900000
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||' \