aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2003-01-30 17:47:35 +0800
committerdirk <dirk@FreeBSD.org>2003-01-30 17:47:35 +0800
commit4e602de6f6b06e5ccfce7993c61dd3d28dab3a56 (patch)
tree8ace2cda69e24312f309e8b28050948cbac65416 /devel
parent44ddbfd8d39f2a2b3aca197642ed491f2278ef4a (diff)
downloadfreebsd-ports-gnome-4e602de6f6b06e5ccfce7993c61dd3d28dab3a56.tar.gz
freebsd-ports-gnome-4e602de6f6b06e5ccfce7993c61dd3d28dab3a56.tar.zst
freebsd-ports-gnome-4e602de6f6b06e5ccfce7993c61dd3d28dab3a56.zip
Add pear-HTML_Select:
Some small PEAR classes to handle common <select> lists. PR: ports/47418 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_Select/Makefile52
-rw-r--r--devel/pear-HTML_Select/distinfo1
-rw-r--r--devel/pear-HTML_Select/files/Select.php328
-rw-r--r--devel/pear-HTML_Select/pkg-comment1
-rw-r--r--devel/pear-HTML_Select/pkg-descr6
-rw-r--r--devel/pear-HTML_Select/pkg-plist9
-rw-r--r--devel/pear-HTML_Select_Common/Makefile52
-rw-r--r--devel/pear-HTML_Select_Common/distinfo1
-rw-r--r--devel/pear-HTML_Select_Common/files/Select.php328
-rw-r--r--devel/pear-HTML_Select_Common/pkg-comment1
-rw-r--r--devel/pear-HTML_Select_Common/pkg-descr6
-rw-r--r--devel/pear-HTML_Select_Common/pkg-plist9
13 files changed, 795 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2583a0a1c1de..fbce0a7bd9a0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -651,6 +651,7 @@
SUBDIR += pear-Console_Getopt
SUBDIR += pear-Date
SUBDIR += pear-HTML_Common
+ SUBDIR += pear-HTML_Select
SUBDIR += pear-PEAR
SUBDIR += pear-install
SUBDIR += pedisassem
diff --git a/devel/pear-HTML_Select/Makefile b/devel/pear-HTML_Select/Makefile
new file mode 100644
index 000000000000..e7183eaa9553
--- /dev/null
+++ b/devel/pear-HTML_Select/Makefile
@@ -0,0 +1,52 @@
+# Ports collection makefile for: pear-HTML_Select
+# Date created: 30 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Select
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common \
+ ${PEARDIR}/I18N/Common.php:${PORTSDIR}/devel/pear-I18N
+
+NO_BUILD= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/pear/HTML_Select
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+MANIFEST= Country.php UKCounty.php USState.php
+EXAMPLES= Country.php UKCounty.php USState.php
+
+do-install:
+ @${MKDIR} ${PEARDIR}/HTML/Select
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/Select/${FILE} ${PEARDIR}/HTML/Select
+.endfor
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Select
+ @${CHMOD} a-x ${PEARDIR}/HTML/Select/*
+#Note: Select.php is still needed for Kronolith 1.0
+# but should be removed with the next release.
+ @${CP} -p ${FILESDIR}/Select.php ${PEARDIR}/HTML
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Select.php
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/Select/examples/${FILE} ${EXAMPLESDIR}
+.endfor
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/pear-HTML_Select/distinfo b/devel/pear-HTML_Select/distinfo
new file mode 100644
index 000000000000..d2e7741410ca
--- /dev/null
+++ b/devel/pear-HTML_Select/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/HTML_Select-1.0.tgz) = b9db4ed0b2e951e6ed81f251a986e566
diff --git a/devel/pear-HTML_Select/files/Select.php b/devel/pear-HTML_Select/files/Select.php
new file mode 100644
index 000000000000..fafdbbfe041a
--- /dev/null
+++ b/devel/pear-HTML_Select/files/Select.php
@@ -0,0 +1,328 @@
+<?php
+/* vim: set expandtab tabstop=4 shiftwidth=4: */
+// +----------------------------------------------------------------------+
+// | PHP Version 4 |
+// +----------------------------------------------------------------------+
+// | Copyright (c) 1997, 1998, 1999, 2000, 2001 The PHP Group |
+// +----------------------------------------------------------------------+
+// | This source file is subject to version 2.0 of the PHP license, |
+// | that is bundled with this package in the file LICENSE, and is |
+// | available at through the world-wide-web at |
+// | http://www.php.net/license/2_02.txt. |
+// | If you did not receive a copy of the PHP license and are unable to |
+// | obtain it through the world-wide-web, please send a note to |
+// | license@php.net so we can mail you a copy immediately. |
+// +----------------------------------------------------------------------+
+// | Author: Adam Daniel <adaniel1@eesus.jnj.com> |
+// +----------------------------------------------------------------------+
+//
+// $Id: Select.php,v 1.10.2.2 2002/04/09 19:04:19 ssb Exp $
+
+require_once 'PEAR.php';
+require_once 'HTML/Common.php';
+
+/**
+ * Class to dynamically create an HTML SELECT
+ *
+ * @author Adam Daniel <adaniel1@eesus.jnj.com>
+ * @version 1.2
+ * @since PHP4.04pl1
+ * @access public
+ */
+class HTML_Select extends HTML_Common
+{
+
+ /**
+ * Contains the select options
+ *
+ * @var array
+ * @since 1.0
+ * @access private
+ */
+ var $_options = array();
+
+ /**
+ * Default values of the SELECT
+ *
+ * @var string
+ * @since 1.0
+ * @access private
+ */
+ var $_values = array();
+
+ /**
+ * Class constructor
+ *
+ * @param string $name (optional)Name attribute of the SELECT
+ * @param int $size (optional) Size attribute of the SELECT
+ * @param bool $multiple (optional)Whether the select will allow multiple
+ * selections or not
+ * @param mixed $attributes (optional)Either a typical HTML attribute string
+ * or an associative array
+ * @param int $tabOffset (optional)Number of tabs to offset HTML source
+ * @since 1.0
+ * @access public
+ * @return void
+ * @throws
+ */
+ function HTML_Select($name = '', $size = 1, $multiple = false, $attributes = null, $tabOffset = 0)
+ {
+ HTML_Common::HTML_Common($attributes, $tabOffset);
+ $attr = array('name' => $name, 'size' => $size);
+ if ($multiple) {
+ $attr[] = 'multiple="multiple"';
+ }
+ $this->updateAttributes($attr);
+ $this->setSelectedValues(array());
+ }
+
+ /**
+ * Returns the current API version
+ *
+ * @since 1.0
+ * @access public
+ * @return double
+ * @throws
+ */
+ function apiVersion()
+ {
+ return 1.2;
+ }
+
+ /**
+ * Sets the default values of the select box
+ *
+ * @param mixed $values Array or comma delimited string of selected values
+ * @since 1.0
+ * @access public
+ * @return void
+ * @throws
+ */
+ function setSelectedValues($values)
+ {
+ if (is_string($values)) {
+ $values = split("[ ]?,[ ]?", $values);
+ }
+ $this->_values = $values;
+ }
+
+ /**
+ * Returns an array of the selected values
+ *
+ * @since 1.0
+ * @access public
+ * @return array of selected values
+ * @throws
+ */
+ function getSelectedValues()
+ {
+ return $this->_values;
+ }
+
+ /**
+ * Adds a new OPTION to the SELECT
+ *
+ * @param string $text Display text for the OPTION
+ * @param string $value Value for the OPTION
+ * @param bool $selected Whether the option is selected or not
+ * @param mixed $attributes Either a typical HTML attribute string
+ * or an associative array
+ * @since 1.0
+ * @access public
+ * @return void
+ * @throws
+ */
+ function addOption($text, $value, $selected = false, $attributes = null)
+ {
+ if ($selected && !in_array($value, $this->_values)) {
+ $this->_values[] = $value;
+ }
+
+ $attributes = $this->_parseAttributes($attributes);
+ $attr['value'] = $value;
+ $this->_updateAttrArray($attributes, $attr);
+ $this->_options[] = array('text' => $text, 'attr' => $attributes);
+ }
+
+ /**
+ * Loads the options from an associative array
+ *
+ * @param array $arr Associative array of options
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.0
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function loadArray($arr, $values=null)
+ {
+ if (!is_array($arr)) {
+ return new PEAR_ERROR('First argument to HTML_Select::loadArray is not a valid array');
+ }
+ if (isset($values)) {
+ $this->setSelectedValues($values);
+ }
+ while (list($key, $value) = each($arr)) {
+ $this->addOption($key, $value);
+ }
+ return true;
+ }
+
+ /**
+ * Loads the options from an array with numeric keys, using the
+ * array values as the form values as well as labels.
+ *
+ * @param array $arr Array of options
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.2
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function loadValueArray($arr, $values = null)
+ {
+ if (!is_array($arr)) {
+ return new PEAR_ERROR("First argument to HTML_Select::loadArray is not a valid array");
+ }
+ if (isset($values)) {
+ $this->setSelectedValues($values);
+ }
+ foreach ($arr as $value) {
+ $this->addOption($value, $value);
+ }
+ return true;
+ }
+
+ /**
+ * Loads the options from DB_result object
+ *
+ * If no column names are specified the first two columns of the result are
+ * used as the text and value columns respectively
+ * @param object $result DB_result object
+ * @param string $textCol (optional) Name of column to display as the OPTION text
+ * @param string $valueCol (optional) Name of column to use as the OPTION value
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.0
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function loadDbResult(&$result, $textCol=null, $valueCol=null, $values=null)
+ {
+ include_once 'DB.php';
+
+ if (!is_object($result) || (get_class($result) != "db_result" &&
+ is_subclass_of($result, "db_result"))) {
+ return new PEAR_ERROR("First argument to HTML_Select::loadDbResult is not a valid DB_result");
+ }
+ if (isset($values)) {
+ $this->setSelectedValues($values);
+ }
+ $fetchMode = ($textCol && $valueCol) ? DB_FETCHMODE_ASSOC : DB_FETCHMODE_DEFAULT;
+ while (is_array($row = $result->fetchRow($fetchMode)) ) {
+ if ($fetchMode == DB_FETCHMODE_ASSOC) {
+ $this->addOption($row[$textCol], $row[$valueCol]);
+ } else {
+ $this->addOption($row[0], $row[1]);
+ }
+ }
+ return true;
+ }
+
+ /**
+ * Queries a database and loads the options from the results
+ *
+ * @param mixed $conn Either an existing DB connection or a valid dsn
+ * @param string $sql SQL query string
+ * @param string $textCol (optional) Name of column to display as the OPTION text
+ * @param string $valueCol (optional) Name of column to use as the OPTION value
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.1
+ * @access private
+ * @return void
+ * @throws
+ */
+ function loadQuery(&$conn, $sql, $textCol=null, $valueCol=null, $values=null)
+ {
+ include_once 'DB.php';
+
+ if (is_string($conn)) {
+ $dbConn = &DB::connect($conn, true);
+ if (DB::isError($dbConn)) return $dbConn;
+ } elseif (is_subclass_of($conn, "db_common")) {
+ $dbConn = $conn;
+ } else {
+ return new PEAR_Error("Argument 1 of HTML_Select::loadQuery is not a valid type");
+ }
+ $result = @$dbConn->query($sql);
+ if (DB::isError($result)) return $result;
+ return $this->loadDbResult($result, $textCol, $valueCol, $values);
+ }
+
+ /**
+ * Loads options from different types of data sources
+ *
+ * This method is a simulated overloaded method. The arguments, other than the
+ * first are optional and only mean something depending on the type of the first argument.
+ * If the first argument is an array then all arguments are passed in order to loadArray.
+ * If the first argument is a db_result then all arguments are passed in order to loadDbResult.
+ * If the first argument is a string or a DB connection then all arguments are
+ * passed in order to loadQuery.
+ * @param mixed $options Options source currently supports assoc array or DB_result
+ * @param mixed $param1 (optional) See function detail
+ * @param mixed $param2 (optional) See function detail
+ * @param mixed $param3 (optional) See function detail
+ * @param mixed $param4 (optional) See function detail
+ * @since 1.1
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function load(&$options, $param1=null, $param2=null, $param3=null, $param4=null)
+ {
+ switch (true) {
+ case is_array($options):
+ return $this->loadArray($options, $param1);
+ break;
+ case (get_class($options) == "db_result" || is_subclass_of($options, "db_result")):
+ return $this->loadDbResult($options, $param1, $param2, $param3);
+ break;
+ case (is_string($options) || is_subclass_of($options, "db_common")):
+ return $this->loadQuery($options, $param1, $param2, $param3, $param4);
+ break;
+ }
+ }
+
+ /**
+ * Returns the SELECT in HTML
+ *
+ * @since 1.0
+ * @access public
+ * @return string
+ * @throws
+ */
+ function toHtml()
+ {
+ $tabs = $this->_getTabs();
+ $name = $this->_attributes['name'];
+ $strHtml = $tabs;
+ if ($this->_comment) {
+ $strHtml .= "<!-- $this->_comment -->\n$tabs";
+ }
+ $strHtml .=
+ '<select' . $this->_getAttrString($this->_attributes) . '>';
+ foreach ($this->_options as $option) {
+ if (@in_array($option['attr']['value'], $this->_values)) {
+ $option['attr']['selected'] = 'selected';
+ }
+ $attrString = $this->_getAttrString($option['attr']);
+ $strHtml .=
+ '<option' . $attrString . '>' .
+ htmlspecialchars($option['text']) . '</option>';
+ }
+ $strHtml .= '</select>';
+ return $strHtml;
+ }
+
+}
+?>
diff --git a/devel/pear-HTML_Select/pkg-comment b/devel/pear-HTML_Select/pkg-comment
new file mode 100644
index 000000000000..6a6c56728be5
--- /dev/null
+++ b/devel/pear-HTML_Select/pkg-comment
@@ -0,0 +1 @@
+Some small PEAR classes to handle common <select> lists
diff --git a/devel/pear-HTML_Select/pkg-descr b/devel/pear-HTML_Select/pkg-descr
new file mode 100644
index 000000000000..4929a54c9d9f
--- /dev/null
+++ b/devel/pear-HTML_Select/pkg-descr
@@ -0,0 +1,6 @@
+Provides <select> lists for:
+o Country
+o UK counties
+o US States
+
+WWW: http://pear.php.net/package-info.php?pacid=58
diff --git a/devel/pear-HTML_Select/pkg-plist b/devel/pear-HTML_Select/pkg-plist
new file mode 100644
index 000000000000..9f094ae340a9
--- /dev/null
+++ b/devel/pear-HTML_Select/pkg-plist
@@ -0,0 +1,9 @@
+%%PEARDIR%%/HTML/Select.php
+%%PEARDIR%%/HTML/Select/Country.php
+%%PEARDIR%%/HTML/Select/UKCounty.php
+%%PEARDIR%%/HTML/Select/USState.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/Country.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/UKCounty.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/USState.php
+@dirrm %%PEARDIR%%/HTML/Select
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
diff --git a/devel/pear-HTML_Select_Common/Makefile b/devel/pear-HTML_Select_Common/Makefile
new file mode 100644
index 000000000000..e7183eaa9553
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/Makefile
@@ -0,0 +1,52 @@
+# Ports collection makefile for: pear-HTML_Select
+# Date created: 30 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Select
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common \
+ ${PEARDIR}/I18N/Common.php:${PORTSDIR}/devel/pear-I18N
+
+NO_BUILD= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/pear/HTML_Select
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+MANIFEST= Country.php UKCounty.php USState.php
+EXAMPLES= Country.php UKCounty.php USState.php
+
+do-install:
+ @${MKDIR} ${PEARDIR}/HTML/Select
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/Select/${FILE} ${PEARDIR}/HTML/Select
+.endfor
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Select
+ @${CHMOD} a-x ${PEARDIR}/HTML/Select/*
+#Note: Select.php is still needed for Kronolith 1.0
+# but should be removed with the next release.
+ @${CP} -p ${FILESDIR}/Select.php ${PEARDIR}/HTML
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML/Select.php
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/Select/examples/${FILE} ${EXAMPLESDIR}
+.endfor
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/pear-HTML_Select_Common/distinfo b/devel/pear-HTML_Select_Common/distinfo
new file mode 100644
index 000000000000..d2e7741410ca
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/HTML_Select-1.0.tgz) = b9db4ed0b2e951e6ed81f251a986e566
diff --git a/devel/pear-HTML_Select_Common/files/Select.php b/devel/pear-HTML_Select_Common/files/Select.php
new file mode 100644
index 000000000000..fafdbbfe041a
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/files/Select.php
@@ -0,0 +1,328 @@
+<?php
+/* vim: set expandtab tabstop=4 shiftwidth=4: */
+// +----------------------------------------------------------------------+
+// | PHP Version 4 |
+// +----------------------------------------------------------------------+
+// | Copyright (c) 1997, 1998, 1999, 2000, 2001 The PHP Group |
+// +----------------------------------------------------------------------+
+// | This source file is subject to version 2.0 of the PHP license, |
+// | that is bundled with this package in the file LICENSE, and is |
+// | available at through the world-wide-web at |
+// | http://www.php.net/license/2_02.txt. |
+// | If you did not receive a copy of the PHP license and are unable to |
+// | obtain it through the world-wide-web, please send a note to |
+// | license@php.net so we can mail you a copy immediately. |
+// +----------------------------------------------------------------------+
+// | Author: Adam Daniel <adaniel1@eesus.jnj.com> |
+// +----------------------------------------------------------------------+
+//
+// $Id: Select.php,v 1.10.2.2 2002/04/09 19:04:19 ssb Exp $
+
+require_once 'PEAR.php';
+require_once 'HTML/Common.php';
+
+/**
+ * Class to dynamically create an HTML SELECT
+ *
+ * @author Adam Daniel <adaniel1@eesus.jnj.com>
+ * @version 1.2
+ * @since PHP4.04pl1
+ * @access public
+ */
+class HTML_Select extends HTML_Common
+{
+
+ /**
+ * Contains the select options
+ *
+ * @var array
+ * @since 1.0
+ * @access private
+ */
+ var $_options = array();
+
+ /**
+ * Default values of the SELECT
+ *
+ * @var string
+ * @since 1.0
+ * @access private
+ */
+ var $_values = array();
+
+ /**
+ * Class constructor
+ *
+ * @param string $name (optional)Name attribute of the SELECT
+ * @param int $size (optional) Size attribute of the SELECT
+ * @param bool $multiple (optional)Whether the select will allow multiple
+ * selections or not
+ * @param mixed $attributes (optional)Either a typical HTML attribute string
+ * or an associative array
+ * @param int $tabOffset (optional)Number of tabs to offset HTML source
+ * @since 1.0
+ * @access public
+ * @return void
+ * @throws
+ */
+ function HTML_Select($name = '', $size = 1, $multiple = false, $attributes = null, $tabOffset = 0)
+ {
+ HTML_Common::HTML_Common($attributes, $tabOffset);
+ $attr = array('name' => $name, 'size' => $size);
+ if ($multiple) {
+ $attr[] = 'multiple="multiple"';
+ }
+ $this->updateAttributes($attr);
+ $this->setSelectedValues(array());
+ }
+
+ /**
+ * Returns the current API version
+ *
+ * @since 1.0
+ * @access public
+ * @return double
+ * @throws
+ */
+ function apiVersion()
+ {
+ return 1.2;
+ }
+
+ /**
+ * Sets the default values of the select box
+ *
+ * @param mixed $values Array or comma delimited string of selected values
+ * @since 1.0
+ * @access public
+ * @return void
+ * @throws
+ */
+ function setSelectedValues($values)
+ {
+ if (is_string($values)) {
+ $values = split("[ ]?,[ ]?", $values);
+ }
+ $this->_values = $values;
+ }
+
+ /**
+ * Returns an array of the selected values
+ *
+ * @since 1.0
+ * @access public
+ * @return array of selected values
+ * @throws
+ */
+ function getSelectedValues()
+ {
+ return $this->_values;
+ }
+
+ /**
+ * Adds a new OPTION to the SELECT
+ *
+ * @param string $text Display text for the OPTION
+ * @param string $value Value for the OPTION
+ * @param bool $selected Whether the option is selected or not
+ * @param mixed $attributes Either a typical HTML attribute string
+ * or an associative array
+ * @since 1.0
+ * @access public
+ * @return void
+ * @throws
+ */
+ function addOption($text, $value, $selected = false, $attributes = null)
+ {
+ if ($selected && !in_array($value, $this->_values)) {
+ $this->_values[] = $value;
+ }
+
+ $attributes = $this->_parseAttributes($attributes);
+ $attr['value'] = $value;
+ $this->_updateAttrArray($attributes, $attr);
+ $this->_options[] = array('text' => $text, 'attr' => $attributes);
+ }
+
+ /**
+ * Loads the options from an associative array
+ *
+ * @param array $arr Associative array of options
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.0
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function loadArray($arr, $values=null)
+ {
+ if (!is_array($arr)) {
+ return new PEAR_ERROR('First argument to HTML_Select::loadArray is not a valid array');
+ }
+ if (isset($values)) {
+ $this->setSelectedValues($values);
+ }
+ while (list($key, $value) = each($arr)) {
+ $this->addOption($key, $value);
+ }
+ return true;
+ }
+
+ /**
+ * Loads the options from an array with numeric keys, using the
+ * array values as the form values as well as labels.
+ *
+ * @param array $arr Array of options
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.2
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function loadValueArray($arr, $values = null)
+ {
+ if (!is_array($arr)) {
+ return new PEAR_ERROR("First argument to HTML_Select::loadArray is not a valid array");
+ }
+ if (isset($values)) {
+ $this->setSelectedValues($values);
+ }
+ foreach ($arr as $value) {
+ $this->addOption($value, $value);
+ }
+ return true;
+ }
+
+ /**
+ * Loads the options from DB_result object
+ *
+ * If no column names are specified the first two columns of the result are
+ * used as the text and value columns respectively
+ * @param object $result DB_result object
+ * @param string $textCol (optional) Name of column to display as the OPTION text
+ * @param string $valueCol (optional) Name of column to use as the OPTION value
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.0
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function loadDbResult(&$result, $textCol=null, $valueCol=null, $values=null)
+ {
+ include_once 'DB.php';
+
+ if (!is_object($result) || (get_class($result) != "db_result" &&
+ is_subclass_of($result, "db_result"))) {
+ return new PEAR_ERROR("First argument to HTML_Select::loadDbResult is not a valid DB_result");
+ }
+ if (isset($values)) {
+ $this->setSelectedValues($values);
+ }
+ $fetchMode = ($textCol && $valueCol) ? DB_FETCHMODE_ASSOC : DB_FETCHMODE_DEFAULT;
+ while (is_array($row = $result->fetchRow($fetchMode)) ) {
+ if ($fetchMode == DB_FETCHMODE_ASSOC) {
+ $this->addOption($row[$textCol], $row[$valueCol]);
+ } else {
+ $this->addOption($row[0], $row[1]);
+ }
+ }
+ return true;
+ }
+
+ /**
+ * Queries a database and loads the options from the results
+ *
+ * @param mixed $conn Either an existing DB connection or a valid dsn
+ * @param string $sql SQL query string
+ * @param string $textCol (optional) Name of column to display as the OPTION text
+ * @param string $valueCol (optional) Name of column to use as the OPTION value
+ * @param mixed $values (optional) Array or comma delimited string of selected values
+ * @since 1.1
+ * @access private
+ * @return void
+ * @throws
+ */
+ function loadQuery(&$conn, $sql, $textCol=null, $valueCol=null, $values=null)
+ {
+ include_once 'DB.php';
+
+ if (is_string($conn)) {
+ $dbConn = &DB::connect($conn, true);
+ if (DB::isError($dbConn)) return $dbConn;
+ } elseif (is_subclass_of($conn, "db_common")) {
+ $dbConn = $conn;
+ } else {
+ return new PEAR_Error("Argument 1 of HTML_Select::loadQuery is not a valid type");
+ }
+ $result = @$dbConn->query($sql);
+ if (DB::isError($result)) return $result;
+ return $this->loadDbResult($result, $textCol, $valueCol, $values);
+ }
+
+ /**
+ * Loads options from different types of data sources
+ *
+ * This method is a simulated overloaded method. The arguments, other than the
+ * first are optional and only mean something depending on the type of the first argument.
+ * If the first argument is an array then all arguments are passed in order to loadArray.
+ * If the first argument is a db_result then all arguments are passed in order to loadDbResult.
+ * If the first argument is a string or a DB connection then all arguments are
+ * passed in order to loadQuery.
+ * @param mixed $options Options source currently supports assoc array or DB_result
+ * @param mixed $param1 (optional) See function detail
+ * @param mixed $param2 (optional) See function detail
+ * @param mixed $param3 (optional) See function detail
+ * @param mixed $param4 (optional) See function detail
+ * @since 1.1
+ * @access public
+ * @return PEAR_Error on error or true
+ * @throws PEAR_Error
+ */
+ function load(&$options, $param1=null, $param2=null, $param3=null, $param4=null)
+ {
+ switch (true) {
+ case is_array($options):
+ return $this->loadArray($options, $param1);
+ break;
+ case (get_class($options) == "db_result" || is_subclass_of($options, "db_result")):
+ return $this->loadDbResult($options, $param1, $param2, $param3);
+ break;
+ case (is_string($options) || is_subclass_of($options, "db_common")):
+ return $this->loadQuery($options, $param1, $param2, $param3, $param4);
+ break;
+ }
+ }
+
+ /**
+ * Returns the SELECT in HTML
+ *
+ * @since 1.0
+ * @access public
+ * @return string
+ * @throws
+ */
+ function toHtml()
+ {
+ $tabs = $this->_getTabs();
+ $name = $this->_attributes['name'];
+ $strHtml = $tabs;
+ if ($this->_comment) {
+ $strHtml .= "<!-- $this->_comment -->\n$tabs";
+ }
+ $strHtml .=
+ '<select' . $this->_getAttrString($this->_attributes) . '>';
+ foreach ($this->_options as $option) {
+ if (@in_array($option['attr']['value'], $this->_values)) {
+ $option['attr']['selected'] = 'selected';
+ }
+ $attrString = $this->_getAttrString($option['attr']);
+ $strHtml .=
+ '<option' . $attrString . '>' .
+ htmlspecialchars($option['text']) . '</option>';
+ }
+ $strHtml .= '</select>';
+ return $strHtml;
+ }
+
+}
+?>
diff --git a/devel/pear-HTML_Select_Common/pkg-comment b/devel/pear-HTML_Select_Common/pkg-comment
new file mode 100644
index 000000000000..6a6c56728be5
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/pkg-comment
@@ -0,0 +1 @@
+Some small PEAR classes to handle common <select> lists
diff --git a/devel/pear-HTML_Select_Common/pkg-descr b/devel/pear-HTML_Select_Common/pkg-descr
new file mode 100644
index 000000000000..4929a54c9d9f
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/pkg-descr
@@ -0,0 +1,6 @@
+Provides <select> lists for:
+o Country
+o UK counties
+o US States
+
+WWW: http://pear.php.net/package-info.php?pacid=58
diff --git a/devel/pear-HTML_Select_Common/pkg-plist b/devel/pear-HTML_Select_Common/pkg-plist
new file mode 100644
index 000000000000..9f094ae340a9
--- /dev/null
+++ b/devel/pear-HTML_Select_Common/pkg-plist
@@ -0,0 +1,9 @@
+%%PEARDIR%%/HTML/Select.php
+%%PEARDIR%%/HTML/Select/Country.php
+%%PEARDIR%%/HTML/Select/UKCounty.php
+%%PEARDIR%%/HTML/Select/USState.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/Country.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/UKCounty.php
+%%PORTDOCS%%%%EXAMPLESDIR%%/USState.php
+@dirrm %%PEARDIR%%/HTML/Select
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%