aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-02-13 17:45:24 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-02-13 17:45:24 +0800
commit4ee9b26054daa221c19e549d555d9e9d0ecbf639 (patch)
treeb2b1248e0cc28b0073419caf03e1045cb217bb6e /devel
parent4d92770eea073094f48896f69029f6106d8265e6 (diff)
downloadfreebsd-ports-gnome-4ee9b26054daa221c19e549d555d9e9d0ecbf639.tar.gz
freebsd-ports-gnome-4ee9b26054daa221c19e549d555d9e9d0ecbf639.tar.zst
freebsd-ports-gnome-4ee9b26054daa221c19e549d555d9e9d0ecbf639.zip
- Add p5-Form-Sensible 0.20023
Form::Sensible is a different kind of form library. Form::Sensible is not just another HTML form creator, or a form validator, though it can do both. Form::Sensible, instead, focuses on what forms are: a method to relay information to and from a user interface. Form::Sensible forms are primarily tied to the data they represent. Form::Sensible is not tied to HTML in any way. You could render Form::Sensible forms using any presentation system you like, whether that's HTML, console prompts, WxPerl or voice prompts. (* currently only an HTML renderer is provided with Form::Sensible, but work is already under way to produce others.) Features: - Easy form validation - Ability to easily save created forms for future use - Define form once, render any number of ways - Flexible built-in form validator - Easily extended to produce new renderers, field types and validation - HTML renderer produces sane html that can be easily styled via CSS - HTML renderer allows for custom templates to control all aspects of form rendering. - HTML output not tied to any javascript library. WWW: http://search.cpan.org/dist/Form-Sensible/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Form-Sensible/Makefile58
-rw-r--r--devel/p5-Form-Sensible/distinfo2
-rw-r--r--devel/p5-Form-Sensible/pkg-descr23
-rw-r--r--devel/p5-Form-Sensible/pkg-plist63
5 files changed, 147 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3155950219d4..6ad81ecff90c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1815,6 +1815,7 @@
SUBDIR += p5-Find-Lib
SUBDIR += p5-FindBin-libs
SUBDIR += p5-Forest
+ SUBDIR += p5-Form-Sensible
SUBDIR += p5-FreeBSD-i386-Ptrace
SUBDIR += p5-FreezeThaw
SUBDIR += p5-Gearman
diff --git a/devel/p5-Form-Sensible/Makefile b/devel/p5-Form-Sensible/Makefile
new file mode 100644
index 000000000000..38a1d9abd3ba
--- /dev/null
+++ b/devel/p5-Form-Sensible/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: p5-Form-Sensible
+# Date created: 2012-02-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Form-Sensible
+PORTVERSION= 0.20.023
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A sensible way to handle form based user interface
+
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Format-Natural>=0:${PORTSDIR}/devel/p5-DateTime-Format-Natural \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set \
+ p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Form::Sensible.3 \
+ Form::Sensible::DelegateConnection.3 \
+ Form::Sensible::Delegation.3 \
+ Form::Sensible::FAQ.3 \
+ Form::Sensible::Field.3 \
+ Form::Sensible::Field::DateTime.3 \
+ Form::Sensible::Field::FileSelector.3 \
+ Form::Sensible::Field::LongText.3 \
+ Form::Sensible::Field::Number.3 \
+ Form::Sensible::Field::Select.3 \
+ Form::Sensible::Field::SubForm.3 \
+ Form::Sensible::Field::Text.3 \
+ Form::Sensible::Field::Toggle.3 \
+ Form::Sensible::Field::Trigger.3 \
+ Form::Sensible::Form.3 \
+ Form::Sensible::Overview.3 \
+ Form::Sensible::Reflector.3 \
+ Form::Sensible::Renderer.3 \
+ Form::Sensible::Renderer::HTML.3 \
+ Form::Sensible::Renderer::HTML::RenderedForm.3 \
+ Form::Sensible::Validator.3 \
+ Form::Sensible::Validator::Result.3
+
+post-extract:
+ @${RM} ${WRKSRC}/lib/Form/Sensible/Renderer/HTML/RenderedForm.pm.orig
+
+#post-patch:
+# @${REINPLACE_CMD} -e 's|Form-Sensible|Form::Sensible|' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Form-Sensible/distinfo b/devel/p5-Form-Sensible/distinfo
new file mode 100644
index 000000000000..dac48815b8e5
--- /dev/null
+++ b/devel/p5-Form-Sensible/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Form-Sensible-0.20023.tar.gz) = 35c5523ce75307706400488402a2bf3064bb5acd527823ff2c66077e0bf7faaf
+SIZE (Form-Sensible-0.20023.tar.gz) = 83584
diff --git a/devel/p5-Form-Sensible/pkg-descr b/devel/p5-Form-Sensible/pkg-descr
new file mode 100644
index 000000000000..3ded55dd2aef
--- /dev/null
+++ b/devel/p5-Form-Sensible/pkg-descr
@@ -0,0 +1,23 @@
+Form::Sensible is a different kind of form library. Form::Sensible is not just
+another HTML form creator, or a form validator, though it can do both.
+Form::Sensible, instead, focuses on what forms are: a method to relay
+information to and from a user interface.
+
+Form::Sensible forms are primarily tied to the data they represent.
+Form::Sensible is not tied to HTML in any way. You could render Form::Sensible
+forms using any presentation system you like, whether that's HTML, console
+prompts, WxPerl or voice prompts. (* currently only an HTML renderer is provided
+with Form::Sensible, but work is already under way to produce others.)
+
+Features:
+- Easy form validation
+- Ability to easily save created forms for future use
+- Define form once, render any number of ways
+- Flexible built-in form validator
+- Easily extended to produce new renderers, field types and validation
+- HTML renderer produces sane html that can be easily styled via CSS
+- HTML renderer allows for custom templates to control all aspects of form
+ rendering.
+- HTML output not tied to any javascript library.
+
+WWW: http://search.cpan.org/dist/Form-Sensible/
diff --git a/devel/p5-Form-Sensible/pkg-plist b/devel/p5-Form-Sensible/pkg-plist
new file mode 100644
index 000000000000..dfd10276e452
--- /dev/null
+++ b/devel/p5-Form-Sensible/pkg-plist
@@ -0,0 +1,63 @@
+%%SITE_PERL%%/Form/Sensible.pm
+%%SITE_PERL%%/Form/Sensible/DelegateConnection.pm
+%%SITE_PERL%%/Form/Sensible/Delegation.pod
+%%SITE_PERL%%/Form/Sensible/FAQ.pod
+%%SITE_PERL%%/Form/Sensible/Field.pm
+%%SITE_PERL%%/Form/Sensible/Field/DateTime.pm
+%%SITE_PERL%%/Form/Sensible/Field/FileSelector.pm
+%%SITE_PERL%%/Form/Sensible/Field/LongText.pm
+%%SITE_PERL%%/Form/Sensible/Field/Number.pm
+%%SITE_PERL%%/Form/Sensible/Field/Select.pm
+%%SITE_PERL%%/Form/Sensible/Field/SubForm.pm
+%%SITE_PERL%%/Form/Sensible/Field/Text.pm
+%%SITE_PERL%%/Form/Sensible/Field/Toggle.pm
+%%SITE_PERL%%/Form/Sensible/Field/Trigger.pm
+%%SITE_PERL%%/Form/Sensible/Form.pm
+%%SITE_PERL%%/Form/Sensible/Overview.pod
+%%SITE_PERL%%/Form/Sensible/Reflector.pm
+%%SITE_PERL%%/Form/Sensible/Renderer.pm
+%%SITE_PERL%%/Form/Sensible/Renderer/HTML.pm
+%%SITE_PERL%%/Form/Sensible/Renderer/HTML/RenderedForm.pm
+%%SITE_PERL%%/Form/Sensible/Validator.pm
+%%SITE_PERL%%/Form/Sensible/Validator/Result.pm
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/datetime.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/field_wrapper.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/fileselector.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/form_end.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/form_messages.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/form_start.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/hidden.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/longtext.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/number.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/password.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/pre_process.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/select.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/subform_end.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/subform_messages.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/subform_start.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/text.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/toggle.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/trigger.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default/unknown.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/field_wrapper.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/form_end.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/form_messages.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/form_start.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/subform_end.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/subform_messages.tt
+%%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table/subform_start.tt
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Form/Sensible/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Form/Sensible
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Form
+@dirrm %%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/table
+@dirrm %%SITE_PERL%%/auto/share/dist/Form-Sensible/templates/default
+@dirrm %%SITE_PERL%%/auto/share/dist/Form-Sensible/templates
+@dirrm %%SITE_PERL%%/auto/share/dist/Form-Sensible
+@dirrmtry %%SITE_PERL%%/auto/share/dist
+@dirrmtry %%SITE_PERL%%/auto/share
+@dirrm %%SITE_PERL%%/Form/Sensible/Validator
+@dirrm %%SITE_PERL%%/Form/Sensible/Renderer/HTML
+@dirrm %%SITE_PERL%%/Form/Sensible/Renderer
+@dirrm %%SITE_PERL%%/Form/Sensible/Field
+@dirrm %%SITE_PERL%%/Form/Sensible
+@dirrmtry %%SITE_PERL%%/Form