aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-21 09:51:44 +0800
committermiwi <miwi@FreeBSD.org>2014-02-21 09:51:44 +0800
commit5801195a0f4890280380b0fe9912259f1254754c (patch)
tree8106c155bf6f0eb31cdb5750452c43c2faa00b42 /devel
parent0afaa65bc36d3ef540611c7aac0e4c449c4149b5 (diff)
downloadfreebsd-ports-gnome-5801195a0f4890280380b0fe9912259f1254754c.tar.gz
freebsd-ports-gnome-5801195a0f4890280380b0fe9912259f1254754c.tar.zst
freebsd-ports-gnome-5801195a0f4890280380b0fe9912259f1254754c.zip
- Stage support
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-ncurses/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/devel/ruby-ncurses/Makefile b/devel/ruby-ncurses/Makefile
index 260b1f3b1047..86c1bd800a4f 100644
--- a/devel/ruby-ncurses/Makefile
+++ b/devel/ruby-ncurses/Makefile
@@ -22,15 +22,12 @@ INSTALL_TARGET= site-install
DOCS= COPYING Changes README THANKS TODO
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_MODEXAMPLESDIR}/
-.endif
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.include <bsd.port.mk>