aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-21 23:19:44 +0800
committerantoine <antoine@FreeBSD.org>2014-09-21 23:19:44 +0800
commit5af9208bea299bba70cf40e55688a625bc0d90c3 (patch)
treee6a990d7499da16587e6397be97490c54f204355 /devel
parent5c862f49c709572fca983fa46ca06a605251a362 (diff)
downloadfreebsd-ports-gnome-5af9208bea299bba70cf40e55688a625bc0d90c3.tar.gz
freebsd-ports-gnome-5af9208bea299bba70cf40e55688a625bc0d90c3.tar.zst
freebsd-ports-gnome-5af9208bea299bba70cf40e55688a625bc0d90c3.zip
- Allow staging as a regular user
- Bump portrevision as files were not packaged with intended owner
Diffstat (limited to 'devel')
-rw-r--r--devel/gitphp/Makefile8
-rw-r--r--devel/gitphp/pkg-plist4
2 files changed, 7 insertions, 5 deletions
diff --git a/devel/gitphp/Makefile b/devel/gitphp/Makefile
index 54d3cd25be41..86ba1ed44585 100644
--- a/devel/gitphp/Makefile
+++ b/devel/gitphp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gitphp
PORTVERSION= 0.2.8
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= http://www.gitphp.org/attachments/download/47/
@@ -15,6 +16,7 @@ USE_PHP= bz2 fileinfo mbstring memcache posix simplexml spl zlib
WANT_PHP_WEB= yes
NO_BUILD= yes
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/xdiff.so:${PORTSDIR}/textproc/pecl-xdiff
@@ -22,11 +24,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/xdiff.so:${PORTSDIR}/textproc/
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC} \
- && ${COPYTREE_SHARE} \* ${STAGEDIR}${WWWDIR})
- ${CHOWN} -R www:www ${STAGEDIR}${WWWDIR}
+ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
${FIND} ${STAGEDIR}${WWWDIR} -type f -exec ${CHMOD} 644 '{}' +
-.if !defined(BATCH)
- @ ${CAT} ${PKGMESSAGE}
-.endif
.include <bsd.port.mk>
diff --git a/devel/gitphp/pkg-plist b/devel/gitphp/pkg-plist
index d7e9781a0d2e..64f51ee7d342 100644
--- a/devel/gitphp/pkg-plist
+++ b/devel/gitphp/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/config/gitphp.conf.defaults.php
%%WWWDIR%%/config/gitphp.conf.php.example
%%WWWDIR%%/config/projects.conf.php.example
@@ -798,3 +800,5 @@
@dirrm %%WWWDIR%%/config
@dirrm %%WWWDIR%%/cache
@dirrm %%WWWDIR%%
+@owner root
+@group wheel