aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2014-12-30 21:36:19 +0800
committerrm <rm@FreeBSD.org>2014-12-30 21:36:19 +0800
commit618dc2b5bf0403bd9d195fc3f7356167b4cc1c62 (patch)
treea2be085a868ff716df1a74f0af4245e546b5c6cd /devel
parentfcdce70f35b141cb231d16307226f96efeefd01c (diff)
downloadfreebsd-ports-gnome-618dc2b5bf0403bd9d195fc3f7356167b4cc1c62.tar.gz
freebsd-ports-gnome-618dc2b5bf0403bd9d195fc3f7356167b4cc1c62.tar.zst
freebsd-ports-gnome-618dc2b5bf0403bd9d195fc3f7356167b4cc1c62.zip
devel/py-twistedCore: add dependency on security/py-service_identity
- add dependency on security/py-service_identity. It fixes this warning when running deluge, for example: """ /usr/local/lib/python2.7/site-packages/twisted/internet/_sslverify.py:184: UserWarning: You do not have the service_identity module installed. Without the service_identity module and a recent enough pyOpenSSL tosupport it, Twisted can perform only rudimentary TLS client hostnameverification. Many valid certificate/hostname mappings may be rejected. verifyHostname, VerificationError = _selectVerifyImplementation() """ - define LICENSE_FILE - update comment - bump PORTREVISION because of dependency change
Diffstat (limited to 'devel')
-rw-r--r--devel/py-twistedCore/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/py-twistedCore/Makefile b/devel/py-twistedCore/Makefile
index f30dafa1c50c..b00d4a65dcbe 100644
--- a/devel/py-twistedCore/Makefile
+++ b/devel/py-twistedCore/Makefile
@@ -3,6 +3,7 @@
PORTNAME= twistedCore
PORTVERSION= 14.0.0
+PORTREVISION= 1
CATEGORIES= devel net python
MASTER_SITES= http://twistedmatrix.com/Releases/Core/${PORTVERSION:R}/ \
LOCAL/sunpoet
@@ -13,16 +14,18 @@ MAINTAINER= python@FreeBSD.org
COMMENT= Asynchronous networking framework for Python - Core module
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.6.0:${PORTSDIR}/devel/py-zope.interface
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>0:${PORTSDIR}/security/py-service_identity
# - Note that Twisted ships with some graphical examples and clients that
# require PyGNOME to run. These are not central to the funcitoning of
-# Twisted, but the user should feel free to install x11-toolits/py-gnome
+# Twisted, but the user should feel free to install x11-toolits/py-gnome2
# separately if desired.
USES= python:2 tar:bzip2
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
.include <bsd.port.mk>