aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-05 07:35:31 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-05 07:35:31 +0800
commit6613a32a58df736469f0aad3082243e4398b2a72 (patch)
tree40c9b8135cccc14632a650481c30eb8aada7d547 /devel
parentabb56069c21bde38c90d02610142c83e31804ae1 (diff)
downloadfreebsd-ports-gnome-6613a32a58df736469f0aad3082243e4398b2a72.tar.gz
freebsd-ports-gnome-6613a32a58df736469f0aad3082243e4398b2a72.tar.zst
freebsd-ports-gnome-6613a32a58df736469f0aad3082243e4398b2a72.zip
DirectX header files for use with MinGW. These header files are used by
the SDL project to compile SDL on Cygwin, but can also be used to compile native applications for Windows with MinGW. WWW: http://www.libsdl.org/extras/win32/cygwin/README.txt PR: ports/100836 Submitted by: Ed Schouten <ed at fxq.nl>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mingw32-directx/Makefile30
-rw-r--r--devel/mingw32-directx/distinfo3
-rw-r--r--devel/mingw32-directx/pkg-descr5
-rw-r--r--devel/mingw32-directx/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 58cff83801d9..7a5e868ba018 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -654,6 +654,7 @@
SUBDIR += mingw-opengl-headers
SUBDIR += mingw32-bin-msvcrt
SUBDIR += mingw32-binutils
+ SUBDIR += mingw32-directx
SUBDIR += mingw32-gcc
SUBDIR += mingw32-pdcurses
SUBDIR += mingw32-pthreads
diff --git a/devel/mingw32-directx/Makefile b/devel/mingw32-directx/Makefile
new file mode 100644
index 000000000000..06b2aa62d7c9
--- /dev/null
+++ b/devel/mingw32-directx/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mingw32-directx
+# Date created: 25 July 2006
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= directx
+PORTVERSION= 20020518
+CATEGORIES= devel
+MASTER_SITES= http://www.libsdl.org/extras/win32/cygwin/
+PKGNAMEPREFIX= mingw32-
+DISTNAME= ${PORTNAME}-devel
+
+MAINTAINER= ed@fxq.nl
+COMMENT= DirectX header files for use with MinGW
+
+BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
+ mingwm10.dll:${PORTSDIR}/devel/mingw32-bin-msvcrt
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+.for f in d3dtypes.h ddraw.h dinput.h directx.h dsound.h
+ ${INSTALL_DATA} ${WRKSRC}/include/w32api/$f \
+ ${LOCALBASE}/mingw32/include/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/mingw32-directx/distinfo b/devel/mingw32-directx/distinfo
new file mode 100644
index 000000000000..986ec2a9a682
--- /dev/null
+++ b/devel/mingw32-directx/distinfo
@@ -0,0 +1,3 @@
+MD5 (directx-devel.tar.gz) = d8080934f6d46080eda1f74dfb95b172
+SHA256 (directx-devel.tar.gz) = 0d5d61a23d9e51dbbf7661c2ed4abd147858ee409857245f6d1cc5f843aeb719
+SIZE (directx-devel.tar.gz) = 65222
diff --git a/devel/mingw32-directx/pkg-descr b/devel/mingw32-directx/pkg-descr
new file mode 100644
index 000000000000..002d7b29d8be
--- /dev/null
+++ b/devel/mingw32-directx/pkg-descr
@@ -0,0 +1,5 @@
+DirectX header files for use with MinGW. These header files are used by
+the SDL project to compile SDL on Cygwin, but can also be used to
+compile native applications for Windows with MinGW.
+
+WWW: http://www.libsdl.org/extras/win32/cygwin/README.txt
diff --git a/devel/mingw32-directx/pkg-plist b/devel/mingw32-directx/pkg-plist
new file mode 100644
index 000000000000..59a7a294b939
--- /dev/null
+++ b/devel/mingw32-directx/pkg-plist
@@ -0,0 +1,5 @@
+mingw32/include/d3dtypes.h
+mingw32/include/ddraw.h
+mingw32/include/dinput.h
+mingw32/include/directx.h
+mingw32/include/dsound.h