aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-04-29 21:53:26 +0800
committerjbeich <jbeich@FreeBSD.org>2015-04-29 21:53:26 +0800
commit688a46045bb6f2dd8a1514df142b4f31340ab7d1 (patch)
treecbf349551bab80ed2575e282c2af7dfabe801879 /devel
parent43745dd5154e6bb8ffe294a3d79ae37c279ed24e (diff)
downloadfreebsd-ports-gnome-688a46045bb6f2dd8a1514df142b4f31340ab7d1.tar.gz
freebsd-ports-gnome-688a46045bb6f2dd8a1514df142b4f31340ab7d1.tar.zst
freebsd-ports-gnome-688a46045bb6f2dd8a1514df142b4f31340ab7d1.zip
devel/onscripter: unbreak build against lang/lua53
LUAHandler.cpp:207:15: error: use of undeclared identifier 'luaL_checkint'; did you mean 'luaL_checkany'? int no = luaL_checkint( state, 1 ); ^~~~~~~~~~~~~ luaL_checkany /usr/local/include/lua53/lauxlib.h:52:18: note: 'luaL_checkany' declared here LUALIB_API void (luaL_checkany) (lua_State *L, int arg); ^ LUAHandler.cpp:207:9: error: cannot initialize a variable of type 'int' with an rvalue of type 'void' int no = luaL_checkint( state, 1 ); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~
Diffstat (limited to 'devel')
-rw-r--r--devel/onscripter/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/onscripter/Makefile b/devel/onscripter/Makefile
index ea6b56c8f654..32fb5b981b1b 100644
--- a/devel/onscripter/Makefile
+++ b/devel/onscripter/Makefile
@@ -46,6 +46,8 @@ post-patch:
.endif
@${REINPLACE_CMD} -e 's/$$(LIBS)/$$(LDFLAGS) &/' \
${WRKSRC}/Makefile.onscripter
+ @${REINPLACE_CMD} -e 's/luaL_checkint/(int)&eger/' \
+ ${WRKSRC}/LUAHandler.cpp
.if !target(do-install)
do-install: