aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-12-16 14:12:28 +0800
committeraz <az@FreeBSD.org>2012-12-16 14:12:28 +0800
commit6da7db56873e789b5619503b294318b9ddcb6d2b (patch)
tree384db2430847574aba884f9787c765d0f5311558 /devel
parentb742942ebdd434fcafc9fe8ac34e1a8bd7692555 (diff)
downloadfreebsd-ports-gnome-6da7db56873e789b5619503b294318b9ddcb6d2b.tar.gz
freebsd-ports-gnome-6da7db56873e789b5619503b294318b9ddcb6d2b.tar.zst
freebsd-ports-gnome-6da7db56873e789b5619503b294318b9ddcb6d2b.zip
- Set default perl version for ports which currently using
(5.x+ and x < 12) scheme. Approved by: bapt@ (portmgr@)
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-happy/Makefile2
-rw-r--r--devel/p5-BZ-Client/Makefile2
-rw-r--r--devel/p5-CPAN-Changes/Makefile2
-rw-r--r--devel/p5-CPANPLUS/Makefile1
-rw-r--r--devel/p5-Class-Accessor-Complex/Makefile1
-rw-r--r--devel/p5-Class-ReturnValue/Makefile2
-rw-r--r--devel/p5-Class-StateMachine/Makefile2
-rw-r--r--devel/p5-Config-Model/Makefile2
-rw-r--r--devel/p5-Data-Domain/Makefile2
-rw-r--r--devel/p5-Data-Miscellany/Makefile1
-rw-r--r--devel/p5-Data-Rmap/Makefile1
-rw-r--r--devel/p5-Devel-NYTProf/Makefile2
-rw-r--r--devel/p5-File-HomeDir-PathClass/Makefile2
-rw-r--r--devel/p5-Getopt-Attribute/Makefile1
-rw-r--r--devel/p5-IO-Async/Makefile2
-rw-r--r--devel/p5-Log-Dispatch-Dir/Makefile2
-rw-r--r--devel/p5-Module-Refresh/Makefile1
-rw-r--r--devel/p5-MooseX-App/Makefile2
-rw-r--r--devel/p5-Regexp-Grammars/Makefile2
-rw-r--r--devel/p5-Scalar-Does/Makefile2
-rw-r--r--devel/p5-ShipIt-Step-Manifest/Makefile1
-rw-r--r--devel/p5-Sub-Delete/Makefile1
-rw-r--r--devel/p5-Test-Block/Makefile1
-rw-r--r--devel/p5-Test-DependentModules/Makefile2
-rw-r--r--devel/p5-subversion/Makefile2
-rw-r--r--devel/p5-uni-perl/Makefile2
-rw-r--r--devel/svn_load_dirs/Makefile2
27 files changed, 16 insertions, 29 deletions
diff --git a/devel/hs-happy/Makefile b/devel/hs-happy/Makefile
index 724e48729740..77d761509f17 100644
--- a/devel/hs-happy/Makefile
+++ b/devel/hs-happy/Makefile
@@ -22,7 +22,7 @@ USE_AUTOTOOLS= autoconf:env
STANDALONE= yes
EXECUTABLE= happy
-USE_PERL5_BUILD= 5.8+
+USE_PERL5_BUILD= yes
INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
diff --git a/devel/p5-BZ-Client/Makefile b/devel/p5-BZ-Client/Makefile
index 9c764cef02b3..59e314ba006f 100644
--- a/devel/p5-BZ-Client/Makefile
+++ b/devel/p5-BZ-Client/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601
-PERL_CONFIGURE= 5.10.1+
+PERL_CONFIGURE= yes
MAN3= BZ::Client.3 BZ::Client::API.3 BZ::Client::Bug.3 \
BZ::Client::Bugzilla.3 BZ::Client::Exception.3 \
diff --git a/devel/p5-CPAN-Changes/Makefile b/devel/p5-CPAN-Changes/Makefile
index 5ab5351ae953..c55632a9a5e7 100644
--- a/devel/p5-CPAN-Changes/Makefile
+++ b/devel/p5-CPAN-Changes/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Read and write CPAN Changes files
-PERL_CONFIGURE= 5.10.0+
+PERL_CONFIGURE= yes
MAN3= CPAN::Changes.3 \
CPAN::Changes::Release.3 \
diff --git a/devel/p5-CPANPLUS/Makefile b/devel/p5-CPANPLUS/Makefile
index 566264139eb7..f7e7040e8477 100644
--- a/devel/p5-CPANPLUS/Makefile
+++ b/devel/p5-CPANPLUS/Makefile
@@ -17,7 +17,6 @@ COMMENT= Ameliorated interface to the CPAN
RUN_DEPENDS= p5-Module-Signature>=0:${PORTSDIR}/security/p5-Module-Signature
-USE_PERL5= 5.6.1+
PERL_CONFIGURE= yes
CONFIGURE_ARGS= AUTOINSTALL=1
INSTALL_TARGET= pure_install
diff --git a/devel/p5-Class-Accessor-Complex/Makefile b/devel/p5-Class-Accessor-Complex/Makefile
index 99d60b299ddb..915091b1f1a8 100644
--- a/devel/p5-Class-Accessor-Complex/Makefile
+++ b/devel/p5-Class-Accessor-Complex/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-USE_PERL5_RUN= 5.8.1+
MAN3= Class::Accessor::Complex.3
diff --git a/devel/p5-Class-ReturnValue/Makefile b/devel/p5-Class-ReturnValue/Makefile
index e3b168e4b22c..7e0bae69d45b 100644
--- a/devel/p5-Class-ReturnValue/Makefile
+++ b/devel/p5-Class-ReturnValue/Makefile
@@ -17,8 +17,6 @@ COMMENT= A return-value object that can be treated as a boolean, array, or objec
BUILD_DEPENDS= p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= 5.8.0+
-USE_PERL5_REASON= fails tests with 5.6.X
PERL_CONFIGURE= yes
MAN3= Class::ReturnValue.3
diff --git a/devel/p5-Class-StateMachine/Makefile b/devel/p5-Class-StateMachine/Makefile
index ed880288f78f..7e30fb1d8510 100644
--- a/devel/p5-Class-StateMachine/Makefile
+++ b/devel/p5-Class-StateMachine/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= p5-MRO-Define>=0.01:${PORTSDIR}/devel/p5-MRO-Define \
p5-Sub-Name>=0.05:${PORTSDIR}/devel/p5-Sub-Name
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.10.1+
+PERL_CONFIGURE= yes
MAN3= Class::StateMachine.3
diff --git a/devel/p5-Config-Model/Makefile b/devel/p5-Config-Model/Makefile
index f7a58bf76725..356dbf03f4d4 100644
--- a/devel/p5-Config-Model/Makefile
+++ b/devel/p5-Config-Model/Makefile
@@ -47,7 +47,7 @@ TEST_DEPENDS= p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Test-Memory-Cycle>=0:${PORTSDIR}/devel/p5-Test-Memory-Cycle \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
-PERL_MODBUILD= 5.10.1+
+PERL_MODBUILD= yes
MAN1= cme.1 config-edit.1
MAN3= Config::Model.3 \
diff --git a/devel/p5-Data-Domain/Makefile b/devel/p5-Data-Domain/Makefile
index 6a70c98487d6..3b05c15deb95 100644
--- a/devel/p5-Data-Domain/Makefile
+++ b/devel/p5-Data-Domain/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_MODBUILD= 5.10.1+
+PERL_MODBUILD= yes
MAN3= Data::Domain.3
diff --git a/devel/p5-Data-Miscellany/Makefile b/devel/p5-Data-Miscellany/Makefile
index dc91ab202488..0f67e6a85fb5 100644
--- a/devel/p5-Data-Miscellany/Makefile
+++ b/devel/p5-Data-Miscellany/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= gslin@gslin.org
COMMENT= Collection of miscellaneous subroutines
PERL_CONFIGURE= yes
-USE_PERL5_RUN= 5.8.1+
MAN3= Data::Miscellany.3
diff --git a/devel/p5-Data-Rmap/Makefile b/devel/p5-Data-Rmap/Makefile
index c3422811566d..42accc94af98 100644
--- a/devel/p5-Data-Rmap/Makefile
+++ b/devel/p5-Data-Rmap/Makefile
@@ -17,7 +17,6 @@ COMMENT= Recursive map, apply a block to a data structure
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
PERL_MODBUILD= yes
-USE_PERL5_RUN= 5.8.1+
MAN3= Data::Rmap.3
diff --git a/devel/p5-Devel-NYTProf/Makefile b/devel/p5-Devel-NYTProf/Makefile
index 74f5710d7f34..01e76611521e 100644
--- a/devel/p5-Devel-NYTProf/Makefile
+++ b/devel/p5-Devel-NYTProf/Makefile
@@ -16,8 +16,6 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= 5.8.1+
-
PERL_CONFIGURE= yes
MAN1= nytprofhtml.1 \
diff --git a/devel/p5-File-HomeDir-PathClass/Makefile b/devel/p5-File-HomeDir-PathClass/Makefile
index ed4938dce45c..7d0809f13c27 100644
--- a/devel/p5-File-HomeDir-PathClass/Makefile
+++ b/devel/p5-File-HomeDir-PathClass/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= p5-File-HomeDir>=0.93:${PORTSDIR}/devel/p5-File-HomeDir \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
-PERL_MODBUILD= 5.10.0+
+PERL_MODBUILD= yes
MAN3= File::HomeDir::PathClass.3
diff --git a/devel/p5-Getopt-Attribute/Makefile b/devel/p5-Getopt-Attribute/Makefile
index 7cc653d4c5ad..0303af137b6f 100644
--- a/devel/p5-Getopt-Attribute/Makefile
+++ b/devel/p5-Getopt-Attribute/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= gslin@gslin.org
COMMENT= Attribute wrapper for Getopt::Long
PERL_CONFIGURE= yes
-USE_PERL5_RUN= 5.8.1+
MAN3= Getopt::Attribute.3
diff --git a/devel/p5-IO-Async/Makefile b/devel/p5-IO-Async/Makefile
index 441975ac3acb..b6e892601416 100644
--- a/devel/p5-IO-Async/Makefile
+++ b/devel/p5-IO-Async/Makefile
@@ -27,7 +27,7 @@ TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Refcount>=0:${PORTSDIR}/devel/p5-Test-Refcount
-PERL_CONFIGURE= 5.10.0+
+PERL_CONFIGURE= yes
MAN3= IO::Async.3 \
IO::Async::Channel.3 \
diff --git a/devel/p5-Log-Dispatch-Dir/Makefile b/devel/p5-Log-Dispatch-Dir/Makefile
index 8815b11ca33c..d25c25e1d9e7 100644
--- a/devel/p5-Log-Dispatch-Dir/Makefile
+++ b/devel/p5-Log-Dispatch-Dir/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
p5-Probe-Perl>=0:${PORTSDIR}/sysutils/p5-Probe-Perl \
p5-Taint-Util>=0:${PORTSDIR}/devel/p5-Taint-Util
-PERL_MODBUILD= 5.10.0+
+PERL_MODBUILD= yes
MAN3= Log::Dispatch::Dir.3
diff --git a/devel/p5-Module-Refresh/Makefile b/devel/p5-Module-Refresh/Makefile
index 044554dbe05d..9f04b2034f81 100644
--- a/devel/p5-Module-Refresh/Makefile
+++ b/devel/p5-Module-Refresh/Makefile
@@ -20,7 +20,6 @@ BUILD_DEPENDS= p5-ExtUtils-MakeMaker>=6.42:${PORTSDIR}/devel/p5-ExtUtils-MakeMak
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-USE_PERL5= 5.8.1+
PERL_CONFIGURE= yes
MAN3= Module::Refresh.3
diff --git a/devel/p5-MooseX-App/Makefile b/devel/p5-MooseX-App/Makefile
index 31aa40b4061d..b254e813179d 100644
--- a/devel/p5-MooseX-App/Makefile
+++ b/devel/p5-MooseX-App/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most \
p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= 5.10.0+
+PERL_CONFIGURE= yes
MAN3= MooseX::App.3 \
MooseX::App::Command.3 \
diff --git a/devel/p5-Regexp-Grammars/Makefile b/devel/p5-Regexp-Grammars/Makefile
index 89860426181d..21e17b6f2b90 100644
--- a/devel/p5-Regexp-Grammars/Makefile
+++ b/devel/p5-Regexp-Grammars/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= Add grammatical parsing features to Perl 5.10 regexes
-PERL_MODBUILD= 5.10+
+PERL_MODBUILD= yes
MAN3= Regexp::Grammars.3
diff --git a/devel/p5-Scalar-Does/Makefile b/devel/p5-Scalar-Does/Makefile
index fa718e42e65d..976cc2a17402 100644
--- a/devel/p5-Scalar-Does/Makefile
+++ b/devel/p5-Scalar-Does/Makefile
@@ -23,7 +23,7 @@ TEST_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
# It requires UNIVERSAL::DOES on Perl 5.8
-PERL_CONFIGURE= 5.10+
+PERL_CONFIGURE= yes
MAN3= Scalar::Does.3 \
Scalar::Does::MooseTypes.3
diff --git a/devel/p5-ShipIt-Step-Manifest/Makefile b/devel/p5-ShipIt-Step-Manifest/Makefile
index 6d63f891cf5e..98d139fd1815 100644
--- a/devel/p5-ShipIt-Step-Manifest/Makefile
+++ b/devel/p5-ShipIt-Step-Manifest/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= p5-Dist-Joseki>=0:${PORTSDIR}/devel/p5-Dist-Joseki \
p5-ShipIt>=0:${PORTSDIR}/devel/p5-ShipIt
PERL_CONFIGURE= yes
-USE_PERL5_RUN= 5.8.1+
MAN3= ShipIt::Step::Manifest.3
diff --git a/devel/p5-Sub-Delete/Makefile b/devel/p5-Sub-Delete/Makefile
index 38b88c2dcbfe..768c03ee905a 100644
--- a/devel/p5-Sub-Delete/Makefile
+++ b/devel/p5-Sub-Delete/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module enabling one to delete subroutines
PERL_CONFIGURE= yes
-USE_PERL5= 5.8.3+
MAN3= Sub::Delete.3
diff --git a/devel/p5-Test-Block/Makefile b/devel/p5-Test-Block/Makefile
index 0ec769879766..9b9008c537a1 100644
--- a/devel/p5-Test-Block/Makefile
+++ b/devel/p5-Test-Block/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= p5-Test-Exception>=0.15:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Simple>=0.47:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= 5.6.1+
PERL_CONFIGURE= yes
MAN3= Test::Block.3
diff --git a/devel/p5-Test-DependentModules/Makefile b/devel/p5-Test-DependentModules/Makefile
index 438cf7e1e5d8..9ea49390ddde 100644
--- a/devel/p5-Test-DependentModules/Makefile
+++ b/devel/p5-Test-DependentModules/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny \
p5-autodie>=0:${PORTSDIR}/devel/p5-autodie
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= 5.10.1+ # CPAN>=1.9402
+PERL_CONFIGURE= yes
MAN3= Test::DependentModules.3
diff --git a/devel/p5-subversion/Makefile b/devel/p5-subversion/Makefile
index fed8fd24c22a..b06ad9decc5c 100644
--- a/devel/p5-subversion/Makefile
+++ b/devel/p5-subversion/Makefile
@@ -17,7 +17,7 @@ MASTERDIR= ${.CURDIR}/../../devel/subversion
.endif
PKGDIR= ${.CURDIR}
-USE_PERL5= 5.8.0+
+USE_PERL5= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/p5-uni-perl/Makefile b/devel/p5-uni-perl/Makefile
index 152c45a76a6a..bc1bce965879 100644
--- a/devel/p5-uni-perl/Makefile
+++ b/devel/p5-uni-perl/Makefile
@@ -20,6 +20,6 @@ RUN_DEPENDS= p5-Encode>=2.37:${PORTSDIR}/converters/p5-Encode \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= 5.10.0+
+PERL_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/devel/svn_load_dirs/Makefile b/devel/svn_load_dirs/Makefile
index 2178158097ff..04c0bd2e4bd0 100644
--- a/devel/svn_load_dirs/Makefile
+++ b/devel/svn_load_dirs/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion16
USE_BZIP2= yes
-USE_PERL5= 5.8.0+
+USE_PERL5= yes
WRKSRC= ${WRKDIR}/subversion-${SVN_PORTVERSION}/contrib/client-side/svn_load_dirs