aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-16 10:53:09 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-16 10:53:09 +0800
commit7410f137a21a1f9debe948652c8daf490d2bd055 (patch)
treeaaa3e23c274e989e79509ec1d1a48c3570b5f286 /devel
parent7366aadab8db7920381ee74871e005a4a26e9047 (diff)
downloadfreebsd-ports-gnome-7410f137a21a1f9debe948652c8daf490d2bd055.tar.gz
freebsd-ports-gnome-7410f137a21a1f9debe948652c8daf490d2bd055.tar.zst
freebsd-ports-gnome-7410f137a21a1f9debe948652c8daf490d2bd055.zip
This module marries App::Cmd with MooseX::Getopt.
Use it like App::Cmd advises (especially see App::Cmd::Tutorial), swapping App::Cmd::Command for MooseX::App::Cmd::Command. Then you can write your moose commands as moose classes, with MooseX::Getopt defining the options for you instead of opt_spec returning a Getopt::Long::Descriptive spec. WWW: http://search.cpan.org/dist/MooseX-App-Cmd/ PR: ports/ports/152164 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-App-Cmd/Makefile27
-rw-r--r--devel/p5-MooseX-App-Cmd/distinfo2
-rw-r--r--devel/p5-MooseX-App-Cmd/pkg-descr10
-rw-r--r--devel/p5-MooseX-App-Cmd/pkg-plist10
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2781cc925343..6ccf701ad84c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1902,6 +1902,7 @@
SUBDIR += p5-Moose-Autobox
SUBDIR += p5-Moose-Policy
SUBDIR += p5-MooseX-Aliases
+ SUBDIR += p5-MooseX-App-Cmd
SUBDIR += p5-MooseX-Async
SUBDIR += p5-MooseX-AttributeHelpers
SUBDIR += p5-MooseX-ClassAttribute
diff --git a/devel/p5-MooseX-App-Cmd/Makefile b/devel/p5-MooseX-App-Cmd/Makefile
new file mode 100644
index 000000000000..4b1902ec357f
--- /dev/null
+++ b/devel/p5-MooseX-App-Cmd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-MooseX-App-Cmd
+# Date created: 2010-11-12
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-App-Cmd
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Mashes up MooseX::Getopt and App::Cmd
+
+RUN_DEPENDS= p5-App-Cmd>=0.3:${PORTSDIR}/devel/p5-App-Cmd \
+ p5-Getopt-Long-Descriptive>=0:${PORTSDIR}/devel/p5-Getopt-Long-Descriptive \
+ p5-Moose>=0.86:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Getopt>=0.18:${PORTSDIR}/devel/p5-MooseX-Getopt
+
+PERL_CONFIGURE= yes
+
+MAN3= MooseX::App::Cmd.3 \
+ MooseX::App::Cmd::Command.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-App-Cmd/distinfo b/devel/p5-MooseX-App-Cmd/distinfo
new file mode 100644
index 000000000000..e17547351a4e
--- /dev/null
+++ b/devel/p5-MooseX-App-Cmd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MooseX-App-Cmd-0.06.tar.gz) = ea4c2b8adba1160cd31b36e17d1fe33ca6e31c30b9af51661627b5f9d987f7d1
+SIZE (MooseX-App-Cmd-0.06.tar.gz) = 6447
diff --git a/devel/p5-MooseX-App-Cmd/pkg-descr b/devel/p5-MooseX-App-Cmd/pkg-descr
new file mode 100644
index 000000000000..d658c0734777
--- /dev/null
+++ b/devel/p5-MooseX-App-Cmd/pkg-descr
@@ -0,0 +1,10 @@
+This module marries App::Cmd with MooseX::Getopt.
+
+Use it like App::Cmd advises (especially see App::Cmd::Tutorial),
+swapping App::Cmd::Command for MooseX::App::Cmd::Command.
+
+Then you can write your moose commands as moose classes, with
+MooseX::Getopt defining the options for you instead of opt_spec
+returning a Getopt::Long::Descriptive spec.
+
+WWW: http://search.cpan.org/dist/MooseX-App-Cmd/
diff --git a/devel/p5-MooseX-App-Cmd/pkg-plist b/devel/p5-MooseX-App-Cmd/pkg-plist
new file mode 100644
index 000000000000..2127b6b6f2ae
--- /dev/null
+++ b/devel/p5-MooseX-App-Cmd/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/App/Cmd/.packlist
+%%SITE_PERL%%/MooseX/App/Cmd.pm
+%%SITE_PERL%%/MooseX/App/Cmd/Command.pm
+@dirrmtry %%SITE_PERL%%/MooseX/App/Cmd
+@dirrmtry %%SITE_PERL%%/MooseX/App
+@dirrmtry %%SITE_PERL%%/MooseX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/App/Cmd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/App
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX