aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-05-15 02:28:25 +0800
committerrakuco <rakuco@FreeBSD.org>2013-05-15 02:28:25 +0800
commit75c2c1339843e5063cc48dd43fa1afb1f83c6c77 (patch)
tree3fc979a572e20ea3cacb864ea87e3c302cb813a2 /devel
parent0d442671de4baaab96edb557149f9443782414f0 (diff)
downloadfreebsd-ports-gnome-75c2c1339843e5063cc48dd43fa1afb1f83c6c77.tar.gz
freebsd-ports-gnome-75c2c1339843e5063cc48dd43fa1afb1f83c6c77.tar.zst
freebsd-ports-gnome-75c2c1339843e5063cc48dd43fa1afb1f83c6c77.zip
Add devel/libe.
It is a collection of high-performance data structures and utilities in C++. PR: ports/178626 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libe/Makefile22
-rw-r--r--devel/libe/distinfo2
-rw-r--r--devel/libe/files/patch-configure11
-rw-r--r--devel/libe/pkg-descr3
-rw-r--r--devel/libe/pkg-plist34
6 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d16a06e68bb9..d6996dab7bba 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -964,6 +964,7 @@
SUBDIR += libds
SUBDIR += libdsp
SUBDIR += libdwarf
+ SUBDIR += libe
SUBDIR += libedit
SUBDIR += libee
SUBDIR += libelf
diff --git a/devel/libe/Makefile b/devel/libe/Makefile
new file mode 100644
index 000000000000..16feb0faff02
--- /dev/null
+++ b/devel/libe/Makefile
@@ -0,0 +1,22 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= libe
+PORTVERSION= 0.3.1
+CATEGORIES= devel
+MASTER_SITES= http://hyperdex.org/src/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= High-performance datastructures and utilities for C++
+
+LICENSE= BSD
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libpo6.pc:${PORTSDIR}/devel/libpo6
+
+GNU_CONFIGURE= yes
+USES= pathfix pkgconfig
+USE_LDCONFIG= yes
+
+ONLY_FOR_ARCHS= amd64
+
+.include <bsd.port.mk>
diff --git a/devel/libe/distinfo b/devel/libe/distinfo
new file mode 100644
index 000000000000..26ddffb02054
--- /dev/null
+++ b/devel/libe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libe-0.3.1.tar.gz) = a10f9ee69a86094b83ed65c86243ab2e32bf134bffbafb9d6a8a2e152d6d914b
+SIZE (libe-0.3.1.tar.gz) = 378945
diff --git a/devel/libe/files/patch-configure b/devel/libe/files/patch-configure
new file mode 100644
index 000000000000..1115466009f1
--- /dev/null
+++ b/devel/libe/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-04-02 21:37:25.502367016 +0000
++++ configure 2013-04-02 21:37:55.951368743 +0000
+@@ -19251,7 +19251,7 @@
+ esac
+
+
+-if test x"${target_cpu}" != "xx86_64"; then
++if test x"${target_cpu}" != "xamd64"; then
+ as_fn_error $? "'this library requires a 64-bit x86 processor'" "$LINENO" 5
+ fi
+
diff --git a/devel/libe/pkg-descr b/devel/libe/pkg-descr
new file mode 100644
index 000000000000..04ebb187c932
--- /dev/null
+++ b/devel/libe/pkg-descr
@@ -0,0 +1,3 @@
+This is a library provide easier to write robust applications.
+
+WWW: https://github.com/rescrv/e
diff --git a/devel/libe/pkg-plist b/devel/libe/pkg-plist
new file mode 100644
index 000000000000..b9f3bd1a9ca2
--- /dev/null
+++ b/devel/libe/pkg-plist
@@ -0,0 +1,34 @@
+include/e/array_ptr.h
+include/e/assert.h
+include/e/atomic.h
+include/e/bitfield.h
+include/e/bitsteal.h
+include/e/buffer.h
+include/e/convert.h
+include/e/endian.h
+include/e/envconfig.h
+include/e/guard.h
+include/e/hazard_ptrs.h
+include/e/intrusive_ptr.h
+include/e/lockfree_fifo.h
+include/e/lockfree_hash_map.h
+include/e/lockfree_hash_set.h
+include/e/locking_fifo.h
+include/e/locking_iterable_fifo.h
+include/e/microbench.h
+include/e/nonblocking_bounded_fifo.h
+include/e/pow2.h
+include/e/profiler.h
+include/e/safe_math.h
+include/e/slice.h
+include/e/striped_lock.h
+include/e/time.h
+include/e/tuple_compare.h
+include/e/unpacker.h
+include/e/worker_barrier.h
+lib/libe.a
+lib/libe.la
+lib/libe.so
+lib/libe.so.0
+libdata/pkgconfig/libe.pc
+@dirrm include/e