aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrodrigc <rodrigc@FreeBSD.org>2005-06-13 01:51:34 +0800
committerrodrigc <rodrigc@FreeBSD.org>2005-06-13 01:51:34 +0800
commit772fbb7d66d1f7c20db3fc55c8a2e719699d021d (patch)
treea9f4be204397288efbabb8cd1506388054e20ff2 /devel
parent011524ffff697c6e6e3a5dfef25fe0584502d1d9 (diff)
downloadfreebsd-ports-gnome-772fbb7d66d1f7c20db3fc55c8a2e719699d021d.tar.gz
freebsd-ports-gnome-772fbb7d66d1f7c20db3fc55c8a2e719699d021d.tar.zst
freebsd-ports-gnome-772fbb7d66d1f7c20db3fc55c8a2e719699d021d.zip
Undo previous commit, which for some reason caused .la files to
be installed only if Python was not used in the build. Approved by: demon (ports mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/apr/Makefile11
-rw-r--r--devel/apr0/Makefile11
-rw-r--r--devel/apr1/Makefile11
-rw-r--r--devel/apr2/Makefile11
4 files changed, 4 insertions, 40 deletions
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index 823eaccd67aa..a846a64db23c 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -13,8 +13,6 @@
# (the database bindings are detected and recorded automatically if these
# switches are not set)
# APR_UTIL_WITH_LDAP: force dependency on OpenLDAP
-# WITH_PYTHON: force dependency on Python and run APR's buildconf.
-# Really only needed if built from APR's CVS depot.
PORTNAME= apr
PORTVERSION= 1.0.1
@@ -27,12 +25,6 @@ DISTFILES= apr-${PORTVERSION}.tar.gz apr-util-${PORTVERSION}.tar.gz
MAINTAINER= rodrigc@crodrigues.org
COMMENT= The Apache Group's Portability Library
-.if defined(WITH_PYTHON)
-BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
-USE_PYTHON= yes
-PYTHON_NO_DEPENDS= yes
-.endif
-
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
@@ -42,6 +34,7 @@ WANT_LIBTOOL_VER= 15
USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
+USE_PYTHON_BUILD= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -146,14 +139,12 @@ pre-configure:
.endfor
run-autotools:
-.if defined(WITH_PYTHON)
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
-.endif
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \
diff --git a/devel/apr0/Makefile b/devel/apr0/Makefile
index 823eaccd67aa..a846a64db23c 100644
--- a/devel/apr0/Makefile
+++ b/devel/apr0/Makefile
@@ -13,8 +13,6 @@
# (the database bindings are detected and recorded automatically if these
# switches are not set)
# APR_UTIL_WITH_LDAP: force dependency on OpenLDAP
-# WITH_PYTHON: force dependency on Python and run APR's buildconf.
-# Really only needed if built from APR's CVS depot.
PORTNAME= apr
PORTVERSION= 1.0.1
@@ -27,12 +25,6 @@ DISTFILES= apr-${PORTVERSION}.tar.gz apr-util-${PORTVERSION}.tar.gz
MAINTAINER= rodrigc@crodrigues.org
COMMENT= The Apache Group's Portability Library
-.if defined(WITH_PYTHON)
-BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
-USE_PYTHON= yes
-PYTHON_NO_DEPENDS= yes
-.endif
-
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
@@ -42,6 +34,7 @@ WANT_LIBTOOL_VER= 15
USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
+USE_PYTHON_BUILD= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -146,14 +139,12 @@ pre-configure:
.endfor
run-autotools:
-.if defined(WITH_PYTHON)
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
-.endif
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 823eaccd67aa..a846a64db23c 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -13,8 +13,6 @@
# (the database bindings are detected and recorded automatically if these
# switches are not set)
# APR_UTIL_WITH_LDAP: force dependency on OpenLDAP
-# WITH_PYTHON: force dependency on Python and run APR's buildconf.
-# Really only needed if built from APR's CVS depot.
PORTNAME= apr
PORTVERSION= 1.0.1
@@ -27,12 +25,6 @@ DISTFILES= apr-${PORTVERSION}.tar.gz apr-util-${PORTVERSION}.tar.gz
MAINTAINER= rodrigc@crodrigues.org
COMMENT= The Apache Group's Portability Library
-.if defined(WITH_PYTHON)
-BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
-USE_PYTHON= yes
-PYTHON_NO_DEPENDS= yes
-.endif
-
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
@@ -42,6 +34,7 @@ WANT_LIBTOOL_VER= 15
USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
+USE_PYTHON_BUILD= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -146,14 +139,12 @@ pre-configure:
.endfor
run-autotools:
-.if defined(WITH_PYTHON)
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
-.endif
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 823eaccd67aa..a846a64db23c 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -13,8 +13,6 @@
# (the database bindings are detected and recorded automatically if these
# switches are not set)
# APR_UTIL_WITH_LDAP: force dependency on OpenLDAP
-# WITH_PYTHON: force dependency on Python and run APR's buildconf.
-# Really only needed if built from APR's CVS depot.
PORTNAME= apr
PORTVERSION= 1.0.1
@@ -27,12 +25,6 @@ DISTFILES= apr-${PORTVERSION}.tar.gz apr-util-${PORTVERSION}.tar.gz
MAINTAINER= rodrigc@crodrigues.org
COMMENT= The Apache Group's Portability Library
-.if defined(WITH_PYTHON)
-BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
-USE_PYTHON= yes
-PYTHON_NO_DEPENDS= yes
-.endif
-
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
@@ -42,6 +34,7 @@ WANT_LIBTOOL_VER= 15
USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
+USE_PYTHON_BUILD= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -146,14 +139,12 @@ pre-configure:
.endfor
run-autotools:
-.if defined(WITH_PYTHON)
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
-.endif
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \