aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-10-05 03:49:56 +0800
committerjbeich <jbeich@FreeBSD.org>2016-10-05 03:49:56 +0800
commit7b236d0edc50c103683da25597dc28890ba6fd6b (patch)
treea0b37cb06c54ecb975a05b325c6e483e10ea5543 /devel
parent7c8e0beb3738cf87244a043fbc06e804ebd80cd1 (diff)
downloadfreebsd-ports-gnome-7b236d0edc50c103683da25597dc28890ba6fd6b.tar.gz
freebsd-ports-gnome-7b236d0edc50c103683da25597dc28890ba6fd6b.tar.zst
freebsd-ports-gnome-7b236d0edc50c103683da25597dc28890ba6fd6b.zip
devel/fb-adb: unbreak fetch for 64bit NDK
fetch: https://dl.google.com/android/ndk/android-ndk-r11c-linux-x86_64.zip: Not Found Note, :7z versus :zip sizes are $ du -Ah android-ndk-* 376M android-ndk-r10e-linux-x86.bin 1.0G android-ndk-r10e-linux-x86.zip 383M android-ndk-r10e-linux-x86_64.bin 1.0G android-ndk-r10e-linux-x86_64.zip 757M android-ndk-r11c-linux-x86_64.zip 721M android-ndk-r12b-linux-x86_64.zip
Diffstat (limited to 'devel')
-rw-r--r--devel/fb-adb/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index a61eeb27b586..1157c488038a 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -49,14 +49,15 @@ DEBUG_CONFIGURE_ENABLE= debuggable-stubs
# XXX Convert into USES=android once more things depend on it
NDK_DESC= Build target stubs using Android NDK
-NDK_MASTER_SITES= https://dl.google.com/android/ndk/:ndk,p7zip
+NDK_MASTER_SITES= https://dl.google.com/android/ndk/:7z \
+ https://dl.google.com/android/repository/:zip
.if defined(ANDROID_NDK)
# Prefer NDK from environment
WRKSRC_ndk= ${ANDROID_NDK}
.else
NDK_DISTFILES= ${NDK_DISTFILES_${LINUX_ARCH}}
-NDK_DISTFILES_i386= android-ndk-r10e-linux-x86.bin:ndk,p7zip
-NDK_DISTFILES_x86_64= android-ndk-r11c-linux-x86_64.zip:ndk
+NDK_DISTFILES_i386= android-ndk-r10e-linux-x86.bin:7z
+NDK_DISTFILES_x86_64= android-ndk-r11c-linux-x86_64.zip:zip
WRKSRC_ndk= ${WRKDIR}/${NDK_DISTFILES:R:C/(-[^-]+){2}$//}
.endif
NDK_USES= 7z:partial linux