aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-04-17 12:17:13 +0800
committerswills <swills@FreeBSD.org>2018-04-17 12:17:13 +0800
commit82adb47d9f7cef4d749d882ed1ff831ed4ee0ce5 (patch)
tree0476207c6fce6c8fb49dc8d2358477b390317dbd /devel
parent23644af67a4ce489dcb0bd2d4de96cbf48d9a663 (diff)
downloadfreebsd-ports-gnome-82adb47d9f7cef4d749d882ed1ff831ed4ee0ce5.tar.gz
freebsd-ports-gnome-82adb47d9f7cef4d749d882ed1ff831ed4ee0ce5.tar.zst
freebsd-ports-gnome-82adb47d9f7cef4d749d882ed1ff831ed4ee0ce5.zip
devel/py-python-gitlab: create port
python-gitlab is a Python package providing access to the GitLab server API. It supports the v3 and v4 APIs of GitLab, and provides a CLI tool (gitlab). WWW: https://github.com/python-gitlab/python-gitlab PR: 226290 Submitted by: dereks@lifeofadishwasher.com
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-python-gitlab/Makefile46
-rw-r--r--devel/py-python-gitlab/distinfo3
-rw-r--r--devel/py-python-gitlab/files/pkg-message.in4
-rw-r--r--devel/py-python-gitlab/pkg-descr5
5 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cdd82788a079..3464bdf3d8a5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4844,6 +4844,7 @@
SUBDIR += py-python-engineio
SUBDIR += py-python-gflags
SUBDIR += py-python-gist
+ SUBDIR += py-python-gitlab
SUBDIR += py-python-jenkins
SUBDIR += py-python-magic
SUBDIR += py-python-pcre
diff --git a/devel/py-python-gitlab/Makefile b/devel/py-python-gitlab/Makefile
new file mode 100644
index 000000000000..6b0288311b73
--- /dev/null
+++ b/devel/py-python-gitlab/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= python-gitlab
+PORTVERSION= 1.3.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dereks@lifeofadishwasher.com
+COMMENT= Interact with GitLab API
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.2:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httmock>0:www/py-httmock@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR}
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR}
+DOCS_PORTDOCS= *
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET=build_sphinx \
+ PYDISTUTILS_BUILDARGS="-n --all-files --fresh-env"
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist concurrent
+
+SUB_FILES= pkg-message
+
+do-test:
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}/etc|g' ${WRKSRC}/gitlab/config.py
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/build/sphinx/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objects.inv")
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/devel/py-python-gitlab/distinfo b/devel/py-python-gitlab/distinfo
new file mode 100644
index 000000000000..71c744029f7b
--- /dev/null
+++ b/devel/py-python-gitlab/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519965217
+SHA256 (python-gitlab-1.3.0.tar.gz) = 74ef4e98383043403d786d1719579b9a638666809b47d93a9fa8f0bd9f12ab84
+SIZE (python-gitlab-1.3.0.tar.gz) = 123955
diff --git a/devel/py-python-gitlab/files/pkg-message.in b/devel/py-python-gitlab/files/pkg-message.in
new file mode 100644
index 000000000000..fdcffd877a91
--- /dev/null
+++ b/devel/py-python-gitlab/files/pkg-message.in
@@ -0,0 +1,4 @@
+Add %%PREFIX%%/etc/python-gitlab.cfg or ~/.python-gitlab.cfg
+
+See https://github.com/python-gitlab/python-gitlab/blob/master/docs/cli.rst
+for CLI configutation details
diff --git a/devel/py-python-gitlab/pkg-descr b/devel/py-python-gitlab/pkg-descr
new file mode 100644
index 000000000000..348dc034b695
--- /dev/null
+++ b/devel/py-python-gitlab/pkg-descr
@@ -0,0 +1,5 @@
+python-gitlab is a Python package providing access to the GitLab server API.
+
+It supports the v3 and v4 APIs of GitLab, and provides a CLI tool (gitlab).
+
+WWW: https://github.com/python-gitlab/python-gitlab