aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-02-17 22:08:11 +0800
committerpawel <pawel@FreeBSD.org>2013-02-17 22:08:11 +0800
commit846e88edfc459f99f5e8f36cd02bc600260a0298 (patch)
tree4504a3c8e3a4f0ce558214b39cd3f692c996a248 /devel
parentc4dc59fb870976befd18375bb51aed17e70fff99 (diff)
downloadfreebsd-ports-gnome-846e88edfc459f99f5e8f36cd02bc600260a0298.tar.gz
freebsd-ports-gnome-846e88edfc459f99f5e8f36cd02bc600260a0298.tar.zst
freebsd-ports-gnome-846e88edfc459f99f5e8f36cd02bc600260a0298.zip
Crossroads I/O ("libxs") is a library for building scalable and high
performance distributed applications. It fits between classic BSD sockets, JMS/AMQP-style message queues, and enterprise message-oriented middleware. Crossroads I/O extends the standard socket interfaces with features traditionally provided by specialised messaging middleware products, providing an abstraction of asynchronous message queues, multiple messaging patterns, message filtering (subscriptions), seamless access to multiple transport protocols, and more. Crossroads I/O provides a native C API for applications. Support for many more languages is provided by the community through language bindings which can be found at the Crossroads website. WWW: http://www.crossroads.io/ PR: ports/175488 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libxs/Makefile110
-rw-r--r--devel/libxs/distinfo2
-rw-r--r--devel/libxs/pkg-descr15
-rw-r--r--devel/libxs/pkg-plist14
5 files changed, 142 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c3405fa880f5..a7834ad07493 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1110,6 +1110,7 @@
SUBDIR += libwfut
SUBDIR += libx86
SUBDIR += libxalloc
+ SUBDIR += libxs
SUBDIR += libytnef
SUBDIR += libzrtp
SUBDIR += libzrtpcpp
diff --git a/devel/libxs/Makefile b/devel/libxs/Makefile
new file mode 100644
index 000000000000..644921b337d8
--- /dev/null
+++ b/devel/libxs/Makefile
@@ -0,0 +1,110 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= libxs
+PORTVERSION= 1.2.0
+CATEGORIES= devel
+MASTER_SITES= http://download.crossroads.io/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Open source lightweight messaging layer
+
+GNU_CONFIGURE= yes
+USE_PKGCONFIG= build
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DEBUG DOCS PLUGINS ZMQ
+EXTERNAL_DESC= PGM extension from ports
+INTERNAL_DESC= PGM extension
+PLUGINS_DESC= Additional plugins
+ZMQ_DESC= Compatibility with ZMQ
+OPTIONS_RADIO= PGM
+OPTIONS_RADIO_PGM= INTERNAL EXTERNAL
+OPTIONS_DEFAULT=PLUGINS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ xmlto:${PORTSDIR}/textproc/xmlto
+
+MAN3= \
+ xs_bind.3 \
+ xs_close.3 \
+ xs_connect.3 \
+ xs_errno.3 \
+ xs_getmsgopt.3 \
+ xs_getsockopt.3 \
+ xs_init.3 \
+ xs_msg_close.3 \
+ xs_msg_copy.3 \
+ xs_msg_data.3 \
+ xs_msg_init.3 \
+ xs_msg_init_data.3 \
+ xs_msg_init_size.3 \
+ xs_msg_move.3 \
+ xs_msg_size.3 \
+ xs_poll.3 \
+ xs_recv.3 \
+ xs_recvmsg.3 \
+ xs_send.3 \
+ xs_sendmsg.3 \
+ xs_setctxopt.3 \
+ xs_setsockopt.3 \
+ xs_shutdown.3 \
+ xs_socket.3 \
+ xs_strerror.3 \
+ xs_term.3 \
+ xs_version.3
+
+MAN7= \
+ xs.7 \
+ xs_inproc.7 \
+ xs_ipc.7 \
+ xs_pgm.7 \
+ xs_tcp.7 \
+ xs_zmq.7
+.else
+CONFIGURE_ARGS+= --without-documentation
+.endif
+
+.if ${PORT_OPTIONS:MINTERNAL}
+CONFIGURE_ARGS+= --with-pgm
+USE_PERL5= yes
+CFLAGS+= -fPIC
+.endif
+
+.if ${PORT_OPTIONS:MEXTERNAL}
+CONFIGURE_ARGS+= --with-system-pgm
+LIB_DEPENDS+= pgm:${PORTSDIR}/net/openpgm
+.endif
+
+.if ${PORT_OPTIONS:MPLUGINS}
+CONFIGURE_ARGS+= --enable-plugins=yes
+.else
+CONFIGURE_ARGS+= --enable-plugins=no
+.endif
+
+.if ${PORT_OPTIONS:MZMQ}
+CONFIGURE_ARGS+= --enable-libzmq
+CONFLICTS= zmq-*
+PLIST_SUB+= ZMQ=""
+.else
+PLIST_SUB+= ZMQ="@comment "
+.endif
+
+pre-configure:
+# fix for clang build
+ @${REINPLACE_CMD} "/^libxs_werror=/ s|yes|no|" \
+ ${WRKSRC}/configure
+.if ${PORT_OPTIONS:MEXTERNAL}
+ ${REINPLACE_CMD} "s|openpgm-5.1|openpgm-5.2|g" \
+ ${WRKSRC}/configure
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libxs/distinfo b/devel/libxs/distinfo
new file mode 100644
index 000000000000..55717b389fa1
--- /dev/null
+++ b/devel/libxs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libxs-1.2.0.tar.gz) = 525dc999cc6524779bc4eef510e423077b7f7ea491cb3ad6d8056ecaf99ff515
+SIZE (libxs-1.2.0.tar.gz) = 1955426
diff --git a/devel/libxs/pkg-descr b/devel/libxs/pkg-descr
new file mode 100644
index 000000000000..7391fc21ba47
--- /dev/null
+++ b/devel/libxs/pkg-descr
@@ -0,0 +1,15 @@
+Crossroads I/O ("libxs") is a library for building scalable and high
+performance distributed applications. It fits between classic BSD sockets,
+JMS/AMQP-style message queues, and enterprise message-oriented middleware.
+
+Crossroads I/O extends the standard socket interfaces with features
+traditionally provided by specialised messaging middleware products,
+providing an abstraction of asynchronous message queues, multiple messaging
+patterns, message filtering (subscriptions), seamless access to multiple
+transport protocols, and more.
+
+Crossroads I/O provides a native C API for applications. Support for many
+more languages is provided by the community through language bindings which
+can be found at the Crossroads website.
+
+WWW: http://www.crossroads.io/
diff --git a/devel/libxs/pkg-plist b/devel/libxs/pkg-plist
new file mode 100644
index 000000000000..77085e8c042b
--- /dev/null
+++ b/devel/libxs/pkg-plist
@@ -0,0 +1,14 @@
+%%ZMQ%%include/zmq.h
+%%ZMQ%%include/zmq_utils.h
+%%ZMQ%%lib/libzmq.a
+%%ZMQ%%lib/libzmq.la
+%%ZMQ%%lib/libzmq.so
+%%ZMQ%%lib/libzmq.so.1
+%%ZMQ%%libdata/pkgconfig/libzmq.pc
+include/xs/xs.h
+lib/libxs.a
+lib/libxs.la
+lib/libxs.so
+lib/libxs.so.2
+libdata/pkgconfig/libxs.pc
+@dirrm include/xs