aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-01-09 22:12:19 +0800
committergarga <garga@FreeBSD.org>2009-01-09 22:12:19 +0800
commit84bfabd0f45a2e2ff6ce581bcfc0df724fb0bd73 (patch)
tree778f11ff8ae7233d36b39688edcbcf6bfa103b4d /devel
parent06cf89970ffc4696b5bb663f4a149e5c66697dce (diff)
downloadfreebsd-ports-gnome-84bfabd0f45a2e2ff6ce581bcfc0df724fb0bd73.tar.gz
freebsd-ports-gnome-84bfabd0f45a2e2ff6ce581bcfc0df724fb0bd73.tar.zst
freebsd-ports-gnome-84bfabd0f45a2e2ff6ce581bcfc0df724fb0bd73.zip
List::Uniq extracts the unique elements of a list.
This is a commonly re-written (or at least re-looked-up) idiom in Perl programs. WWW: http://search.cpan.org/dist/List-Uniq/ PR: ports/130322 Submitted by: Murilo Opsfelder <mopsfelder at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-List-Uniq/Makefile21
-rw-r--r--devel/p5-List-Uniq/distinfo3
-rw-r--r--devel/p5-List-Uniq/pkg-descr5
-rw-r--r--devel/p5-List-Uniq/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 980967c109bb..8f16541a5020 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1463,6 +1463,7 @@
SUBDIR += p5-List-Permutor
SUBDIR += p5-List-PowerSet
SUBDIR += p5-List-Rotation-Cycle
+ SUBDIR += p5-List-Uniq
SUBDIR += p5-Locale-Maketext
SUBDIR += p5-Locale-Maketext-Fuzzy
SUBDIR += p5-Locale-Maketext-Gettext
diff --git a/devel/p5-List-Uniq/Makefile b/devel/p5-List-Uniq/Makefile
new file mode 100644
index 000000000000..c9a193368037
--- /dev/null
+++ b/devel/p5-List-Uniq/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-List-Uniq
+# Date created: 2009-01-09
+# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= List-Uniq
+PORTVERSION= 0.12
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mopsfelder@gmail.com
+COMMENT= Extract the unique elements of a list
+
+PERL_CONFIGURE= yes
+
+MAN3= List::Uniq.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-List-Uniq/distinfo b/devel/p5-List-Uniq/distinfo
new file mode 100644
index 000000000000..8dd4ff113396
--- /dev/null
+++ b/devel/p5-List-Uniq/distinfo
@@ -0,0 +1,3 @@
+MD5 (List-Uniq-0.12.tar.gz) = afb38a5e514cbcba21c0b5591e6ebc8d
+SHA256 (List-Uniq-0.12.tar.gz) = cba510cd1b61a83d636f908e2c9d9333a670aa1ea79ef7dc950f666fca77aaef
+SIZE (List-Uniq-0.12.tar.gz) = 4981
diff --git a/devel/p5-List-Uniq/pkg-descr b/devel/p5-List-Uniq/pkg-descr
new file mode 100644
index 000000000000..7dec65a87bb6
--- /dev/null
+++ b/devel/p5-List-Uniq/pkg-descr
@@ -0,0 +1,5 @@
+List::Uniq extracts the unique elements of a list.
+This is a commonly re-written (or at least re-looked-up)
+idiom in Perl programs.
+
+WWW: http://search.cpan.org/dist/List-Uniq/
diff --git a/devel/p5-List-Uniq/pkg-plist b/devel/p5-List-Uniq/pkg-plist
new file mode 100644
index 000000000000..b58f1453db44
--- /dev/null
+++ b/devel/p5-List-Uniq/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Uniq/.packlist
+%%SITE_PERL%%/List/Uniq.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Uniq
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List
+@dirrmtry %%SITE_PERL%%/List