aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-05 21:34:22 +0800
committermiwi <miwi@FreeBSD.org>2007-06-05 21:34:22 +0800
commit8c7ab6b02804ba43ece8b1baf4db6df07d29b92b (patch)
tree8a9ffd4371bbccb5ec890c9eeae7dbc3a75c963c /devel
parent872571f22f389e513f69f3bedf98c640d182ec13 (diff)
downloadfreebsd-ports-gnome-8c7ab6b02804ba43ece8b1baf4db6df07d29b92b.tar.gz
freebsd-ports-gnome-8c7ab6b02804ba43ece8b1baf4db6df07d29b92b.tar.zst
freebsd-ports-gnome-8c7ab6b02804ba43ece8b1baf4db6df07d29b92b.zip
Device::USB, Perl wrappers for libusb. This
port is a dependency for others on the way regarding Lego Mindstorms NXT software. PR: ports/112605 Submitted by: Jason Bacon <bacon at smithers.neuro.mcw.edu>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Device-USB/Makefile34
-rw-r--r--devel/p5-Device-USB/distinfo3
-rw-r--r--devel/p5-Device-USB/pkg-descr3
-rw-r--r--devel/p5-Device-USB/pkg-plist23
-rw-r--r--devel/p5-usb/Makefile34
-rw-r--r--devel/p5-usb/distinfo3
-rw-r--r--devel/p5-usb/pkg-descr3
-rw-r--r--devel/p5-usb/pkg-plist23
9 files changed, 127 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03eeb68810bc..0058e64264b2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1632,6 +1632,7 @@
SUBDIR += p5-subatom
SUBDIR += p5-threads
SUBDIR += p5-threads-shared
+ SUBDIR += p5-usb
SUBDIR += p5-version
SUBDIR += p65
SUBDIR += pas2dox
diff --git a/devel/p5-Device-USB/Makefile b/devel/p5-Device-USB/Makefile
new file mode 100644
index 000000000000..82e5cf5b4524
--- /dev/null
+++ b/devel/p5-Device-USB/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-usb
+# Date created: 2007-05-05
+# Whom: Jason Bacon <bacon@smithers.neuro.mcw.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= usb
+PORTVERSION= 0.21
+CATEGORIES= devel
+MASTER_SITES= http://search.cpan.org/CPAN/authors/id/G/GW/GWADEJ/ \
+ http://personalpages.tds.net/~jwbacon/Ports/distfiles/
+PKGNAMEPREFIX= p5-
+DISTNAME= Device-USB-${PORTVERSION}
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Perl wrapper for libusb
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/5.8.8/Inline.pm:${PORTSDIR}/devel/p5-Inline
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+
+WRKSRC= ${WRKDIR}/Device-USB-0.21
+PERL_CONFIGURE= yes
+
+MAN3= Device::USB.3 \
+ Device::USB::Bus.3 \
+ Device::USB::DevConfig.3 \
+ Device::USB::DevEndpoint.3 \
+ Device::USB::DevInterface.3 \
+ Device::USB::Device.3 \
+ Device::USB::FAQ.3 \
+ Device::dump_usb.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Device-USB/distinfo b/devel/p5-Device-USB/distinfo
new file mode 100644
index 000000000000..a04b9a4d497b
--- /dev/null
+++ b/devel/p5-Device-USB/distinfo
@@ -0,0 +1,3 @@
+MD5 (Device-USB-0.21.tar.gz) = cdf87569bde86e8c2ec4335f8984b2bf
+SHA256 (Device-USB-0.21.tar.gz) = 65eb03d4962cfeec23334b49e5189fe88ce948fd76b046b61c98748ddb5c8163
+SIZE (Device-USB-0.21.tar.gz) = 27463
diff --git a/devel/p5-Device-USB/pkg-descr b/devel/p5-Device-USB/pkg-descr
new file mode 100644
index 000000000000..9efb3d4208ee
--- /dev/null
+++ b/devel/p5-Device-USB/pkg-descr
@@ -0,0 +1,3 @@
+Device::USB, Perl wrappers for libusb. This
+port is a dependency for others on the way regarding Lego
+Mindstorms NXT software.
diff --git a/devel/p5-Device-USB/pkg-plist b/devel/p5-Device-USB/pkg-plist
new file mode 100644
index 000000000000..cfe7d2f77641
--- /dev/null
+++ b/devel/p5-Device-USB/pkg-plist
@@ -0,0 +1,23 @@
+lib/perl5/site_perl/5.8.8/mach/Device/USB.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/Bus.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/DevConfig.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/DevEndpoint.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/DevInterface.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/Device.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/FAQ.pod
+lib/perl5/site_perl/5.8.8/mach/Device/dump_usb.pl
+lib/perl5/site_perl/5.8.8/mach/auto/Device/USB/.packlist
+lib/perl5/site_perl/5.8.8/mach/auto/Device/USB/USB.bs
+lib/perl5/site_perl/5.8.8/mach/auto/Device/USB/USB.so
+@dirrm lib/perl5/site_perl/5.8.8/mach/auto/Device/USB
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/auto/Device
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/auto
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/Device/USB
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/Device
+@dirrmtry lib/perl5/site_perl/5.8.8/mach
+@dirrmtry lib/perl5/site_perl/5.8.8
+@dirrmtry lib/perl5/site_perl
+@dirrmtry lib/perl5/5.8.8/man/man3
+@dirrmtry lib/perl5/5.8.8/man
+@dirrmtry lib/perl5/5.8.8
+@dirrmtry lib/perl5
diff --git a/devel/p5-usb/Makefile b/devel/p5-usb/Makefile
new file mode 100644
index 000000000000..82e5cf5b4524
--- /dev/null
+++ b/devel/p5-usb/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-usb
+# Date created: 2007-05-05
+# Whom: Jason Bacon <bacon@smithers.neuro.mcw.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= usb
+PORTVERSION= 0.21
+CATEGORIES= devel
+MASTER_SITES= http://search.cpan.org/CPAN/authors/id/G/GW/GWADEJ/ \
+ http://personalpages.tds.net/~jwbacon/Ports/distfiles/
+PKGNAMEPREFIX= p5-
+DISTNAME= Device-USB-${PORTVERSION}
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Perl wrapper for libusb
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/5.8.8/Inline.pm:${PORTSDIR}/devel/p5-Inline
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+
+WRKSRC= ${WRKDIR}/Device-USB-0.21
+PERL_CONFIGURE= yes
+
+MAN3= Device::USB.3 \
+ Device::USB::Bus.3 \
+ Device::USB::DevConfig.3 \
+ Device::USB::DevEndpoint.3 \
+ Device::USB::DevInterface.3 \
+ Device::USB::Device.3 \
+ Device::USB::FAQ.3 \
+ Device::dump_usb.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-usb/distinfo b/devel/p5-usb/distinfo
new file mode 100644
index 000000000000..a04b9a4d497b
--- /dev/null
+++ b/devel/p5-usb/distinfo
@@ -0,0 +1,3 @@
+MD5 (Device-USB-0.21.tar.gz) = cdf87569bde86e8c2ec4335f8984b2bf
+SHA256 (Device-USB-0.21.tar.gz) = 65eb03d4962cfeec23334b49e5189fe88ce948fd76b046b61c98748ddb5c8163
+SIZE (Device-USB-0.21.tar.gz) = 27463
diff --git a/devel/p5-usb/pkg-descr b/devel/p5-usb/pkg-descr
new file mode 100644
index 000000000000..9efb3d4208ee
--- /dev/null
+++ b/devel/p5-usb/pkg-descr
@@ -0,0 +1,3 @@
+Device::USB, Perl wrappers for libusb. This
+port is a dependency for others on the way regarding Lego
+Mindstorms NXT software.
diff --git a/devel/p5-usb/pkg-plist b/devel/p5-usb/pkg-plist
new file mode 100644
index 000000000000..cfe7d2f77641
--- /dev/null
+++ b/devel/p5-usb/pkg-plist
@@ -0,0 +1,23 @@
+lib/perl5/site_perl/5.8.8/mach/Device/USB.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/Bus.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/DevConfig.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/DevEndpoint.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/DevInterface.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/Device.pm
+lib/perl5/site_perl/5.8.8/mach/Device/USB/FAQ.pod
+lib/perl5/site_perl/5.8.8/mach/Device/dump_usb.pl
+lib/perl5/site_perl/5.8.8/mach/auto/Device/USB/.packlist
+lib/perl5/site_perl/5.8.8/mach/auto/Device/USB/USB.bs
+lib/perl5/site_perl/5.8.8/mach/auto/Device/USB/USB.so
+@dirrm lib/perl5/site_perl/5.8.8/mach/auto/Device/USB
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/auto/Device
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/auto
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/Device/USB
+@dirrmtry lib/perl5/site_perl/5.8.8/mach/Device
+@dirrmtry lib/perl5/site_perl/5.8.8/mach
+@dirrmtry lib/perl5/site_perl/5.8.8
+@dirrmtry lib/perl5/site_perl
+@dirrmtry lib/perl5/5.8.8/man/man3
+@dirrmtry lib/perl5/5.8.8/man
+@dirrmtry lib/perl5/5.8.8
+@dirrmtry lib/perl5