aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-10-09 23:20:04 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-10-09 23:20:04 +0800
commit9a0a69cbe0a87fc6a91d93887a8f54fbd3bf0b0f (patch)
treedfa3c249894b41af43b305bc65ed1fb7fb782b8e /devel
parent5967ba3e8a729a207ebd43e77510c59d07eb4f4e (diff)
downloadfreebsd-ports-gnome-9a0a69cbe0a87fc6a91d93887a8f54fbd3bf0b0f.tar.gz
freebsd-ports-gnome-9a0a69cbe0a87fc6a91d93887a8f54fbd3bf0b0f.tar.zst
freebsd-ports-gnome-9a0a69cbe0a87fc6a91d93887a8f54fbd3bf0b0f.zip
This modules exports the needed subtypes, and coercions for POEx
modules and is based on Sub::Exporter, so see that module for options on importing. WWW: http://search.cpan.org/dist/POEx-Types/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POEx-Types/Makefile28
-rw-r--r--devel/p5-POEx-Types/distinfo3
-rw-r--r--devel/p5-POEx-Types/pkg-descr5
-rw-r--r--devel/p5-POEx-Types/pkg-plist5
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4c8378e21207..0b811af2b4b4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1981,6 +1981,7 @@
SUBDIR += p5-POE-Test-Loops
SUBDIR += p5-POE-XS-Loop-Poll
SUBDIR += p5-POE-XS-Queue-Array
+ SUBDIR += p5-POEx-Types
SUBDIR += p5-POSIX-strptime
SUBDIR += p5-PPerl
SUBDIR += p5-PV
diff --git a/devel/p5-POEx-Types/Makefile b/devel/p5-POEx-Types/Makefile
new file mode 100644
index 000000000000..72332d7cc7ae
--- /dev/null
+++ b/devel/p5-POEx-Types/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: POEx::Types
+# Date created: 09 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POEx-Types
+PORTVERSION= 1.100910
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/N/NP/NPEREZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to provide MooseX::Types types for modern POE
+
+RUN_DEPENDS= \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Types-Structured>0:${PORTSDIR}/devel/p5-MooseX-Types-Structured \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POEx::Types.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POEx-Types/distinfo b/devel/p5-POEx-Types/distinfo
new file mode 100644
index 000000000000..cdf1cb7d5e9a
--- /dev/null
+++ b/devel/p5-POEx-Types/distinfo
@@ -0,0 +1,3 @@
+MD5 (POEx-Types-1.100910.tar.gz) = a260ab5d10454eea2ac43638bcdc3652
+SHA256 (POEx-Types-1.100910.tar.gz) = a05aab5b6aaba6846c29a28f1f5658dc0fd0d93b8ca3e03e0f76babf4958f6ae
+SIZE (POEx-Types-1.100910.tar.gz) = 9846
diff --git a/devel/p5-POEx-Types/pkg-descr b/devel/p5-POEx-Types/pkg-descr
new file mode 100644
index 000000000000..184fe820b042
--- /dev/null
+++ b/devel/p5-POEx-Types/pkg-descr
@@ -0,0 +1,5 @@
+This modules exports the needed subtypes, and coercions for POEx
+modules and is based on Sub::Exporter, so see that module for options
+on importing.
+
+WWW: http://search.cpan.org/dist/POEx-Types/
diff --git a/devel/p5-POEx-Types/pkg-plist b/devel/p5-POEx-Types/pkg-plist
new file mode 100644
index 000000000000..a74280087402
--- /dev/null
+++ b/devel/p5-POEx-Types/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Types/.packlist
+%%SITE_PERL%%/POEx/Types.pm
+@dirrmtry %%SITE_PERL%%/POEx
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Types
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx