aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2005-11-02 23:25:28 +0800
committeraaron <aaron@FreeBSD.org>2005-11-02 23:25:28 +0800
commit9dd6db9a293dbf1a66634ee1040c5e6b6cf624c6 (patch)
treecbb77fc5dc1b9388466b44e0e39face75060364d /devel
parent79683ec276fd80596bb18a813966b3b173ca2654 (diff)
downloadfreebsd-ports-gnome-9dd6db9a293dbf1a66634ee1040c5e6b6cf624c6.tar.gz
freebsd-ports-gnome-9dd6db9a293dbf1a66634ee1040c5e6b6cf624c6.tar.zst
freebsd-ports-gnome-9dd6db9a293dbf1a66634ee1040c5e6b6cf624c6.zip
Add devel/p5-Class-Throwable 0.10, A Perl module that implements a minimal lightweight exception class.
submitted by: aaron Reviewed by: tobez Approved by: tobez
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Throwable/Makefile31
-rw-r--r--devel/p5-Class-Throwable/distinfo2
-rw-r--r--devel/p5-Class-Throwable/pkg-descr12
-rw-r--r--devel/p5-Class-Throwable/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7c1229ebade4..7a6483a4bf23 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -754,6 +754,7 @@
SUBDIR += p5-Class-Roles
SUBDIR += p5-Class-Singleton
SUBDIR += p5-Class-Tangram
+ SUBDIR += p5-Class-Throwable
SUBDIR += p5-Class-Tom
SUBDIR += p5-Class-Trigger
SUBDIR += p5-Class-Virtual
diff --git a/devel/p5-Class-Throwable/Makefile b/devel/p5-Class-Throwable/Makefile
new file mode 100644
index 000000000000..09d3f2a2b98b
--- /dev/null
+++ b/devel/p5-Class-Throwable/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Class::Throwable
+# Date created: 1 November 2005
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Throwable
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A minimal lightweight exception class
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Class::Throwable.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Throwable/distinfo b/devel/p5-Class-Throwable/distinfo
new file mode 100644
index 000000000000..ed4dcf1ddc21
--- /dev/null
+++ b/devel/p5-Class-Throwable/distinfo
@@ -0,0 +1,2 @@
+MD5 (Class-Throwable-0.10.tar.gz) = 888ea61abfd8d9b60c024a997de9dbbd
+SIZE (Class-Throwable-0.10.tar.gz) = 10971
diff --git a/devel/p5-Class-Throwable/pkg-descr b/devel/p5-Class-Throwable/pkg-descr
new file mode 100644
index 000000000000..c8f1aec8f88d
--- /dev/null
+++ b/devel/p5-Class-Throwable/pkg-descr
@@ -0,0 +1,12 @@
+This module implements a minimal lightweight exception object. It is meant
+to be a compromise between more basic solutions like Carp which can only
+print information and cannot handle exception objects, and more complex
+solutions like Exception::Class which can be used to define complex inline
+exceptions and has a number of module dependencies.
+
+WWW: http://search.cpan.org/dist/Class-Throwable/
+Author: Stevan Little <stevan@iinteractive.com>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/devel/p5-Class-Throwable/pkg-plist b/devel/p5-Class-Throwable/pkg-plist
new file mode 100644
index 000000000000..61005db9236d
--- /dev/null
+++ b/devel/p5-Class-Throwable/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/Throwable.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Throwable/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Throwable
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true