aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-04-04 02:51:03 +0800
committermi <mi@FreeBSD.org>2015-04-04 02:51:03 +0800
commit9f79f577bebe9f071b0ae46ce8496624f21fd0d2 (patch)
tree4fe9165814953b3daf6e48b14a5bc3b913c18be4 /devel
parent2d6fb50eb01da5d4830b63310582c2a59edbc463 (diff)
downloadfreebsd-ports-gnome-9f79f577bebe9f071b0ae46ce8496624f21fd0d2.tar.gz
freebsd-ports-gnome-9f79f577bebe9f071b0ae46ce8496624f21fd0d2.tar.zst
freebsd-ports-gnome-9f79f577bebe9f071b0ae46ce8496624f21fd0d2.zip
Add port of Atlassian Software Development Kit allowing development of
plugins for the company's applications (like JIRA, Confluence, and others). Sponsored by: http://sybpipe.com/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/atlassian-plugin-sdk/Makefile48
-rw-r--r--devel/atlassian-plugin-sdk/distinfo2
-rw-r--r--devel/atlassian-plugin-sdk/files/patch-parse-integer33
-rw-r--r--devel/atlassian-plugin-sdk/pkg-descr8
-rw-r--r--devel/atlassian-plugin-sdk/pkg-plist41
6 files changed, 133 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 16a6ced2fbea..7ca9322b238b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -91,6 +91,7 @@
SUBDIR += atf
SUBDIR += atlas
SUBDIR += atlas-devel
+ SUBDIR += atlassian-plugin-sdk
SUBDIR += autobook
SUBDIR += autoconf
SUBDIR += autoconf-archive
diff --git a/devel/atlassian-plugin-sdk/Makefile b/devel/atlassian-plugin-sdk/Makefile
new file mode 100644
index 000000000000..39ccbc604604
--- /dev/null
+++ b/devel/atlassian-plugin-sdk/Makefile
@@ -0,0 +1,48 @@
+# Created by: Mikhail T. <mi@aldan.algebra.com>
+# $FreeBSD$
+
+PORTNAME= atlassian-plugin-sdk
+PORTVERSION= 6.0.1
+CATEGORIES= devel java
+MASTER_SITES= https://maven.atlassian.com/content/repositories/atlassian-public/com/atlassian/amps/atlassian-plugin-sdk/${PORTVERSION}/
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Atlassian Plugin SDK
+
+RUN_DEPENDS= mvn:${PORTSDIR}/devel/maven-wrapper
+
+USE_JAVA= yes
+JAVA_VERSION= 1.7+
+
+EXTRACT_AFTER_ARGS=${DISTNAME}/bin ${DISTNAME}/apache-maven*/conf/settings.xml
+
+NO_BUILD= Just sh-scripts and JARs here, no source code
+MAVEN_SETTINGS= ${ETCDIR_REL}/settings.xml
+PLIST_SUB+= MAVEN_SETTINGS="${MAVEN_SETTINGS}"
+RESTRICTED= License uncertain and no point in redistributing anyway
+
+post-patch:
+ ${REINPLACE_CMD} -i "" \
+ -e '$$s,^sh -c "\([^"]*\)",exec \1,' \
+ -e 's|^ATLAS_HOME=.*|ATLAS_HOME=${DATADIR}|' \
+ -e 's|^MAVEN_EXECUTABLE=.*|MAVEN_EXECUTABLE=${LOCALBASE}/bin/mvn|' \
+ -e '/^M2_HOME/d' \
+ -e 's/^read$$/& unused/' \
+ -e 's|^MVN_PARAMS=.*|MVN_PARAMS="-gs ${PREFIX}/${MAVEN_SETTINGS}"|' \
+ -e 's|\$${ATLAS_HOME}/bin|${PREFIX}/bin|g' \
+ ${WRKSRC}/bin/*
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${MAVEN_SETTINGS:H}
+ ${INSTALL_DATA} ${WRKSRC}/apache-maven*/conf/settings.xml \
+ ${STAGEDIR}${PREFIX}/${MAVEN_SETTINGS}.dist
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${TAR} --strip-components 1 -C ${STAGEDIR}${DATADIR} -xv \
+ --no-same-permissions --no-same-owner --exclude maven \
+ -f ${DISTDIR}/${DISTFILES} ${DISTNAME}/repository 2>&1 | \
+ ${SED} -e 's,^x ,${DATADIR_REL}/,' -e 's,.*/$$,@dirrm &,' | \
+ ${SORT} -r >> ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${DATADIR}/repository -type f | ${XARGS} ${CHMOD} ${_SHAREMODE}
+
+.include <bsd.port.mk>
diff --git a/devel/atlassian-plugin-sdk/distinfo b/devel/atlassian-plugin-sdk/distinfo
new file mode 100644
index 000000000000..c0c3c0de818e
--- /dev/null
+++ b/devel/atlassian-plugin-sdk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (atlassian-plugin-sdk-6.0.1.tar.gz) = d950d0f9759dcf8dde6aa37f78ed9be76069b97121fbc814376b5df54f36dee5
+SIZE (atlassian-plugin-sdk-6.0.1.tar.gz) = 43963664
diff --git a/devel/atlassian-plugin-sdk/files/patch-parse-integer b/devel/atlassian-plugin-sdk/files/patch-parse-integer
new file mode 100644
index 000000000000..f35253ee885e
--- /dev/null
+++ b/devel/atlassian-plugin-sdk/files/patch-parse-integer
@@ -0,0 +1,33 @@
+--- bin/atlas-install-plugin 2015-03-11 00:21:27.000000000 -0400
++++ bin/atlas-install-plugin 2015-04-02 17:15:41.000000000 -0400
+@@ -85,23 +84,23 @@
+ case "$1" in
+ "-p" | "--http-port")
+- MVN_PARAMS="${MVN_PARAMS} -Dhttp.port='${2}'"
++ MVN_PARAMS="${MVN_PARAMS} -Dhttp.port=$2"
+ shift 2;;
+ "--context-path")
+- MVN_PARAMS="${MVN_PARAMS} -Dcontext.path='${2}'"
++ MVN_PARAMS="${MVN_PARAMS} -Dcontext.path=$2"
+ shift 2;;
+ "--server")
+- MVN_PARAMS="${MVN_PARAMS} -Dserver='${2}'"
++ MVN_PARAMS="${MVN_PARAMS} -Dserver=$2"
+ shift 2;;
+ "--username")
+- MVN_PARAMS="${MVN_PARAMS} -Dusername='${2}'"
++ MVN_PARAMS="${MVN_PARAMS} -Dusername=$2"
+ shift 2;;
+ "--password")
+- MVN_PARAMS="${MVN_PARAMS} -Dpassword='${2}'"
++ MVN_PARAMS="${MVN_PARAMS} -Dpassword=$2"
+ shift 2;;
+ "--plugin-key")
+- MVN_PARAMS="${MVN_PARAMS} -Datlassian.plugin.key='${2}'"
++ MVN_PARAMS="${MVN_PARAMS} -Datlassian.plugin.key=$2"
+ shift 2;;
+ *)
+- MVN_PARAMS="${MVN_PARAMS} ${1}"
++ MVN_PARAMS="$MVN_PARAMS $1"
+ shift 1;; esac
+ done
diff --git a/devel/atlassian-plugin-sdk/pkg-descr b/devel/atlassian-plugin-sdk/pkg-descr
new file mode 100644
index 000000000000..f13a2c12c2e6
--- /dev/null
+++ b/devel/atlassian-plugin-sdk/pkg-descr
@@ -0,0 +1,8 @@
+Software Development Kit for Atlassian's family of applications
+(JIRA, Confluence, and others).
+
+This port strips out the Maven bits bundled with the SDK by Altassian
+relying instead on the Maven installed from one of the FreeBSD
+mvn-ports.
+
+WWW: https://developer.atlassian.com/docs/getting-started/set-up-the-atlassian-plugin-sdk-and-build-a-project
diff --git a/devel/atlassian-plugin-sdk/pkg-plist b/devel/atlassian-plugin-sdk/pkg-plist
new file mode 100644
index 000000000000..80c2bb1035b2
--- /dev/null
+++ b/devel/atlassian-plugin-sdk/pkg-plist
@@ -0,0 +1,41 @@
+bin/atlas-clean
+bin/atlas-cli
+bin/atlas-clover
+bin/atlas-compile
+bin/atlas-create-bamboo-plugin
+bin/atlas-create-bamboo-plugin-module
+bin/atlas-create-confluence-plugin
+bin/atlas-create-confluence-plugin-module
+bin/atlas-create-crowd-plugin
+bin/atlas-create-crowd-plugin-module
+bin/atlas-create-fecru-plugin
+bin/atlas-create-fecru-plugin-module
+bin/atlas-create-home-zip
+bin/atlas-create-jira-plugin
+bin/atlas-create-jira-plugin-module
+bin/atlas-create-jira4-plugin
+bin/atlas-create-jira5-plugin
+bin/atlas-create-plugin
+bin/atlas-create-refapp-plugin
+bin/atlas-create-refapp-plugin-module
+bin/atlas-create-stash-plugin
+bin/atlas-create-stash-plugin-module
+bin/atlas-debug
+bin/atlas-help
+bin/atlas-install-plugin
+bin/atlas-integration-test
+bin/atlas-mvn
+bin/atlas-package
+bin/atlas-release
+bin/atlas-release-rollback
+bin/atlas-remote-test
+bin/atlas-ruin
+bin/atlas-run
+bin/atlas-run-standalone
+bin/atlas-unit-test
+bin/atlas-update
+bin/atlas-version
+@exec %D/%F
+%%MAVEN_SETTINGS%%.dist
+@unexec cmp -s %D/%F %D/%%MAVEN_SETTINGS%% && rm -f %D/%%MAVEN_SETTINGS%% && rmdir %D/%B || true
+@exec [ -f %D/%%MAVEN_SETTINGS%% ] || cp -p %D/%F %D/%%MAVEN_SETTINGS%%