aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2016-09-20 23:25:28 +0800
committerphilip <philip@FreeBSD.org>2016-09-20 23:25:28 +0800
commita6feff0303002c53bcd8f14230d2d47c257bfb40 (patch)
tree8b4cc143e2d03ec33bcda59f5f2349b6a68d7744 /devel
parent0d4957a059348156102f0b975cdfe12412050936 (diff)
downloadfreebsd-ports-gnome-a6feff0303002c53bcd8f14230d2d47c257bfb40.tar.gz
freebsd-ports-gnome-a6feff0303002c53bcd8f14230d2d47c257bfb40.tar.zst
freebsd-ports-gnome-a6feff0303002c53bcd8f14230d2d47c257bfb40.zip
Add devel/py-pylru-cache.
This is an LRU cache for Python. Provides a dictionary-like object as well as a method decorator.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pylru-cache/Makefile19
-rw-r--r--devel/py-pylru-cache/distinfo3
-rw-r--r--devel/py-pylru-cache/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5f27ac3c28dd..df29c2eed705 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4356,6 +4356,7 @@
SUBDIR += py-pykde4
SUBDIR += py-pykdeuic4
SUBDIR += py-pyke
+ SUBDIR += py-pylru-cache
SUBDIR += py-pymarc
SUBDIR += py-pympler
SUBDIR += py-pymtbl
diff --git a/devel/py-pylru-cache/Makefile b/devel/py-pylru-cache/Makefile
new file mode 100644
index 000000000000..ac6181ea010d
--- /dev/null
+++ b/devel/py-pylru-cache/Makefile
@@ -0,0 +1,19 @@
+# Created by: philip@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= pylru-cache
+PORTVERSION= 0.1.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py_lru_cache-${PORTVERSION}
+
+MAINTAINER= philip@FreeBSD.org
+COMMENT= LRU cache for Python
+
+LICENSE= BSD
+
+USES?= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-pylru-cache/distinfo b/devel/py-pylru-cache/distinfo
new file mode 100644
index 000000000000..8811a5c11e91
--- /dev/null
+++ b/devel/py-pylru-cache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474303987
+SHA256 (py_lru_cache-0.1.4.tar.gz) = 02df33684e13e1a78987bf9f8b0ac90210952857d9d12d1cf83fd0c906456af0
+SIZE (py_lru_cache-0.1.4.tar.gz) = 2969
diff --git a/devel/py-pylru-cache/pkg-descr b/devel/py-pylru-cache/pkg-descr
new file mode 100644
index 000000000000..85c26f588078
--- /dev/null
+++ b/devel/py-pylru-cache/pkg-descr
@@ -0,0 +1,4 @@
+LRU cache for python. Provides a dictionary-like object as well
+ as a method decorator.
+
+WWW: https://pypi.python.org/pypi/py_lru_cache/