aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-23 06:32:14 +0800
committerwg <wg@FreeBSD.org>2013-06-23 06:32:14 +0800
commita72f7bfccf0cc5dac06a558a23706d535c9e78cc (patch)
tree16e2989b26a31196ba42a5112e82db5a97b7969c /devel
parentf63cf1bcab3bb186eb0c42cf73245876a39b8bc9 (diff)
downloadfreebsd-ports-gnome-a72f7bfccf0cc5dac06a558a23706d535c9e78cc.tar.gz
freebsd-ports-gnome-a72f7bfccf0cc5dac06a558a23706d535c9e78cc.tar.zst
freebsd-ports-gnome-a72f7bfccf0cc5dac06a558a23706d535c9e78cc.zip
Pygit2 is a set of Python bindings to the libgit2 shared library, libgit2
implements the core of Git. Pygit2 works with Python 2.6, 2.7, 3.1, 3.2 and 3.3. WWW: http://www.pygit2.org
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pygit2/Makefile18
-rw-r--r--devel/py-pygit2/distinfo2
-rw-r--r--devel/py-pygit2/pkg-descr4
-rw-r--r--devel/py-pygit2/pkg-plist14
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e4772011eae1..fea39b8b3e2d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3634,6 +3634,7 @@
SUBDIR += py-pyechonest
SUBDIR += py-pyev
SUBDIR += py-pygithub
+ SUBDIR += py-pygit2
SUBDIR += py-pygpx
SUBDIR += py-pykde4
SUBDIR += py-pykdeuic4
diff --git a/devel/py-pygit2/Makefile b/devel/py-pygit2/Makefile
new file mode 100644
index 000000000000..ce9852378631
--- /dev/null
+++ b/devel/py-pygit2/Makefile
@@ -0,0 +1,18 @@
+# Created by: William Grzybowski <wg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pygit2
+PORTVERSION= 0.18.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Python bindings for libgit2
+
+LIB_DEPENDS= git2:${PORTSDIR}/devel/libgit2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pygit2/distinfo b/devel/py-pygit2/distinfo
new file mode 100644
index 000000000000..7292e70662a3
--- /dev/null
+++ b/devel/py-pygit2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pygit2-0.18.1.tar.gz) = cddfb237a0582109086d0e666f96430b3c262c5f7ccf326b6c947a0f7052d2fd
+SIZE (pygit2-0.18.1.tar.gz) = 96524
diff --git a/devel/py-pygit2/pkg-descr b/devel/py-pygit2/pkg-descr
new file mode 100644
index 000000000000..a5b5125cb2ad
--- /dev/null
+++ b/devel/py-pygit2/pkg-descr
@@ -0,0 +1,4 @@
+Pygit2 is a set of Python bindings to the libgit2 shared library, libgit2
+implements the core of Git. Pygit2 works with Python 2.6, 2.7, 3.1, 3.2 and 3.3.
+
+WWW: http://www.pygit2.org/
diff --git a/devel/py-pygit2/pkg-plist b/devel/py-pygit2/pkg-plist
new file mode 100644
index 000000000000..d16b26bf96b9
--- /dev/null
+++ b/devel/py-pygit2/pkg-plist
@@ -0,0 +1,14 @@
+%%PYTHON_SITELIBDIR%%/_pygit2.so
+%%PYTHON_SITELIBDIR%%/pygit2/__init__.py
+%%PYTHON_SITELIBDIR%%/pygit2/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pygit2/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pygit2/repository.py
+%%PYTHON_SITELIBDIR%%/pygit2/repository.pyc
+%%PYTHON_SITELIBDIR%%/pygit2/repository.pyo
+%%PYTHON_SITELIBDIR%%/pygit2/utils.py
+%%PYTHON_SITELIBDIR%%/pygit2/utils.pyc
+%%PYTHON_SITELIBDIR%%/pygit2/utils.pyo
+%%PYTHON_SITELIBDIR%%/pygit2/version.py
+%%PYTHON_SITELIBDIR%%/pygit2/version.pyc
+%%PYTHON_SITELIBDIR%%/pygit2/version.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/pygit2