aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-12-28 21:01:31 +0800
committerpawel <pawel@FreeBSD.org>2014-12-28 21:01:31 +0800
commitada99d8e55b81f2724526877b0f7745b9754ac55 (patch)
tree1b77422097259bb4c8278541c0e6ff7c6d330026 /devel
parent10e6674683dad60f0e04e20aa0e48883884392de (diff)
downloadfreebsd-ports-gnome-ada99d8e55b81f2724526877b0f7745b9754ac55.tar.gz
freebsd-ports-gnome-ada99d8e55b81f2724526877b0f7745b9754ac55.tar.zst
freebsd-ports-gnome-ada99d8e55b81f2724526877b0f7745b9754ac55.zip
- Update to version 2.3
- Change maintainer's email PR: 195874 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/google-perftools/Makefile13
-rw-r--r--devel/google-perftools/distinfo4
-rw-r--r--devel/google-perftools/files/patch-pprof23
-rw-r--r--devel/google-perftools/pkg-plist12
4 files changed, 20 insertions, 32 deletions
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index 90f70674a204..bbd940559241 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -1,14 +1,14 @@
-# Created by: Yuri Victorovich <yuri@tsoft.com>
+# Created by: Yuri Victorovich <yuri@rawbw.com>
# $FreeBSD$
PORTNAME= google-perftools
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3
CATEGORIES= devel
MASTER_SITES= https://googledrive.com/host/0B6NtGsLhIcf7MWxMMF9JdTN3UVk/ \
${MASTER_SITE_LOCAL}
DISTNAME= gperftools-${PORTVERSION}
-MAINTAINER= yuri@tsoft.com
+MAINTAINER= yuri@rawbw.com
COMMENT= Fast, multi-threaded malloc() and nifty performance analysis tools
LICENSE= BSD3CLAUSE
@@ -39,7 +39,7 @@ CXXFLAGS+= -fno-builtin
CONFIGURE_ARGS+=--enable-frame-pointers
.endif
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not build, assembly not supported, see PR-94: http://code.google.com/p/google-perftools/issues/detail?id=94&can=1
+BROKEN= Does not build, assembly not supported, see PR#94: http://code.google.com/p/google-perftools/issues/detail?id=94&can=1
.endif
post-patch:
@@ -56,8 +56,9 @@ post-patch:
post-build:
@${ECHO}
- @${ECHO} "Please run 'make check'. Two testcases are known to fail."
- @${ECHO} "Report any testcase failures to http://code.google.com/p/google-perftools/issues/list"
+ @${ECHO} "Please run 'make check' (requires bash)."
+ @${ECHO} "Two testcases are known to fail. Testsuite is known to be"
+ @${ECHO} "unreliable and give false positives and negatives (PR#661)."
@${ECHO}
post-install:
diff --git a/devel/google-perftools/distinfo b/devel/google-perftools/distinfo
index 08cd080afd55..e015257ecf61 100644
--- a/devel/google-perftools/distinfo
+++ b/devel/google-perftools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gperftools-2.2.1.tar.gz) = 56f8f730e56576ad972553bf8467f1c77770f00a6289d3d961ec6f026bf9f313
-SIZE (gperftools-2.2.1.tar.gz) = 1370247
+SHA256 (gperftools-2.3.tar.gz) = 093452ad45d639093c144b4ec732a3417e8ee1f3744f2b0f8d45c996223385ce
+SIZE (gperftools-2.3.tar.gz) = 1346151
diff --git a/devel/google-perftools/files/patch-pprof b/devel/google-perftools/files/patch-pprof
index 8adfa3464949..a85e676d7c38 100644
--- a/devel/google-perftools/files/patch-pprof
+++ b/devel/google-perftools/files/patch-pprof
@@ -1,24 +1,11 @@
---- src/pprof.orig 2012-02-03 15:39:48.000000000 -0800
-+++ src/pprof 2013-05-03 10:29:08.000000000 -0700
-@@ -752,10 +752,9 @@
- # (Stop once we find one.)
- # Works best if the browser is already running.
- my @alt = (
-- "/etc/alternatives/gnome-www-browser",
-- "/etc/alternatives/x-www-browser",
-- "google-chrome",
-+ "chrome",
- "firefox",
-+ "opera"
- );
- foreach my $b (@alt) {
- if (system($b, $fname) == 0) {
-@@ -4345,7 +4344,7 @@
+--- src/pprof
++++ src/pprof
+@@ -4405,7 +4405,7 @@
my $finish;
my $offset;
my $lib;
-- if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(\S+\.(so|dll|dylib|bundle)((\.\d+)+\w*(\.\d+){0,3})?)$/i) {
-+ if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(\S+\.(so|dll|dylib|bundle)((\.\d+)+\w*(\.\d+){0,3})?)\s+[A-Z]+\s+[\-0-9]+$/i) {
+- if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(.+\.(so|dll|dylib|bundle)((\.\d+)+\w*(\.\d+){0,3})?)$/i) {
++ if ($l =~ /^($h)-($h)\s+..x.\s+($h)\s+\S+:\S+\s+\d+\s+(.+\.(so|dll|dylib|bundle)((\.\d+)+\w*(\.\d+){0,3})?)\s+[A-Z]+\s+[\-0-9]+$/i) {
# Full line from /proc/self/maps. Example:
# 40000000-40015000 r-xp 00000000 03:01 12845071 /lib/ld-2.3.2.so
$start = HexExtend($1);
diff --git a/devel/google-perftools/pkg-plist b/devel/google-perftools/pkg-plist
index 7ccded9d82f0..842b598fa92d 100644
--- a/devel/google-perftools/pkg-plist
+++ b/devel/google-perftools/pkg-plist
@@ -20,27 +20,27 @@ include/gperftools/tcmalloc.h
lib/libprofiler.a
lib/libprofiler.so
lib/libprofiler.so.0
-lib/libprofiler.so.0.4.1
+lib/libprofiler.so.0.4.3
lib/libtcmalloc.a
lib/libtcmalloc.so
lib/libtcmalloc.so.4
-lib/libtcmalloc.so.4.2.2
+lib/libtcmalloc.so.4.2.4
lib/libtcmalloc_and_profiler.a
lib/libtcmalloc_and_profiler.so
lib/libtcmalloc_and_profiler.so.4
-lib/libtcmalloc_and_profiler.so.4.2.2
+lib/libtcmalloc_and_profiler.so.4.2.4
lib/libtcmalloc_debug.a
lib/libtcmalloc_debug.so
lib/libtcmalloc_debug.so.4
-lib/libtcmalloc_debug.so.4.2.2
+lib/libtcmalloc_debug.so.4.2.4
lib/libtcmalloc_minimal.a
lib/libtcmalloc_minimal.so
lib/libtcmalloc_minimal.so.4
-lib/libtcmalloc_minimal.so.4.2.2
+lib/libtcmalloc_minimal.so.4.2.4
lib/libtcmalloc_minimal_debug.a
lib/libtcmalloc_minimal_debug.so
lib/libtcmalloc_minimal_debug.so.4
-lib/libtcmalloc_minimal_debug.so.4.2.2
+lib/libtcmalloc_minimal_debug.so.4.2.4
libdata/pkgconfig/libprofiler.pc
libdata/pkgconfig/libtcmalloc.pc
libdata/pkgconfig/libtcmalloc_debug.pc