aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2016-09-21 02:36:15 +0800
committercrees <crees@FreeBSD.org>2016-09-21 02:36:15 +0800
commitb2a7c8147f62d75172693a4f03796209906ee8d9 (patch)
tree63d018123645104b667b5e2c9b1d3ecfc63df0a0 /devel
parent2b2f501e570d34a1d22e512863ba14aab4cccd7a (diff)
downloadfreebsd-ports-gnome-b2a7c8147f62d75172693a4f03796209906ee8d9.tar.gz
freebsd-ports-gnome-b2a7c8147f62d75172693a4f03796209906ee8d9.tar.zst
freebsd-ports-gnome-b2a7c8147f62d75172693a4f03796209906ee8d9.zip
Find new MASTER_SITES
PR: ports/212719
Diffstat (limited to 'devel')
-rw-r--r--devel/ucpp/Makefile20
-rw-r--r--devel/ucpp/distinfo5
-rw-r--r--devel/ucpp/files/patch-Makefile24
-rw-r--r--devel/ucpp/files/patch-cpp.c2
-rw-r--r--devel/ucpp/pkg-descr2
-rw-r--r--devel/ucpp/pkg-plist14
6 files changed, 28 insertions, 39 deletions
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
index b6ff4a943dae..713a0e6fb811 100644
--- a/devel/ucpp/Makefile
+++ b/devel/ucpp/Makefile
@@ -2,24 +2,22 @@
# $FreeBSD$
PORTNAME= ucpp
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.4
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= # GITHUB
MAINTAINER= crees@FreeBSD.org
COMMENT= C preprocessor and lexer
LICENSE= BSD3CLAUSE
-BROKEN= Unfetchable (google code has gone away)
+USE_GITHUB= yes
+GH_ACCOUNT= scarabeusiv
+USES= autoreconf libtool pathfix
+PATHFIX_MAKEFILEIN= Makefile.am
+GNU_CONFIGURE= yes
-PLIST_FILES= bin/ucpp man/man1/ucpp.1.gz
-USES= gmake
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1/
+post-patch:
+ ${REINPLACE_CMD} '/^CFLAGS/s/-ansi//' ${WRKSRC}/configure.ac
.include <bsd.port.mk>
diff --git a/devel/ucpp/distinfo b/devel/ucpp/distinfo
index c4cb88ae2df7..cf2c577b6532 100644
--- a/devel/ucpp/distinfo
+++ b/devel/ucpp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ucpp-1.3.2.tar.gz) = 983941d31ee8d366085cadf28db75eb1f5cb03ba1e5853b98f12f7f51c63b776
-SIZE (ucpp-1.3.2.tar.gz) = 96939
+TIMESTAMP = 1474029495
+SHA256 (scarabeusiv-ucpp-1.3.4_GH0.tar.gz) = 35958c5f3bb3851c03d3f442cc072cf27b21dc8478e1eecfce289b1c5aba951a
+SIZE (scarabeusiv-ucpp-1.3.4_GH0.tar.gz) = 92999
diff --git a/devel/ucpp/files/patch-Makefile b/devel/ucpp/files/patch-Makefile
deleted file mode 100644
index dd82792b47f1..000000000000
--- a/devel/ucpp/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-Fixes clang build
-
---- Makefile.orig 2011-08-09 05:13:15.000000000 +0000
-+++ Makefile 2011-08-29 21:10:34.000000000 +0000
-@@ -56,8 +56,8 @@
- #FLAGS = -O -m -DMEM_CHECK
-
- # for gcc
--CC = gcc
--FLAGS = -O3 -W -Wall -ansi
-+CC ?= cc
-+FLAGS = -ansi -DAUDIT -DMEM_DEBUG
- #FLAGS = -g -W -Wall -ansi -DAUDIT -DMEM_DEBUG
- #FLAGS = -O3 -mcpu=pentiumpro -fomit-frame-pointer -W -Wall -ansi -DMEM_CHECK
- #FLAGS = -O -pg -W -Wall -ansi -DMEM_CHECK
-@@ -88,7 +88,7 @@
- # ----- nothing should be changed below this line -----
-
- COBJ = mem.o nhash.o cpp.o lexer.o assert.o macro.o eval.o
--CFLAGS = $(FLAGS)
-+CFLAGS += $(FLAGS)
-
- all: ucpp
- @ar cq libucpp.a *.o
diff --git a/devel/ucpp/files/patch-cpp.c b/devel/ucpp/files/patch-cpp.c
index 426b5b2e6bfd..6abcf8dd8133 100644
--- a/devel/ucpp/files/patch-cpp.c
+++ b/devel/ucpp/files/patch-cpp.c
@@ -1,5 +1,5 @@
--- cpp.c.orig 2008-10-01 21:15:41.000000000 +0400
-+++ cpp.c 2011-03-17 21:08:15.000000000 +0300
++++ src/cpp.c 2011-03-17 21:08:15.000000000 +0300
@@ -65,8 +65,8 @@
FILE *emit_output;
diff --git a/devel/ucpp/pkg-descr b/devel/ucpp/pkg-descr
index 229cf87183ca..9574f2362798 100644
--- a/devel/ucpp/pkg-descr
+++ b/devel/ucpp/pkg-descr
@@ -6,4 +6,4 @@ ucpp is a C preprocessor and lexer. It has the following goals:
- Possibility to use the code as a lexer (that outputs tokens
directly)
-WWW: http://code.google.com/p/ucpp/
+WWW: https://github.com/scarabeusiv/ucpp
diff --git a/devel/ucpp/pkg-plist b/devel/ucpp/pkg-plist
new file mode 100644
index 000000000000..9e787ec9e775
--- /dev/null
+++ b/devel/ucpp/pkg-plist
@@ -0,0 +1,14 @@
+bin/ucpp
+include/libucpp/cpp.h
+include/libucpp/hash.h
+include/libucpp/mem.h
+include/libucpp/nhash.h
+include/libucpp/tune.h
+include/libucpp/ucpp-config.h
+include/libucpp/ucppi.h
+lib/libucpp.a
+lib/libucpp.so
+lib/libucpp.so.13
+lib/libucpp.so.13.0.4
+libdata/pkgconfig/libucpp.pc
+man/man1/ucpp.1.gz