aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-21 21:10:05 +0800
committerpav <pav@FreeBSD.org>2005-07-21 21:10:05 +0800
commitc33d5eb436df839123bdde0863823c8a6d6c780e (patch)
treee6538c169480a9debe89f04a647f175dc29c2de7 /devel
parent5f312dd044f064afe2d5f15f436b09388a4bf771 (diff)
downloadfreebsd-ports-gnome-c33d5eb436df839123bdde0863823c8a6d6c780e.tar.gz
freebsd-ports-gnome-c33d5eb436df839123bdde0863823c8a6d6c780e.tar.zst
freebsd-ports-gnome-c33d5eb436df839123bdde0863823c8a6d6c780e.zip
OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented,
flexible 3D engine written in C++ designed to make it easier and more intuitive for developers to produce games and demos utilising 3D hardware. The class library abstracts all the details of using the underlying system libraries like Direct3D and OpenGL and provides an interface based on world objects and other intuitive classes. PR: ports/83781 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ogre/Makefile53
-rw-r--r--devel/ogre/distinfo2
-rw-r--r--devel/ogre/files/patch-Makefile.am11
-rw-r--r--devel/ogre/pkg-descr8
-rw-r--r--devel/ogre/pkg-plist209
6 files changed, 284 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b3858cb1b28f..c0b520fe1990 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -618,6 +618,7 @@
SUBDIR += ocaml-ulex
SUBDIR += ocamlweb
SUBDIR += ode
+ SUBDIR += ogre
SUBDIR += omniNotify
SUBDIR += omniORB
SUBDIR += oniguruma
diff --git a/devel/ogre/Makefile b/devel/ogre/Makefile
new file mode 100644
index 000000000000..fe102522869f
--- /dev/null
+++ b/devel/ogre/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: ogre
+# Date created: 2005 Jul 10
+# Whom: Jack Twilley <jmt@twilley.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ogre
+DISTVERSION= 1.0.3p1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ogre
+DISTNAME= ogre-linux_osx-v1-0-3p1
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Object-Oriented Graphical Rendering Engine
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libzzip.a:${PORTSDIR}/devel/zziplib \
+ ${LOCALBASE}/bin/sdl11-config:${PORTSDIR}/devel/sdl12 \
+ ${LOCALBASE}/lib/libIL.a:${PORTSDIR}/graphics/devil \
+ ${LOCALBASE}/lib/libcppunit.a:${PORTSDIR}/devel/cppunit
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/ogrenew
+
+USE_AUTOMAKE_VER= 19
+AUTOMAKE_ARGS= --include-deps --add-missing --foreign
+USE_AUTOCONF_VER= 259
+USE_ACLOCAL_VER= 19
+ACLOCAL_ARGS= -I Scripts/m4 -I ${LOCALBASE}/share/aclocal
+USE_LIBTOOL_VER= 15
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-cg
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lc" SDL_CONFIG=${LOCALBASE}/bin/sdl11-config
+INSTALLS_SHLIB= yes
+PLIST_SUB+= CONFIGURE_TARGET="${CONFIGURE_TARGET}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile"
+.endif
+
+pre-configure:
+ @(${SED} -i.orig -e 's,[(]libdir[)],(prefix)/libdata,' ${WRKSRC}/Makefile.am)
+ @(${FIND} ${WRKSRC} -type f -name Makefile.am -print0 | ${XARGS} -0 ${SED} -i.orig -e 's#.libs/##')
+ @(cd ${WRKSRC} && ${LIBTOOLIZE} --copy --force && ${SED} -i.orig -e '/X-lc.*continue/d' ltmain.sh)
+
+pre-build:
+ @(${FIND} ${WRKSRC} -type d -name obj -print0 | ${XARGS} -0 ${RM} -rf)
+
+.include <bsd.port.post.mk>
diff --git a/devel/ogre/distinfo b/devel/ogre/distinfo
new file mode 100644
index 000000000000..422804dbf5ad
--- /dev/null
+++ b/devel/ogre/distinfo
@@ -0,0 +1,2 @@
+MD5 (ogre-linux_osx-v1-0-3p1.tar.bz2) = fa8c843de62a505d1a707ea319a58734
+SIZE (ogre-linux_osx-v1-0-3p1.tar.bz2) = 19986714
diff --git a/devel/ogre/files/patch-Makefile.am b/devel/ogre/files/patch-Makefile.am
new file mode 100644
index 000000000000..99bd73f6a715
--- /dev/null
+++ b/devel/ogre/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+
+$FreeBSD$
+
+--- Makefile.am.orig
++++ Makefile.am
+@@ -1,4 +1,4 @@
+-SUBDIRS = OgreMain PlatformManagers PlugIns RenderSystems Samples Tools Tests
++SUBDIRS = OgreMain PlatformManagers PlugIns RenderSystems Tools Tests
+
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = OGRE.pc
diff --git a/devel/ogre/pkg-descr b/devel/ogre/pkg-descr
new file mode 100644
index 000000000000..5954bca420f2
--- /dev/null
+++ b/devel/ogre/pkg-descr
@@ -0,0 +1,8 @@
+OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented,
+flexible 3D engine written in C++ designed to make it easier and more
+intuitive for developers to produce games and demos utilising 3D
+hardware. The class library abstracts all the details of using the
+underlying system libraries like Direct3D and OpenGL and provides an
+interface based on world objects and other intuitive classes.
+
+WWW: http://www.ogre3d.org/
diff --git a/devel/ogre/pkg-plist b/devel/ogre/pkg-plist
new file mode 100644
index 000000000000..3b868daa8c23
--- /dev/null
+++ b/devel/ogre/pkg-plist
@@ -0,0 +1,209 @@
+bin/%%CONFIGURE_TARGET%%-OgreMaterialUpgrade
+bin/%%CONFIGURE_TARGET%%-OgreMeshUpgrade
+bin/%%CONFIGURE_TARGET%%-OgreXMLConverter
+include/OGRE/Ogre.h
+include/OGRE/OgreAnimation.h
+include/OGRE/OgreAnimationState.h
+include/OGRE/OgreAnimationTrack.h
+include/OGRE/OgreArchive.h
+include/OGRE/OgreArchiveFactory.h
+include/OGRE/OgreArchiveManager.h
+include/OGRE/OgreAutoParamDataSource.h
+include/OGRE/OgreAxisAlignedBox.h
+include/OGRE/OgreBillboard.h
+include/OGRE/OgreBillboardParticleRenderer.h
+include/OGRE/OgreBillboardSet.h
+include/OGRE/OgreBitwise.h
+include/OGRE/OgreBlendMode.h
+include/OGRE/OgreBone.h
+include/OGRE/OgreBorderPanelOverlayElement.h
+include/OGRE/OgreCamera.h
+include/OGRE/OgreCodec.h
+include/OGRE/OgreColourValue.h
+include/OGRE/OgreCommon.h
+include/OGRE/OgreConfig.h
+include/OGRE/OgreConfigDialog.h
+include/OGRE/OgreConfigFile.h
+include/OGRE/OgreConfigOptionMap.h
+include/OGRE/OgreController.h
+include/OGRE/OgreControllerManager.h
+include/OGRE/OgreCursor.h
+include/OGRE/OgreDataStream.h
+include/OGRE/OgreDefaultHardwareBufferManager.h
+include/OGRE/OgreDynLib.h
+include/OGRE/OgreDynLibManager.h
+include/OGRE/OgreEdgeListBuilder.h
+include/OGRE/OgreEntity.h
+include/OGRE/OgreErrorDialog.h
+include/OGRE/OgreEventDispatcher.h
+include/OGRE/OgreEventListeners.h
+include/OGRE/OgreEventProcessor.h
+include/OGRE/OgreEventQueue.h
+include/OGRE/OgreEventTarget.h
+include/OGRE/OgreException.h
+include/OGRE/OgreExternalTextureSource.h
+include/OGRE/OgreExternalTextureSourceManager.h
+include/OGRE/OgreFactoryObj.h
+include/OGRE/OgreFileSystem.h
+include/OGRE/OgreFont.h
+include/OGRE/OgreFontManager.h
+include/OGRE/OgreFrameListener.h
+include/OGRE/OgreFrustum.h
+include/OGRE/OgreGpuProgram.h
+include/OGRE/OgreGpuProgramManager.h
+include/OGRE/OgreGpuProgramUsage.h
+include/OGRE/OgreHardwareBuffer.h
+include/OGRE/OgreHardwareBufferManager.h
+include/OGRE/OgreHardwareIndexBuffer.h
+include/OGRE/OgreHardwareOcclusionQuery.h
+include/OGRE/OgreHardwarePixelBuffer.h
+include/OGRE/OgreHardwareVertexBuffer.h
+include/OGRE/OgreHighLevelGpuProgram.h
+include/OGRE/OgreHighLevelGpuProgramManager.h
+include/OGRE/OgreILCodecs.h
+include/OGRE/OgreILImageCodec.h
+include/OGRE/OgreImage.h
+include/OGRE/OgreImageCodec.h
+include/OGRE/OgreInput.h
+include/OGRE/OgreInputEvent.h
+include/OGRE/OgreIteratorWrappers.h
+include/OGRE/OgreKeyEvent.h
+include/OGRE/OgreKeyFrame.h
+include/OGRE/OgreKeyTarget.h
+include/OGRE/OgreLight.h
+include/OGRE/OgreLog.h
+include/OGRE/OgreLogManager.h
+include/OGRE/OgreMaterial.h
+include/OGRE/OgreMaterialManager.h
+include/OGRE/OgreMaterialSerializer.h
+include/OGRE/OgreMath.h
+include/OGRE/OgreMatrix3.h
+include/OGRE/OgreMatrix4.h
+include/OGRE/OgreMemoryMacros.h
+include/OGRE/OgreMemoryManager.h
+include/OGRE/OgreMesh.h
+include/OGRE/OgreMeshFileFormat.h
+include/OGRE/OgreMeshManager.h
+include/OGRE/OgreMeshSerializer.h
+include/OGRE/OgreMeshSerializerImpl.h
+include/OGRE/OgreMouseEvent.h
+include/OGRE/OgreMouseMotionTarget.h
+include/OGRE/OgreMouseTarget.h
+include/OGRE/OgreMovableObject.h
+include/OGRE/OgreMovablePlane.h
+include/OGRE/OgreNoMemoryMacros.h
+include/OGRE/OgreNode.h
+include/OGRE/OgreOverlay.h
+include/OGRE/OgreOverlayContainer.h
+include/OGRE/OgreOverlayElement.h
+include/OGRE/OgreOverlayElementCommands.h
+include/OGRE/OgreOverlayElementFactory.h
+include/OGRE/OgreOverlayManager.h
+include/OGRE/OgrePanelOverlayElement.h
+include/OGRE/OgreParticle.h
+include/OGRE/OgreParticleAffector.h
+include/OGRE/OgreParticleAffectorFactory.h
+include/OGRE/OgreParticleEmitter.h
+include/OGRE/OgreParticleEmitterCommands.h
+include/OGRE/OgreParticleEmitterFactory.h
+include/OGRE/OgreParticleIterator.h
+include/OGRE/OgreParticleSystem.h
+include/OGRE/OgreParticleSystemManager.h
+include/OGRE/OgreParticleSystemRenderer.h
+include/OGRE/OgrePass.h
+include/OGRE/OgrePatchMesh.h
+include/OGRE/OgrePatchSurface.h
+include/OGRE/OgrePixelFormat.h
+include/OGRE/OgrePlane.h
+include/OGRE/OgrePlaneBoundedVolume.h
+include/OGRE/OgrePlatform.h
+include/OGRE/OgrePlatformManager.h
+include/OGRE/OgrePositionTarget.h
+include/OGRE/OgrePredefinedControllers.h
+include/OGRE/OgrePrerequisites.h
+include/OGRE/OgreProfiler.h
+include/OGRE/OgreProgressiveMesh.h
+include/OGRE/OgreQuaternion.h
+include/OGRE/OgreRay.h
+include/OGRE/OgreRectangle.h
+include/OGRE/OgreRectangle2D.h
+include/OGRE/OgreRenderOperation.h
+include/OGRE/OgreRenderQueue.h
+include/OGRE/OgreRenderQueueListener.h
+include/OGRE/OgreRenderQueueSortingGrouping.h
+include/OGRE/OgreRenderSystem.h
+include/OGRE/OgreRenderSystemCapabilities.h
+include/OGRE/OgreRenderTarget.h
+include/OGRE/OgreRenderTargetListener.h
+include/OGRE/OgreRenderTargetTexture.h
+include/OGRE/OgreRenderTexture.h
+include/OGRE/OgreRenderWindow.h
+include/OGRE/OgreRenderable.h
+include/OGRE/OgreResource.h
+include/OGRE/OgreResourceBackgroundQueue.h
+include/OGRE/OgreResourceGroupManager.h
+include/OGRE/OgreResourceManager.h
+include/OGRE/OgreRoot.h
+include/OGRE/OgreRotationalSpline.h
+include/OGRE/OgreSceneManager.h
+include/OGRE/OgreSceneManagerEnumerator.h
+include/OGRE/OgreSceneNode.h
+include/OGRE/OgreSceneQuery.h
+include/OGRE/OgreScriptLoader.h
+include/OGRE/OgreSearchOps.h
+include/OGRE/OgreSerializer.h
+include/OGRE/OgreShadowCaster.h
+include/OGRE/OgreShadowVolumeExtrudeProgram.h
+include/OGRE/OgreSharedPtr.h
+include/OGRE/OgreSimpleRenderable.h
+include/OGRE/OgreSimpleSpline.h
+include/OGRE/OgreSingleton.h
+include/OGRE/OgreSkeleton.h
+include/OGRE/OgreSkeletonFileFormat.h
+include/OGRE/OgreSkeletonInstance.h
+include/OGRE/OgreSkeletonManager.h
+include/OGRE/OgreSkeletonSerializer.h
+include/OGRE/OgreSphere.h
+include/OGRE/OgreSpotShadowFadePng.h
+include/OGRE/OgreStableHeaders.h
+include/OGRE/OgreStaticFaceGroup.h
+include/OGRE/OgreStaticGeometry.h
+include/OGRE/OgreStdHeaders.h
+include/OGRE/OgreString.h
+include/OGRE/OgreStringConverter.h
+include/OGRE/OgreStringInterface.h
+include/OGRE/OgreStringVector.h
+include/OGRE/OgreSubEntity.h
+include/OGRE/OgreSubMesh.h
+include/OGRE/OgreTagPoint.h
+include/OGRE/OgreTargetManager.h
+include/OGRE/OgreTechnique.h
+include/OGRE/OgreTextAreaOverlayElement.h
+include/OGRE/OgreTexture.h
+include/OGRE/OgreTextureManager.h
+include/OGRE/OgreTextureUnitState.h
+include/OGRE/OgreTimer.h
+include/OGRE/OgreUserDefinedObject.h
+include/OGRE/OgreVector2.h
+include/OGRE/OgreVector3.h
+include/OGRE/OgreVector4.h
+include/OGRE/OgreVertexBoneAssignment.h
+include/OGRE/OgreVertexIndexData.h
+include/OGRE/OgreViewport.h
+include/OGRE/OgreWireBoundingBox.h
+include/OGRE/OgreZip.h
+include/OGRE/asm_math.h
+lib/OGRE/Plugin_BSPSceneManager.so
+lib/OGRE/Plugin_OctreeSceneManager.so
+lib/OGRE/Plugin_ParticleFX.so
+lib/OGRE/RenderSystem_GL.so
+lib/libOgreMain.so
+lib/libOgreMain.so.7
+lib/libOgrePlatform.so
+libdata/pkgconfig/OGRE.pc
+share/OGRE/ogre-config.glade
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm share/OGRE
+@dirrm lib/OGRE
+@dirrm include/OGRE