aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2001-03-11 16:37:18 +0800
committerjoerg <joerg@FreeBSD.org>2001-03-11 16:37:18 +0800
commitc44504d505c3c5ce1feb164c1130c6ae4515c971 (patch)
treed4af26520e65f8c403680ce22f1926f15b35f8a5 /devel
parentb10ae8b1d61d453c5993d3fbf00c50a01e735751 (diff)
downloadfreebsd-ports-gnome-c44504d505c3c5ce1feb164c1130c6ae4515c971.tar.gz
freebsd-ports-gnome-c44504d505c3c5ce1feb164c1130c6ae4515c971.tar.zst
freebsd-ports-gnome-c44504d505c3c5ce1feb164c1130c6ae4515c971.zip
Argl. USE_AUTOCONF wasn't quite what i actually intented... Instead,
manually add the dependency for autoheader(1), but don't have the ports infrastructure run `autoconf' (which clobbered the top-level configure script).
Diffstat (limited to 'devel')
-rw-r--r--devel/avr-gcc-3/Makefile4
-rw-r--r--devel/avr-gcc/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 118d986e89f3..29656d92a37c 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -20,7 +20,8 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= joerg@freebsd.org
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
- avr-ld:${PORTSDIR}/devel/avr-binutils
+ avr-ld:${PORTSDIR}/devel/avr-binutils \
+ autoheader:${PORTSDIR}/devel/autoconf
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
@@ -30,7 +31,6 @@ WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}
# the original master site still uses .gz.
#USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 118d986e89f3..29656d92a37c 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -20,7 +20,8 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= joerg@freebsd.org
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
- avr-ld:${PORTSDIR}/devel/avr-binutils
+ avr-ld:${PORTSDIR}/devel/avr-binutils \
+ autoheader:${PORTSDIR}/devel/autoconf
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
@@ -30,7 +31,6 @@ WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}
# the original master site still uses .gz.
#USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOCONF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr