aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-07-06 14:23:00 +0800
committerrene <rene@FreeBSD.org>2011-07-06 14:23:00 +0800
commitc6683e3b181360059c0fb1a6b3759cc3fca73110 (patch)
tree439f8e27aa76b6b698fcb668b84adf12d650bec9 /devel
parent5d6346d2fad053611484f1ed4f665ddc56861749 (diff)
downloadfreebsd-ports-gnome-c6683e3b181360059c0fb1a6b3759cc3fca73110.tar.gz
freebsd-ports-gnome-c6683e3b181360059c0fb1a6b3759cc3fca73110.tar.zst
freebsd-ports-gnome-c6683e3b181360059c0fb1a6b3759cc3fca73110.zip
Do not hardcode JAVA_VERSION in argouml.sh.in
Diffstat (limited to 'devel')
-rw-r--r--devel/argouml/Makefile1
-rw-r--r--devel/argouml/files/argouml.sh.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/argouml/Makefile b/devel/argouml/Makefile
index 6a9670c0fe25..0325320e63b7 100644
--- a/devel/argouml/Makefile
+++ b/devel/argouml/Makefile
@@ -33,6 +33,7 @@ USE_JAVA= yes
JAVA_VERSION= 1.5+
SUB_FILES= argouml.sh
+SUB_LIST= JAVA_VERSION=${JAVA_VERSION}
PORTDOCS= manual-${PORTVERSION}.pdf quickguide-${PORTVERSION}.pdf
DESKTOP_ENTRIES= "ArgoUML" \
diff --git a/devel/argouml/files/argouml.sh.in b/devel/argouml/files/argouml.sh.in
index 811f8e168348..cb517b269680 100644
--- a/devel/argouml/files/argouml.sh.in
+++ b/devel/argouml/files/argouml.sh.in
@@ -2,4 +2,4 @@
#
# $FreeBSD$
-JAVA_VERSION="1.5+" "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/argouml.jar" "$@"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%DATADIR%%/argouml.jar" "$@"