aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-12-21 02:14:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-12-21 02:14:59 +0800
commitc9639cc1e360d49077b5da71c4a3b2c421f8d89d (patch)
treeceaffe448623c731c12d99404aafd8bc4ad889d9 /devel
parentbe856320bcb8f4607812f1046227d20f445850df (diff)
downloadfreebsd-ports-gnome-c9639cc1e360d49077b5da71c4a3b2c421f8d89d.tar.gz
freebsd-ports-gnome-c9639cc1e360d49077b5da71c4a3b2c421f8d89d.tar.zst
freebsd-ports-gnome-c9639cc1e360d49077b5da71c4a3b2c421f8d89d.zip
- Add rubygem-nenv 0.1.1
Using ENV in Ruby is like using raw SQL statements - it feels wrong, because it is. If you agree, this gem is for you. The benefits over using ENV directly: - much friendlier stubbing in tests - you no longer have to care whether false is "0" or "false" or whatever - NO MORE ALL CAPS EVERYWHERE! - keys become methods - namespaces which can be passed around as objects - you can subclass! - you can marshal/unmarshal your own types automatically! - strict mode saves you from doing validation yourself - and there's more to come... - it's designed to be as lightweight and as fast as possible compared to ENV - designed to be both hackable and convenient WWW: https://github.com/e2/nenv RG: https://rubygems.org/gems/nenv
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-nenv/Makefile18
-rw-r--r--devel/rubygem-nenv/distinfo2
-rw-r--r--devel/rubygem-nenv/pkg-descr18
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 01ec1e25e3eb..87bd7fd04ceb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4483,6 +4483,7 @@
SUBDIR += rubygem-mutter
SUBDIR += rubygem-naught
SUBDIR += rubygem-needle
+ SUBDIR += rubygem-nenv
SUBDIR += rubygem-nesty
SUBDIR += rubygem-nice-ffi
SUBDIR += rubygem-nio4r
diff --git a/devel/rubygem-nenv/Makefile b/devel/rubygem-nenv/Makefile
new file mode 100644
index 000000000000..88354b161347
--- /dev/null
+++ b/devel/rubygem-nenv/Makefile
@@ -0,0 +1,18 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= nenv
+PORTVERSION= 0.1.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Convenient wrapper for ENV
+
+LICENSE= MIT
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-nenv/distinfo b/devel/rubygem-nenv/distinfo
new file mode 100644
index 000000000000..8099e2f6e0da
--- /dev/null
+++ b/devel/rubygem-nenv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/nenv-0.1.1.gem) = 8c6706840e3359fd0815e50b9da0a32702bf5d7171b1d0d1fc90cfae46ca74c1
+SIZE (rubygem/nenv-0.1.1.gem) = 9728
diff --git a/devel/rubygem-nenv/pkg-descr b/devel/rubygem-nenv/pkg-descr
new file mode 100644
index 000000000000..c8ed1f8f5a03
--- /dev/null
+++ b/devel/rubygem-nenv/pkg-descr
@@ -0,0 +1,18 @@
+Using ENV in Ruby is like using raw SQL statements - it feels wrong, because it
+is. If you agree, this gem is for you.
+
+The benefits over using ENV directly:
+- much friendlier stubbing in tests
+- you no longer have to care whether false is "0" or "false" or whatever
+- NO MORE ALL CAPS EVERYWHERE!
+- keys become methods
+- namespaces which can be passed around as objects
+- you can subclass!
+- you can marshal/unmarshal your own types automatically!
+- strict mode saves you from doing validation yourself
+- and there's more to come...
+- it's designed to be as lightweight and as fast as possible compared to ENV
+- designed to be both hackable and convenient
+
+WWW: https://github.com/e2/nenv
+RG: https://rubygems.org/gems/nenv