aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2011-06-13 02:59:59 +0800
committerromain <romain@FreeBSD.org>2011-06-13 02:59:59 +0800
commitcdcc2643c0d960e93f09b9a8fdf5cbe7c9136356 (patch)
tree2958e83becfaef94fff1ae78c0e12da46bdac11d /devel
parentb3176d1d4a571d27b0b1ea59fe9a2454eaa4c78c (diff)
downloadfreebsd-ports-gnome-cdcc2643c0d960e93f09b9a8fdf5cbe7c9136356.tar.gz
freebsd-ports-gnome-cdcc2643c0d960e93f09b9a8fdf5cbe7c9136356.tar.zst
freebsd-ports-gnome-cdcc2643c0d960e93f09b9a8fdf5cbe7c9136356.zip
notify-sharp is a C# client implementation for Desktop Notifications, i.e.
notification-daemon. It is inspired by the libnotify API. WWW: http://www.ndesk.org/NotifySharp
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/notify-sharp/Makefile24
-rw-r--r--devel/notify-sharp/distinfo2
-rw-r--r--devel/notify-sharp/pkg-descr4
-rw-r--r--devel/notify-sharp/pkg-plist11
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3393549c0bab..d23559dad04e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1057,6 +1057,7 @@
SUBDIR += newt
SUBDIR += nini
SUBDIR += ninja
+ SUBDIR += notify-sharp
SUBDIR += noweb
SUBDIR += nspr
SUBDIR += nxt-python
diff --git a/devel/notify-sharp/Makefile b/devel/notify-sharp/Makefile
new file mode 100644
index 000000000000..f05d779d0e5e
--- /dev/null
+++ b/devel/notify-sharp/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: notify-sharp
+# Date created: 2008-08-05
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= notify-sharp
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+MASTER_SITES= http://romain.blogreen.org/distfiles/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= C\# client library for notification-daemon
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib \
+ ${LOCALBASE}/share/dbus-1/services/org.freedesktop.Notifications.service:${PORTSDIR}/deskutils/notification-daemon
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtksharp20
+
+.include <bsd.port.mk>
diff --git a/devel/notify-sharp/distinfo b/devel/notify-sharp/distinfo
new file mode 100644
index 000000000000..cde224e76781
--- /dev/null
+++ b/devel/notify-sharp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (notify-sharp-0.4.0.tar.gz) = bb6649ad2e4bdd217f1dfbde3e550c2b8c1800641dbd0b66cef78155bfb86fcc
+SIZE (notify-sharp-0.4.0.tar.gz) = 89400
diff --git a/devel/notify-sharp/pkg-descr b/devel/notify-sharp/pkg-descr
new file mode 100644
index 000000000000..6980067cd4b7
--- /dev/null
+++ b/devel/notify-sharp/pkg-descr
@@ -0,0 +1,4 @@
+notify-sharp is a C# client implementation for Desktop Notifications, i.e.
+notification-daemon. It is inspired by the libnotify API.
+
+WWW: http://www.ndesk.org/NotifySharp
diff --git a/devel/notify-sharp/pkg-plist b/devel/notify-sharp/pkg-plist
new file mode 100644
index 000000000000..9f602ca4b8b3
--- /dev/null
+++ b/devel/notify-sharp/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+lib/mono/gac/notify-sharp/0.4.0.0__2df29c54e245917a/notify-sharp.dll
+lib/mono/gac/notify-sharp/0.4.0.0__2df29c54e245917a/notify-sharp.dll.config
+lib/mono/notify-sharp/notify-sharp.dll
+lib/monodoc/sources/notify-sharp-docs.source
+lib/monodoc/sources/notify-sharp-docs.tree
+lib/monodoc/sources/notify-sharp-docs.zip
+libdata/pkgconfig/notify-sharp.pc
+@dirrm lib/mono/notify-sharp
+@dirrm lib/mono/gac/notify-sharp/0.4.0.0__2df29c54e245917a
+@dirrm lib/mono/gac/notify-sharp