aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2016-10-05 05:51:15 +0800
committerlme <lme@FreeBSD.org>2016-10-05 05:51:15 +0800
commitcfd0cc32456305c4e3495200f1a70678d33f34ed (patch)
treecaa2258f995c71b3e081110ffbdb21723254778c /devel
parentdd1f41979cf736a1baaf6d387c983391bb6ab88a (diff)
downloadfreebsd-ports-gnome-cfd0cc32456305c4e3495200f1a70678d33f34ed.tar.gz
freebsd-ports-gnome-cfd0cc32456305c4e3495200f1a70678d33f34ed.tar.zst
freebsd-ports-gnome-cfd0cc32456305c4e3495200f1a70678d33f34ed.zip
devel/astyle:
- Remove doubled CLFAGS - Use astyle/build/${COMPILER_TYPE} as WRCSRC instead of hard-coding gcc - Remove blank MAGE_ARGS - Drop no longer needed pre-patch target - Stripping the binary is now done by the linker itself PR: 213042 Submitted by: bsam
Diffstat (limited to 'devel')
-rw-r--r--devel/astyle/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index e2dc125f12c2..d9a636de8d1c 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -13,22 +13,18 @@ COMMENT= Source code indenter and formatter for C, C++, C\#, and Java
LICENSE= LGPL3
ALL_TARGET= astyle
-CFLAGS+= -W -Wall -fno-rtti -fno-exceptions
LDFLAGS+= -s
-MAKE_ARGS+= CFLAGS="${CFLAGS}"
USES= compiler gmake iconv
-WRKSRC= ${WRKDIR}/astyle/build/gcc
+WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
OPTIONS_DEFINE= DOCS
pre-patch:
- @${REINPLACE_CMD} -e 's,^CFLAGS,#CFLAGS,; s,g++,${CXX},; \
- s,\(CFLAGSr.*=.*\),\1 -I${LOCALBASE}/include,' \
+ @${REINPLACE_CMD} -e 's,\(CFLAGSr.*=.*\),\1 -I${LOCALBASE}/include,' \
${WRKSRC}/Makefile
do-install:
- ${STRIP_CMD} ${WRKSRC}/bin/astyle
${INSTALL_PROGRAM} ${WRKSRC}/bin/astyle ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/astyle/doc/* ${STAGEDIR}${DOCSDIR}