aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-02-14 05:35:07 +0800
committermiwi <miwi@FreeBSD.org>2010-02-14 05:35:07 +0800
commitd39651e429dfc46d11415295c0ae6f6d18f70a58 (patch)
tree8f7b647319fd8fccfabd612568488f69727d48f6 /devel
parent5564ea412dc1a29a7d284c5c429907ddcfd4482f (diff)
downloadfreebsd-ports-gnome-d39651e429dfc46d11415295c0ae6f6d18f70a58.tar.gz
freebsd-ports-gnome-d39651e429dfc46d11415295c0ae6f6d18f70a58.tar.zst
freebsd-ports-gnome-d39651e429dfc46d11415295c0ae6f6d18f70a58.zip
This module is a wrapper around Getopt::Long that extends the value of
the original Getopt::Long module to: 1) add a simple graphical user interface option screen if no arguments are passed to the program. 2) provide an auto-help mechanism such that -h and --help are handled automatically. It's designed to make the creation of graphical shells trivial without the programmer having to think about it much as well as providing automatic good-looking usage output without the programmer needing to write usage() functions. This also can turn normal command line programs into web CGI scripts as well (automatically). If the Getopt::GUI::Long program is installed as a CGI script then it will automatically prompt the user for the same variables. WWW: http://search.cpan.org/dist/Getopt-GUI-Long/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getopt-GUI-Long/Makefile21
-rw-r--r--devel/p5-Getopt-GUI-Long/distinfo3
-rw-r--r--devel/p5-Getopt-GUI-Long/pkg-descr19
-rw-r--r--devel/p5-Getopt-GUI-Long/pkg-plist8
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 36338c6623f5..21204edac1e7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1569,6 +1569,7 @@
SUBDIR += p5-Getopt-ArgvFile
SUBDIR += p5-Getopt-Declare
SUBDIR += p5-Getopt-Euclid
+ SUBDIR += p5-Getopt-GUI-Long
SUBDIR += p5-Getopt-Long
SUBDIR += p5-Getopt-Long-Descriptive
SUBDIR += p5-Getopt-Mixed
diff --git a/devel/p5-Getopt-GUI-Long/Makefile b/devel/p5-Getopt-GUI-Long/Makefile
new file mode 100644
index 000000000000..497e094b1684
--- /dev/null
+++ b/devel/p5-Getopt-GUI-Long/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: devel/p5-Getopt-GUI-Long
+# Date created: 13 Feb 2010
+# Whom: Martin Wilke <miwi@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-GUI-Long
+PORTVERSION= 0.91
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Wrapper around Getopt::Long
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::GUI::Long.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Getopt-GUI-Long/distinfo b/devel/p5-Getopt-GUI-Long/distinfo
new file mode 100644
index 000000000000..86120f23c16e
--- /dev/null
+++ b/devel/p5-Getopt-GUI-Long/distinfo
@@ -0,0 +1,3 @@
+MD5 (Getopt-GUI-Long-0.91.tar.gz) = b77e9516c8cf9593fa108a2eca61bb5b
+SHA256 (Getopt-GUI-Long-0.91.tar.gz) = 6393b725e2a8328afdc69993108e4be6fde07f083d94ecd66fc043df4fac9dac
+SIZE (Getopt-GUI-Long-0.91.tar.gz) = 13726
diff --git a/devel/p5-Getopt-GUI-Long/pkg-descr b/devel/p5-Getopt-GUI-Long/pkg-descr
new file mode 100644
index 000000000000..661d1c236688
--- /dev/null
+++ b/devel/p5-Getopt-GUI-Long/pkg-descr
@@ -0,0 +1,19 @@
+This module is a wrapper around Getopt::Long that extends the value of
+the original Getopt::Long module to:
+
+1) add a simple graphical user interface option screen if no arguments
+ are passed to the program.
+2) provide an auto-help mechanism such that -h and --help are handled
+ automatically.
+
+ It's designed to make the creation of graphical shells trivial without the
+ programmer having to think about it much as well as providing automatic
+ good-looking usage output without the programmer needing to write usage()
+ functions.
+
+ This also can turn normal command line programs into web CGI scripts as
+ well (automatically). If the Getopt::GUI::Long program is installed as a
+ CGI script then it will automatically prompt the user for the same
+ variables.
+
+ WWW: http://search.cpan.org/dist/Getopt-GUI-Long/
diff --git a/devel/p5-Getopt-GUI-Long/pkg-plist b/devel/p5-Getopt-GUI-Long/pkg-plist
new file mode 100644
index 000000000000..00149ee5a053
--- /dev/null
+++ b/devel/p5-Getopt-GUI-Long/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Getopt/GUI/Long.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/GUI/Long/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/GUI/Long
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/GUI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/Getopt/GUI
+@dirrmtry %%SITE_PERL%%/Getopt