aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2009-11-05 02:02:43 +0800
committerbrooks <brooks@FreeBSD.org>2009-11-05 02:02:43 +0800
commitd5d029f56241e8134c7c1a6273dd114fc6bcf723 (patch)
treef0b4171c6914e64edc8e7c6cdb76b6734c690c75 /devel
parent17fb7e839fdb5a8b8eb9066e6f6c971234aed5a0 (diff)
downloadfreebsd-ports-gnome-d5d029f56241e8134c7c1a6273dd114fc6bcf723.tar.gz
freebsd-ports-gnome-d5d029f56241e8134c7c1a6273dd114fc6bcf723.tar.zst
freebsd-ports-gnome-d5d029f56241e8134c7c1a6273dd114fc6bcf723.zip
Upgrade to r86028.
Reduce the complexity of CONFLICTS. Chase plist changes.
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm-devel/Makefile6
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/pkg-plist22
4 files changed, 24 insertions, 12 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 2e606edbe0c6..2da612de2d42 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.endif
-CONFLICTS= clang-2.6* llvm-2.[123456]* llvm-2.7.[0-9]* llvm-2.7
+CONFLICTS= clang-2.[0-9]* llvm-2.[0-9]*
GNU_CONFIGURE= yes
USE_GCC= 4.2+
@@ -129,9 +129,7 @@ PLIST_DIR_LIST= include/clang \
include/clang-c \
include/llvm-c \
include/llvm \
- lib/clang \
- share/clang \
- share/doc/clang
+ lib/clang
build-plist:
${RM} -f ${PLIST}
cd ${PREFIX} && \
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 2b4fd482fb26..28f7915b7ce0 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 85018
+SVN_REV= 86028
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 0aae77006d1c..fc3eead7a9d4 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.7.r85018.tar.bz2) = 9bd82c27bda9ed6d332271d8737a6ac0
-SHA256 (llvm-2.7.r85018.tar.bz2) = 182a8fd5ffe3bc32463b5297979be575b57911046aca437624ecf2cebb83f32d
-SIZE (llvm-2.7.r85018.tar.bz2) = 9670735
+MD5 (llvm-2.7.r86028.tar.bz2) = 2926fa1ddb908045219923abdedb8eb3
+SHA256 (llvm-2.7.r86028.tar.bz2) = 7091955b76096d44ec1a7c8dae794945ac27247503e996580283f9c753c968b7
+SIZE (llvm-2.7.r86028.tar.bz2) = 9756836
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 43aa04383914..bf9e053bcb2a 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -54,6 +54,7 @@ include/clang/AST/StmtIterator.h
include/clang/AST/StmtNodes.def
include/clang/AST/StmtObjC.h
include/clang/AST/StmtVisitor.h
+include/clang/AST/TemplateBase.h
include/clang/AST/TemplateName.h
include/clang/AST/Type.h
include/clang/AST/TypeLoc.h
@@ -76,9 +77,17 @@ include/clang/Analysis/PathSensitive/AnalysisContext.h
include/clang/Analysis/PathSensitive/AnalysisManager.h
include/clang/Analysis/PathSensitive/BasicValueFactory.h
include/clang/Analysis/PathSensitive/BugReporter.h
+include/clang/Analysis/PathSensitive/BugType.h
include/clang/Analysis/PathSensitive/Checker.h
include/clang/Analysis/PathSensitive/CheckerVisitor.def
include/clang/Analysis/PathSensitive/CheckerVisitor.h
+include/clang/Analysis/PathSensitive/Checkers/AttrNonNullChecker.h
+include/clang/Analysis/PathSensitive/Checkers/BadCallChecker.h
+include/clang/Analysis/PathSensitive/Checkers/DereferenceChecker.h
+include/clang/Analysis/PathSensitive/Checkers/DivZeroChecker.h
+include/clang/Analysis/PathSensitive/Checkers/UndefinedArgChecker.h
+include/clang/Analysis/PathSensitive/Checkers/UndefinedAssignmentChecker.h
+include/clang/Analysis/PathSensitive/Checkers/VLASizeChecker.h
include/clang/Analysis/PathSensitive/ConstraintManager.h
include/clang/Analysis/PathSensitive/Environment.h
include/clang/Analysis/PathSensitive/ExplodedGraph.h
@@ -176,6 +185,7 @@ include/clang/Frontend/CommandLineSourceLoc.h
include/clang/Frontend/CompileOptions.h
include/clang/Frontend/DeclContextXML.def
include/clang/Frontend/DeclXML.def
+include/clang/Frontend/DiagnosticOptions.h
include/clang/Frontend/DocumentXML.def
include/clang/Frontend/DocumentXML.h
include/clang/Frontend/FixItRewriter.h
@@ -288,6 +298,7 @@ include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/StringRef.h
include/llvm/ADT/StringSet.h
+include/llvm/ADT/StringSwitch.h
include/llvm/ADT/Trie.h
include/llvm/ADT/Triple.h
include/llvm/ADT/Twine.h
@@ -320,7 +331,7 @@ include/llvm/Analysis/LiveValues.h
include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
-include/llvm/Analysis/MallocHelper.h
+include/llvm/Analysis/MemoryBuiltins.h
include/llvm/Analysis/MemoryDependenceAnalysis.h
include/llvm/Analysis/Passes.h
include/llvm/Analysis/PointerTracking.h
@@ -402,6 +413,7 @@ include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/ProcessImplicitDefs.h
include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
@@ -413,6 +425,7 @@ include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
+include/llvm/CodeGen/SlotIndexes.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/CompilerDriver/Action.h
@@ -491,7 +504,6 @@ include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
-include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
include/llvm/Support/CFG.h
@@ -503,8 +515,6 @@ include/llvm/Support/ConstantFolder.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataFlow.h
-include/llvm/Support/DataTypes.h
-include/llvm/Support/DataTypes.h.cmake
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
include/llvm/Support/Dwarf.h
@@ -554,8 +564,11 @@ include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
+include/llvm/System/AIXDataTypesFix.h
include/llvm/System/Alarm.h
include/llvm/System/Atomic.h
+include/llvm/System/DataTypes.h
+include/llvm/System/DataTypes.h.cmake
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
include/llvm/System/Errno.h
@@ -872,6 +885,7 @@ libexec/clang-cc
@dirrm include/clang/Basic
@dirrm include/clang/Analysis/Visitors
@dirrm include/clang/Analysis/Support
+@dirrm include/clang/Analysis/PathSensitive/Checkers
@dirrm include/clang/Analysis/PathSensitive
@dirrm include/clang/Analysis/FlowSensitive
@dirrm include/clang/Analysis/Analyses