aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-05-02 09:46:43 +0800
committerswills <swills@FreeBSD.org>2011-05-02 09:46:43 +0800
commitda497dcbdbdbe4f59e603e3ca7f22524e8931896 (patch)
treec8407f364048e57bff9094cc75dfa2c76160428f /devel
parent6a74894b82969280725b046d903a9fb663926302 (diff)
downloadfreebsd-ports-gnome-da497dcbdbdbe4f59e603e3ca7f22524e8931896.tar.gz
freebsd-ports-gnome-da497dcbdbdbe4f59e603e3ca7f22524e8931896.tar.zst
freebsd-ports-gnome-da497dcbdbdbe4f59e603e3ca7f22524e8931896.zip
Path::Resource is a module for combining local file and directory manipulation
with URI manipulation. It allows you to effortlessly map local file locations to their URI equivalent. WWW: http://search.cpan.org/dist/Path-Resource/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Path-Resource/Makefile32
-rw-r--r--devel/p5-Path-Resource/distinfo2
-rw-r--r--devel/p5-Path-Resource/pkg-descr5
-rw-r--r--devel/p5-Path-Resource/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0818297a3462..8c8267b28935 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2108,6 +2108,7 @@
SUBDIR += p5-Path-Class
SUBDIR += p5-Path-Dispatcher
SUBDIR += p5-Path-Dispatcher-Declarative
+ SUBDIR += p5-Path-Resource
SUBDIR += p5-PathTools
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
diff --git a/devel/p5-Path-Resource/Makefile b/devel/p5-Path-Resource/Makefile
new file mode 100644
index 000000000000..44d7c85f0179
--- /dev/null
+++ b/devel/p5-Path-Resource/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Path-Resource
+# Date created: 2011-04-26
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Path-Resource
+PORTVERSION= 0.072
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RKRIMEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Perl module for combining local path manipulation and URI manipulation
+
+BUILD_DEPENDS= p5-Path-Abstract>0:${PORTSDIR}/devel/p5-Path-Abstract \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= p5-Path-Abstract>0:${PORTSDIR}/devel/p5-Path-Abstract \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= Path::Resource.3 Path::Resource::Base.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Path-Resource/distinfo b/devel/p5-Path-Resource/distinfo
new file mode 100644
index 000000000000..267e9946b174
--- /dev/null
+++ b/devel/p5-Path-Resource/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Path-Resource-0.072.tar.gz) = f77d5838c8d52e8f54c646960678310735a16f15601832970898bdcf53361ee5
+SIZE (Path-Resource-0.072.tar.gz) = 26851
diff --git a/devel/p5-Path-Resource/pkg-descr b/devel/p5-Path-Resource/pkg-descr
new file mode 100644
index 000000000000..f5dd1a105603
--- /dev/null
+++ b/devel/p5-Path-Resource/pkg-descr
@@ -0,0 +1,5 @@
+Path::Resource is a module for combining local file and directory manipulation
+with URI manipulation. It allows you to effortlessly map local file locations
+to their URI equivalent.
+
+WWW: http://search.cpan.org/dist/Path-Resource/
diff --git a/devel/p5-Path-Resource/pkg-plist b/devel/p5-Path-Resource/pkg-plist
new file mode 100644
index 000000000000..351a65b3b948
--- /dev/null
+++ b/devel/p5-Path-Resource/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Path/Resource/Base.pm
+%%SITE_PERL%%/Path/Resource.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Resource/.packlist
+@dirrmtry %%SITE_PERL%%/Path/Resource
+@dirrmtry %%SITE_PERL%%/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Resource
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path