aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-11 18:50:31 +0800
committermm <mm@FreeBSD.org>2011-07-11 18:50:31 +0800
commitda7eb3cdaee71f2b8f0cce85d449bd8f725d54d7 (patch)
treefc23e9c65d28e6f6e42d1b9afd56ebb81efbced1 /devel
parent6cd62da212763762999054311e2f4fd1c5538967 (diff)
downloadfreebsd-ports-gnome-da7eb3cdaee71f2b8f0cce85d449bd8f725d54d7.tar.gz
freebsd-ports-gnome-da7eb3cdaee71f2b8f0cce85d449bd8f725d54d7.tar.zst
freebsd-ports-gnome-da7eb3cdaee71f2b8f0cce85d449bd8f725d54d7.zip
Update to new PEAR channel infrastructure
Diffstat (limited to 'devel')
-rw-r--r--devel/pear-PHPUnit2/Makefile84
-rw-r--r--devel/pear-PHPUnit2/distinfo4
2 files changed, 18 insertions, 70 deletions
diff --git a/devel/pear-PHPUnit2/Makefile b/devel/pear-PHPUnit2/Makefile
index aa8d2ec25336..30567092e386 100644
--- a/devel/pear-PHPUnit2/Makefile
+++ b/devel/pear-PHPUnit2/Makefile
@@ -5,17 +5,29 @@
# $FreeBSD$
#
-PORTNAME= PHPUnit2
+PORTNAME= PHPUnit
PORTVERSION= 2.3.6
CATEGORIES= devel www pear
+MASTER_SITES= http://pear.phpunit.de/get/
+PKGNAMEPREFIX= pear-
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR regression testing framework for unit tests
-BUILD_DEPENDS= ${PEARDIR}/Benchmark/Timer.php:${PORTSDIR}/benchmarks/pear-Benchmark
-RUN_DEPENDS= ${BUILD_DEPENDS}
+CONFLICTS= pear-PHPUnit-[13]*
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/.channels/pear.phpunit.de.reg:${PORTSDIR}/devel/pear-channel-phpunit
+
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/.channels/pear.phpunit.de.reg:${PORTSDIR}/devel/pear-channel-phpunit \
+ ${PEARDIR}/Benchmark/Timer.php:${PORTSDIR}/benchmarks/pear-Benchmark
+
+PEAR_CHANNEL= phpunit
+PEAR_AUTOINSTALL= yes
+
+LATEST_LINK= pear-PHPUnit2
-LATEST_LINK= pear-${PORTNAME}
OPTIONS= PEAR_LOG "PEAR::Log support" off
USE_PHP= dom pcre
@@ -23,70 +35,6 @@ USE_PHP= dom pcre
DEFAULT_PHP_VER=5
IGNORE_WITH_PHP=4
-CATEGORY= PHPUnit2
-FILES= Extensions/ExceptionTestCase.php \
- Extensions/PerformanceTestCase.php Extensions/RepeatedTest.php \
- Extensions/TestDecorator.php Extensions/TestSetup.php \
- Framework/Assert.php Framework/AssertionFailedError.php \
- Framework/Error.php Framework/ComparisonFailure.php \
- Framework/IncompleteTest.php Framework/IncompleteTestError.php \
- Framework/Test.php Framework/TestCase.php \
- Framework/TestFailure.php Framework/TestListener.php \
- Framework/TestResult.php Framework/TestSuite.php \
- Framework/Warning.php Runner/BaseTestRunner.php \
- Runner/IncludePathTestCollector.php \
- Runner/StandardTestSuiteLoader.php Runner/TestCollector.php \
- Runner/TestSuiteLoader.php Runner/Version.php \
- TextUI/ResultPrinter.php TextUI/TestRunner.php \
- Util/CodeCoverage/Renderer/HTML.php \
- Util/CodeCoverage/Renderer/Text.php \
- Util/CodeCoverage/Renderer.php Util/Log/PEAR.php \
- Util/Log/XML.php Util/TestDox/ResultPrinter/HTML.php \
- Util/TestDox/ResultPrinter/Text.php \
- Util/TestDox/NamePrettifier.php Util/TestDox/ResultPrinter.php \
- Util/ErrorHandler.php Util/Fileloader.php Util/Filter.php \
- Util/Printer.php Util/Skeleton.php
-EXAMPLES= BankAccount/BankAccount.php BankAccount/BankAccountTest.php \
- Money/IMoney.php Money/Money.php Money/MoneyBag.php \
- Money/MoneyTest.php
-TESTS= Framework/AllTests.php Framework/AssertTest.php \
- Framework/ComparisonFailureTest.php Framework/SuiteTest.php \
- Framework/TestCaseTest.php Framework/TestImplementorTest.php \
- Framework/TestListenerTest.php Extensions/AllTests.php \
- Extensions/ExceptionTestCaseTest.php \
- Extensions/ExtensionTest.php \
- Extensions/PerformanceTestCaseTest.php \
- Extensions/RepeatedTestTest.php Runner/AllTests.php \
- Runner/BaseTestRunnerTest.php Util/TestDox/AllTests.php \
- Util/TestDox/NamePrettifierTest.php AllTests.php \
- DoubleTestCase.php Error.php Failure.php InheritedTestCase.php \
- MockRunner.php NoArgTestCaseTest.php NonStatic.php \
- NoTestCaseClass.php NoTestCases.php NotPublicTestCase.php \
- NotVoidTestCase.php OneTestCase.php OverrideTestCase.php \
- SetupFailure.php Sleep.php Success.php TearDownFailure.php \
- TestIterator.php ThrowExceptionTestCase.php \
- ThrowNoExceptionTestCase.php TornDown.php TornDown2.php \
- TornDown3.php TornDown4.php TornDown5.php TornDown6.php \
- WasRun.php Util/AllTests.php
-SCRIPTFILES= phpunit
-_EXAMPLESDIR= Samples
-_TESTSDIR= Tests
-
-post-extract:
- @${CP} ${WRKSRC}/${_TESTSDIR}/AllTests.php ${WRKSRC}/${_TESTSDIR}/Util
-
-post-patch:
-. for FILE in ${FILES}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/${FILE}
-. endfor
-. for FILE in ${EXAMPLES}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/${_EXAMPLESDIR}/${FILE}
-. endfor
-. for FILE in ${TESTS}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/${_TESTSDIR}/${FILE}
-. endfor
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/pear-${SCRIPTFILES}
-
.include <bsd.port.pre.mk>
.if defined(WITH_PEAR_LOG)
diff --git a/devel/pear-PHPUnit2/distinfo b/devel/pear-PHPUnit2/distinfo
index 44cc0d81c31e..4b4f9579ba6a 100644
--- a/devel/pear-PHPUnit2/distinfo
+++ b/devel/pear-PHPUnit2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PEAR/PHPUnit2-2.3.6.tgz) = 702e38cbe65519f201df535fd5c6ed7c4e3daa02a00c43f972d26ed887d8f50a
-SIZE (PEAR/PHPUnit2-2.3.6.tgz) = 44069
+SHA256 (PEAR/PHPUnit-2.3.6.tgz) = 2bb09189cf88d75f8487d4caf583eec7e38e31dea5a5741b44932b1e301a7b41
+SIZE (PEAR/PHPUnit-2.3.6.tgz) = 41548