aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2010-11-16 04:11:25 +0800
committerculot <culot@FreeBSD.org>2010-11-16 04:11:25 +0800
commitdd0b661faecd52bfb351ecb86f892bd4deb1ea19 (patch)
tree179925e567cf3139d09e4124f8b169b8611ea42f /devel
parent0111c0132cd0314fc5fc46e7b6887dfc9c7d9b57 (diff)
downloadfreebsd-ports-gnome-dd0b661faecd52bfb351ecb86f892bd4deb1ea19.tar.gz
freebsd-ports-gnome-dd0b661faecd52bfb351ecb86f892bd4deb1ea19.tar.zst
freebsd-ports-gnome-dd0b661faecd52bfb351ecb86f892bd4deb1ea19.zip
Test::Fatal is an alternative to the popular Test::Exception.
It does much less, but should allow greater flexibility in testing exception-throwing code with about the same amount of typing. WWW: http://search.cpan.org/dist/Test-Fatal/ Approved by: sahil@ (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Fatal/Makefile24
-rw-r--r--devel/p5-Test-Fatal/distinfo2
-rw-r--r--devel/p5-Test-Fatal/pkg-descr7
-rw-r--r--devel/p5-Test-Fatal/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f40c8c48ea9..5305e58acc58 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2217,6 +2217,7 @@
SUBDIR += p5-Test-Distribution
SUBDIR += p5-Test-Exception
SUBDIR += p5-Test-Expect
+ SUBDIR += p5-Test-Fatal
SUBDIR += p5-Test-File
SUBDIR += p5-Test-File-Contents
SUBDIR += p5-Test-Fixture-DBIC-Schema
diff --git a/devel/p5-Test-Fatal/Makefile b/devel/p5-Test-Fatal/Makefile
new file mode 100644
index 000000000000..17881fdc2af4
--- /dev/null
+++ b/devel/p5-Test-Fatal/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: devel/p5-Test-Fatal
+# Date created: 2010-11-15
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Fatal
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Incredibly simple helpers for testing code with exceptions
+
+BUILD_DEPENDS= p5-Try-Tiny>=0.07:${PORTSDIR}/lang/p5-Try-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Fatal.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Fatal/distinfo b/devel/p5-Test-Fatal/distinfo
new file mode 100644
index 000000000000..90d67d1d4ea3
--- /dev/null
+++ b/devel/p5-Test-Fatal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Fatal-0.003.tar.gz) = 2725dbddf64a1c6f3a5bf29dc15d167d881716ec35b2abd6e05c05b537f65184
+SIZE (Test-Fatal-0.003.tar.gz) = 11256
diff --git a/devel/p5-Test-Fatal/pkg-descr b/devel/p5-Test-Fatal/pkg-descr
new file mode 100644
index 000000000000..422ec926863b
--- /dev/null
+++ b/devel/p5-Test-Fatal/pkg-descr
@@ -0,0 +1,7 @@
+Test::Fatal is an alternative to the popular Test::Exception.
+It does much less, but should allow greater flexibility in
+testing exception-throwing code with about the same amount of
+typing.
+
+
+WWW: http://search.cpan.org/dist/Test-Fatal/
diff --git a/devel/p5-Test-Fatal/pkg-plist b/devel/p5-Test-Fatal/pkg-plist
new file mode 100644
index 000000000000..a16c02e6269f
--- /dev/null
+++ b/devel/p5-Test-Fatal/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Fatal.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Fatal/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Fatal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test
class='insertions'>+6 * dns/libasr: Unbreakyuri2018-03-182-13/+5 * Add py-idna_ssl 1.0.1sunpoet2018-03-174-0/+35 * Upgrade dnsdbq to version 1.0.0:truckman2018-03-172-6/+6 * Fix plistbdrewery2018-03-162-1/+2 * Update to 0.4.1sunpoet2018-03-142-5/+4 * dns/mdnsd: Fix package and install missing librarytobik2018-03-131-4/+7 * Update KDE Frameworks to 5.44tcberner2018-03-131-3/+3 * - Update to 1.4.1zi2018-03-122-6/+5 * Update to latest commit.mat2018-03-123-9/+9 * Bump PORTREVISIONs of all users of math/mpc that we just updated togerald2018-03-111-1/+1 * Introduce PHP flavors.mat2018-03-091-2/+2 * dns/knot-resolver: Update to 2.1.1yuri2018-03-074-17/+35 * - Add LICENSEamdmi32018-03-061-0/+4 * dns/packetq: Update to 1.4.1yuri2018-03-062-7/+6 * dns/knot-resolver: Update to 1.5.3pizzamig2018-03-063-10/+14 * Update to latest commit.mat2018-03-052-10/+12 * dns/py-dns-lexicon: Update to 2.1.20yuri2018-03-022-7/+7 * Update to 1.9.0sunpoet2018-03-012-4/+4 * - Add missing python run-dependencyamdmi32018-03-011-2/+3 * - Add LICENSEamdmi32018-03-011-6/+9 * Update dns/libpsl to 0.20.1sunpoet2018-02-273-6/+6 * Switch some MASTER_SITES from http/ftp to https.mat2018-02-27