aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-06-29 02:26:25 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-06-29 02:26:25 +0800
commite054690e359f78b2213a5eeacf727c4972f3c8fe (patch)
treef34528cac3488f8e10ad3723e438342dbbc19eae /devel
parent6a84cd73985d13aa87be58ac426d362704ec6add (diff)
downloadfreebsd-ports-gnome-e054690e359f78b2213a5eeacf727c4972f3c8fe.tar.gz
freebsd-ports-gnome-e054690e359f78b2213a5eeacf727c4972f3c8fe.tar.zst
freebsd-ports-gnome-e054690e359f78b2213a5eeacf727c4972f3c8fe.zip
- Relax *_DEPENDS: all/some of them are already in different Perl releases
- Remove WRKSRC/bin/config_data without confirmation - Bump PORTREVISION for dependency change
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Build/Makefile38
1 files changed, 26 insertions, 12 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 9a3963f6876a..f7dfbaf3f05b 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -7,25 +7,15 @@
PORTNAME= Module-Build
PORTVERSION= 0.3800
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
PKGNAMEPREFIX= p5-
-#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
MAINTAINER= perl@FreeBSD.org
COMMENT= Build and install Perl modules
-RUN_DEPENDS= p5-CPAN-Meta>=2.110420:${PORTSDIR}/devel/p5-CPAN-Meta \
- p5-ExtUtils-CBuilder>=0.27:${PORTSDIR}/devel/p5-ExtUtils-CBuilder \
- p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS \
- p5-ExtUtils-Install>=1.54:${PORTSDIR}/devel/p5-ExtUtils-Install \
- p5-Module-Metadata>=1.000002:${PORTSDIR}/devel/p5-Module-Metadata \
- p5-Perl-OSType>=1.000:${PORTSDIR}/devel/p5-Perl-OSType \
- p5-version>=0.87:${PORTSDIR}/devel/p5-version
-BUILD_DEPENDS= ${RUN_DEPENDS} \
- p5-Parse-CPAN-Meta>=1.44.01:${PORTSDIR}/devel/p5-Parse-CPAN-Meta
-
PORTSCOUT= skipv:0.31012
PERL_MODBUILD= yes
@@ -76,9 +66,33 @@ MAN1= config_data.1
PLIST_FILES= bin/config_data
.endif
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-ExtUtils-Install>=1.54:${PORTSDIR}/devel/p5-ExtUtils-Install
+RUN_DEPENDS+= p5-ExtUtils-Install>=1.54:${PORTSDIR}/devel/p5-ExtUtils-Install
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-ExtUtils-CBuilder>=0.27:${PORTSDIR}/devel/p5-ExtUtils-CBuilder \
+ p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+RUN_DEPENDS+= p5-ExtUtils-CBuilder>=0.27:${PORTSDIR}/devel/p5-ExtUtils-CBuilder \
+ p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+.endif
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-CPAN-Meta>=2.110420:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Module-Metadata>=1.000002:${PORTSDIR}/devel/p5-Module-Metadata \
+ p5-Parse-CPAN-Meta>=1.44.01:${PORTSDIR}/devel/p5-Parse-CPAN-Meta \
+ p5-Perl-OSType>=1.000:${PORTSDIR}/devel/p5-Perl-OSType \
+ p5-version>=0.87:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS+= p5-CPAN-Meta>=2.110420:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Module-Metadata>=1.000002:${PORTSDIR}/devel/p5-Module-Metadata \
+ p5-Perl-OSType>=1.000:${PORTSDIR}/devel/p5-Perl-OSType \
+ p5-version>=0.87:${PORTSDIR}/devel/p5-version
+.endif
+
post-patch:
.if ${PERL_LEVEL} >= 501000
- @${RM} ${WRKSRC}/bin/config_data
+ @${RM} -f ${WRKSRC}/bin/config_data
@${REINPLACE_CMD} -e '/script_files/d' ${WRKSRC}/Build.PL
@${REINPLACE_CMD} -e '/^bin\/config_data/d' ${WRKSRC}/MANIFEST
.endif