aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-09-25 20:21:03 +0800
committervanilla <vanilla@FreeBSD.org>2014-09-25 20:21:03 +0800
commite171e4d51462b40c012c652a4d8b88661a151f2b (patch)
treefbaaedda47f01d2f10427c7ae004b7bfca8a432d /devel
parent80effc036f682b19a6f06b239a49382f4db7fec5 (diff)
downloadfreebsd-ports-gnome-e171e4d51462b40c012c652a4d8b88661a151f2b.tar.gz
freebsd-ports-gnome-e171e4d51462b40c012c652a4d8b88661a151f2b.tar.zst
freebsd-ports-gnome-e171e4d51462b40c012c652a4d8b88661a151f2b.zip
Update to version 4.3.0.
PR: ports/193895 Submitted by: Ports Fury.
Diffstat (limited to 'devel')
-rw-r--r--devel/gecode/Makefile25
-rw-r--r--devel/gecode/distinfo4
-rw-r--r--devel/gecode/pkg-plist41
3 files changed, 35 insertions, 35 deletions
diff --git a/devel/gecode/Makefile b/devel/gecode/Makefile
index 3108f6725619..560d472b6f4e 100644
--- a/devel/gecode/Makefile
+++ b/devel/gecode/Makefile
@@ -2,18 +2,17 @@
# $FreeBSD$
PORTNAME= gecode
-PORTVERSION= 4.2.1
-PORTREVISION= 1
+PORTVERSION= 4.3.0
CATEGORIES= devel
MASTER_SITES= http://www.gecode.org/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Generic Constraint Development Environment
-LICENSE= MIT
+LICENSE= BSL MIT
+LICENSE_COMB= multi
-LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
- libmpfr.so:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= libmpfr.so:${PORTSDIR}/math/mpfr
USES= bison gmake perl5
USE_PERL5= build
@@ -36,16 +35,16 @@ CONFIGURE_ARGS= --disable-static \
--with-mpfr-lib=${LOCALBASE}/lib
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
+SHLIB= 37
-CFLAGS+= -I${LOCALBASE}/include/boost
+OPTIONS_DEFINE= GIST
+OPTIONS_SUB= yes
-OPTIONS_DEFINE= GIST
-OPTIONS_SUB= yes
-
-GIST_DESC= Interactive Search Tool (requires Qt)
-GIST_USE= QT4=corelib,gui,moc_build,qmake_build
+GIST_DESC= Interactive Search Tool (requires Qt)
+GIST_USE= QT4=corelib,gui,moc_build,qmake_build
GIST_CONFIGURE_ON= --enable-gist --enable-qt
GIST_CONFIGURE_OFF= --disable-gist --disable-qt
+PLIST_SUB= SHLIB="${SHLIB}"
.include <bsd.port.options.mk>
@@ -55,8 +54,7 @@ CFLAGS+= -D__USE_ISOC99
post-patch:
@${REINPLACE_CMD} -e \
- '/^ARR/s|^|#| ; \
- /^PACKAGE_VERSION_NUMBER/s|^|#| ; \
+ '/^PACKAGE_VERSION_NUMBER/s|^|#| ; \
/_vendor/s| == | = | ; \
/host_os/s| == | = | ; \
/gcc_optimize_flag/s|-O3|| ; \
@@ -64,5 +62,6 @@ post-patch:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fzn-gecode
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgecode*.so.[0-9]*.[0-9]*
.include <bsd.port.mk>
diff --git a/devel/gecode/distinfo b/devel/gecode/distinfo
index e09c9f5768b3..d99ecf180695 100644
--- a/devel/gecode/distinfo
+++ b/devel/gecode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gecode-4.2.1.tar.gz) = 65744cb6b90f8b95c0f69eaa133df8f201e5890834cad4eb79788c2c8f93e6e3
-SIZE (gecode-4.2.1.tar.gz) = 1898037
+SHA256 (gecode-4.3.0.tar.gz) = a789b75fd993bae0d5e5f72f0b2234396388137e8cffd4600110e3ae4db341a1
+SIZE (gecode-4.3.0.tar.gz) = 2353891
diff --git a/devel/gecode/pkg-plist b/devel/gecode/pkg-plist
index 1eaee4ec1e5f..7c082a044c27 100644
--- a/devel/gecode/pkg-plist
+++ b/devel/gecode/pkg-plist
@@ -99,6 +99,7 @@ include/gecode/int/arithmetic/pow.hpp
include/gecode/int/array-traits.hpp
include/gecode/int/array.hpp
include/gecode/int/bin-packing.hh
+include/gecode/int/bin-packing/conflict-graph.hpp
include/gecode/int/bin-packing/propagate.hpp
include/gecode/int/bool.hh
include/gecode/int/bool/base.hpp
@@ -598,35 +599,35 @@ include/gecode/third-party/boost/numeric/interval/transc.hpp
include/gecode/third-party/boost/numeric/interval/utility.hpp
include/gecode/third-party/boost/type.hpp
lib/libgecodedriver.so
-lib/libgecodedriver.so.36
-lib/libgecodedriver.so.36.0
+lib/libgecodedriver.so.%%SHLIB%%
+lib/libgecodedriver.so.%%SHLIB%%.0
lib/libgecodeflatzinc.so
-lib/libgecodeflatzinc.so.36
-lib/libgecodeflatzinc.so.36.0
+lib/libgecodeflatzinc.so.%%SHLIB%%
+lib/libgecodeflatzinc.so.%%SHLIB%%.0
lib/libgecodefloat.so
-lib/libgecodefloat.so.36
-lib/libgecodefloat.so.36.0
+lib/libgecodefloat.so.%%SHLIB%%
+lib/libgecodefloat.so.%%SHLIB%%.0
%%GIST%%lib/libgecodegist.so
-%%GIST%%lib/libgecodegist.so.36
-%%GIST%%lib/libgecodegist.so.36.0
+%%GIST%%lib/libgecodegist.so.%%SHLIB%%
+%%GIST%%lib/libgecodegist.so.%%SHLIB%%.0
lib/libgecodeint.so
-lib/libgecodeint.so.36
-lib/libgecodeint.so.36.0
+lib/libgecodeint.so.%%SHLIB%%
+lib/libgecodeint.so.%%SHLIB%%.0
lib/libgecodekernel.so
-lib/libgecodekernel.so.36
-lib/libgecodekernel.so.36.0
+lib/libgecodekernel.so.%%SHLIB%%
+lib/libgecodekernel.so.%%SHLIB%%.0
lib/libgecodeminimodel.so
-lib/libgecodeminimodel.so.36
-lib/libgecodeminimodel.so.36.0
+lib/libgecodeminimodel.so.%%SHLIB%%
+lib/libgecodeminimodel.so.%%SHLIB%%.0
lib/libgecodesearch.so
-lib/libgecodesearch.so.36
-lib/libgecodesearch.so.36.0
+lib/libgecodesearch.so.%%SHLIB%%
+lib/libgecodesearch.so.%%SHLIB%%.0
lib/libgecodeset.so
-lib/libgecodeset.so.36
-lib/libgecodeset.so.36.0
+lib/libgecodeset.so.%%SHLIB%%
+lib/libgecodeset.so.%%SHLIB%%.0
lib/libgecodesupport.so
-lib/libgecodesupport.so.36
-lib/libgecodesupport.so.36.0
+lib/libgecodesupport.so.%%SHLIB%%
+lib/libgecodesupport.so.%%SHLIB%%.0
%%DATADIR%%/mznlib/all_different_int.mzn
%%DATADIR%%/mznlib/all_equal_int.mzn
%%DATADIR%%/mznlib/among.mzn