aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2016-10-05 14:54:47 +0800
committerbsam <bsam@FreeBSD.org>2016-10-05 14:54:47 +0800
commite41fa9978c53ccdf0d3b4120bdfe511abea3641b (patch)
tree713d65e3255b7458a0fbd8190eabcefbd007646f /devel
parent92510641460f6d44eca28be07b7ea5608f9ee552 (diff)
downloadfreebsd-ports-gnome-e41fa9978c53ccdf0d3b4120bdfe511abea3641b.tar.gz
freebsd-ports-gnome-e41fa9978c53ccdf0d3b4120bdfe511abea3641b.tar.zst
freebsd-ports-gnome-e41fa9978c53ccdf0d3b4120bdfe511abea3641b.zip
JNI of the Artistic Style source code indenter, formatter, and beautifier.
Artistic Style is a source code indenter, formatter, and beautifier for the C, C++, C# and Java programming languages. It automatically re-indents and re-formats source files and can be used from a command line. WWW: http://astyle.sourceforge.net/ Note: this library is used by a native Arduino IDE 1.6.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libastylej/Makefile36
-rw-r--r--devel/libastylej/distinfo3
-rw-r--r--devel/libastylej/pkg-descr7
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 695198259897..891c9d56a9be 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1161,6 +1161,7 @@
SUBDIR += libassa
SUBDIR += libassetml
SUBDIR += libast
+ SUBDIR += libastylej
SUBDIR += libatomic_ops
SUBDIR += libaura
SUBDIR += libavl
diff --git a/devel/libastylej/Makefile b/devel/libastylej/Makefile
new file mode 100644
index 000000000000..e74843cc315d
--- /dev/null
+++ b/devel/libastylej/Makefile
@@ -0,0 +1,36 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libastylej
+PORTVERSION= 2.05.1
+CATEGORIES= devel java textproc
+ASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
+DISTNAME= astyle_${PORTVERSION}_linux
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Source code indenter, formatter, and beautifier (JNI library)
+
+LICENSE= LGPL3
+
+ALL_TARGET= java
+LDFLAGS+= -s
+USES= compiler gmake
+USE_JAVA= yes
+USE_LDCONFIG= yes
+MAKE_ARGS+= JAVA_HOME=${JAVA_HOME}
+
+WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
+
+PLIST_FILES= lib/jni/libastylej.so lib/jni/libastyle-${PORTVERSION}j.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,\(JAVAINCS.*=.*\),\1 -I$(JAVA_HOME)/include/freebsd,' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/jni
+ ${INSTALL_DATA} ${WRKSRC}/bin/*.so ${STAGEDIR}${PREFIX}/lib/jni
+ ${LN} -sf libastyle-${PORTVERSION}j.so \
+ ${STAGEDIR}${PREFIX}/lib/jni/libastylej.so
+
+.include <bsd.port.mk>
diff --git a/devel/libastylej/distinfo b/devel/libastylej/distinfo
new file mode 100644
index 000000000000..076baedeb15e
--- /dev/null
+++ b/devel/libastylej/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475650394
+SHA256 (astyle_2.05.1_linux.tar.gz) = fbdfc6f1966a972d19a215927266c76d4183eee235ed1e2bd7ec551c2a270eac
+SIZE (astyle_2.05.1_linux.tar.gz) = 152765
diff --git a/devel/libastylej/pkg-descr b/devel/libastylej/pkg-descr
new file mode 100644
index 000000000000..fe27761e88f4
--- /dev/null
+++ b/devel/libastylej/pkg-descr
@@ -0,0 +1,7 @@
+JNI of the Artistic Style source code indenter, formatter, and beautifier.
+
+Artistic Style is a source code indenter, formatter, and beautifier for the C,
+C++, C# and Java programming languages. It automatically re-indents and
+re-formats source files and can be used from a command line.
+
+WWW: http://astyle.sourceforge.net/