aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-11-12 10:16:58 +0800
committerswills <swills@FreeBSD.org>2014-11-12 10:16:58 +0800
commite46660492838767e6bb23b17d17d5b159e649df5 (patch)
tree637c7759318f9d26110fe0978a91eec2f1a29207 /devel
parentfd23e82b535e3da1ae4c9e6be54b9dfceb0b8852 (diff)
downloadfreebsd-ports-gnome-e46660492838767e6bb23b17d17d5b159e649df5.tar.gz
freebsd-ports-gnome-e46660492838767e6bb23b17d17d5b159e649df5.tar.zst
freebsd-ports-gnome-e46660492838767e6bb23b17d17d5b159e649df5.zip
Mark broken with Ruby 2.1
With hat: ruby@
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-langscan/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/ruby-langscan/Makefile b/devel/ruby-langscan/Makefile
index 2da68e803b05..4db5e178e91d 100644
--- a/devel/ruby-langscan/Makefile
+++ b/devel/ruby-langscan/Makefile
@@ -64,4 +64,10 @@ x-generate-plist:
${FIND} ${RUBY_SITELIBDIR}/${PORTNAME} -type d -depth | ${SORT} -r | ${SED} -e 's,${RUBY_SITELIBDIR},@dirrm %%RUBY_SITELIBDIR%%,' >> pkg-plist.new
${FIND} ${RUBY_SITEARCHLIBDIR}/${PORTNAME} -type d -depth | ${SORT} -r | ${SED} -e 's,${RUBY_SITEARCHLIBDIR},@dirrm %%RUBY_SITEARCHLIBDIR%%,' >> pkg-plist.new
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 2.1
+BROKEN= Does not build with Ruby 2.1
+.endif
+
+.include <bsd.port.post.mk>