aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-11-14 23:02:49 +0800
committerpi <pi@FreeBSD.org>2015-11-14 23:02:49 +0800
commite51ead5b326f53e3d5a82976e42e762992f3722e (patch)
tree19eda63551903a07c3c84080b3367d41f5e2d282 /devel
parentfa7b111dc3c7cd29c9ee54878c62dad31f4b9fc0 (diff)
downloadfreebsd-ports-gnome-e51ead5b326f53e3d5a82976e42e762992f3722e.tar.gz
freebsd-ports-gnome-e51ead5b326f53e3d5a82976e42e762992f3722e.tar.zst
freebsd-ports-gnome-e51ead5b326f53e3d5a82976e42e762992f3722e.zip
devel/py-pip: 7.0.3 -> 7.1.2
Changes: https://pip.pypa.io/en/stable/news/ See also: https://reviews.freebsd.org/D4106 PR: 204367 Reviewed by: antoine, koobs, nivit Approved by: nivit (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-pip/Makefile24
-rw-r--r--devel/py-pip/distinfo4
-rw-r--r--devel/py-pip/files/patch-setup.cfg2
-rw-r--r--devel/py-pip/files/patch-setup.py4
-rw-r--r--devel/py-pip/pkg-plist74
5 files changed, 13 insertions, 95 deletions
diff --git a/devel/py-pip/Makefile b/devel/py-pip/Makefile
index 05e58327703c..60165425cdd4 100644
--- a/devel/py-pip/Makefile
+++ b/devel/py-pip/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= pip
-PORTVERSION= 7.0.3
+PORTVERSION= 7.1.2
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= nivit@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= Tool for installing and managing Python packages
LICENSE= MIT
@@ -27,7 +27,9 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
-DOCS_MAKE_ENV= HOME=${WRKDIR}
+DOCS_PORTDOCS= *
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET=build_sphinx \
+ PYDISTUTILS_BUILDARGS="-n --all-files --fresh-env"
USES= python shebangfix
USE_GITHUB= yes
@@ -37,22 +39,12 @@ SHEBANG_FILES= pip/__init__.py
GH_ACCOUNT= pypa
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-PYDISTUTILS_BUILD_TARGET+= build_sphinx -n --all-files --fresh-env
-.endif
-
-post-install:
-# ${RM} ${STAGEDIR}${PREFIX}/bin/pip2
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/build/sphinx/html && \
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objects.inv")
-.endif
-regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/devel/py-pip/distinfo b/devel/py-pip/distinfo
index 8d6028fced9b..7e1203ce41a3 100644
--- a/devel/py-pip/distinfo
+++ b/devel/py-pip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pypa-pip-7.0.3_GH0.tar.gz) = 00d52c4a846ea3849489a473c3c4902237d31fa950068148badb4f43e8213fa2
-SIZE (pypa-pip-7.0.3_GH0.tar.gz) = 7848309
+SHA256 (pypa-pip-7.1.2_GH0.tar.gz) = a45494a8e3041b1bbf5976598f7075e305afd54ebb655395be6f3df2ea0c2733
+SIZE (pypa-pip-7.1.2_GH0.tar.gz) = 7837584
diff --git a/devel/py-pip/files/patch-setup.cfg b/devel/py-pip/files/patch-setup.cfg
index 87e081e8237b..2c38ba8d99a1 100644
--- a/devel/py-pip/files/patch-setup.cfg
+++ b/devel/py-pip/files/patch-setup.cfg
@@ -1,4 +1,4 @@
---- setup.cfg.orig 2015-06-02 01:28:40 UTC
+--- setup.cfg.orig 2015-08-22 22:46:55 UTC
+++ setup.cfg
@@ -1,5 +1,6 @@
[pytest]
diff --git a/devel/py-pip/files/patch-setup.py b/devel/py-pip/files/patch-setup.py
index aa98ac870356..78f0c0ade243 100644
--- a/devel/py-pip/files/patch-setup.py
+++ b/devel/py-pip/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2015-06-19 02:39:23 UTC
+--- setup.py.orig 2015-11-14 14:08:36 UTC
+++ setup.py
-@@ -98,8 +98,6 @@ setup(
+@@ -78,8 +78,6 @@ setup(
entry_points={
"console_scripts": [
"pip=pip:main",
diff --git a/devel/py-pip/pkg-plist b/devel/py-pip/pkg-plist
deleted file mode 100644
index 8713c8fd8f5d..000000000000
--- a/devel/py-pip/pkg-plist
+++ /dev/null
@@ -1,74 +0,0 @@
-%%PORTDOCS%%%%DOCSDIR%%/_sources/configuration.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/cookbook.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/development.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/index.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/installing.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/logic.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/news.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/quickstart.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/index.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_freeze.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_install.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_list.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_search.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_show.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_uninstall.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_wheel.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/usage.txt
-%%PORTDOCS%%%%DOCSDIR%%/_sources/user_guide.txt
-%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
-%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/css/badge_only.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/css/theme.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/Inconsolata-Bold.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/Inconsolata.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/Lato-Bold.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/Lato-Regular.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/RobotoSlab-Bold.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/RobotoSlab-Regular.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.eot
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.svg
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.ttf
-%%PORTDOCS%%%%DOCSDIR%%/_static/fonts/fontawesome-webfont.woff
-%%PORTDOCS%%%%DOCSDIR%%/_static/jquery-1.11.1.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/js/modernizr.min.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/js/theme.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
-%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/underscore-1.3.1.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
-%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
-%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
-%%PORTDOCS%%%%DOCSDIR%%/configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/cookbook.html
-%%PORTDOCS%%%%DOCSDIR%%/development.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/installing.html
-%%PORTDOCS%%%%DOCSDIR%%/logic.html
-%%PORTDOCS%%%%DOCSDIR%%/news.html
-%%PORTDOCS%%%%DOCSDIR%%/quickstart.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_freeze.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_install.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_list.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_search.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_show.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_uninstall.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/pip_wheel.html
-%%PORTDOCS%%%%DOCSDIR%%/search.html
-%%PORTDOCS%%%%DOCSDIR%%/searchindex.js
-%%PORTDOCS%%%%DOCSDIR%%/usage.html
-%%PORTDOCS%%%%DOCSDIR%%/user_guide.html