aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2011-04-12 03:54:35 +0800
committerade <ade@FreeBSD.org>2011-04-12 03:54:35 +0800
commitefd0dd922d2e5cd332f1aee5fdf6810814e7f400 (patch)
treee271fb9ea44573beae8c29a58a911ee2aa3b3448 /devel
parent97b1c095bb1886b4b943dd0175183d8d02a3fbb7 (diff)
downloadfreebsd-ports-gnome-efd0dd922d2e5cd332f1aee5fdf6810814e7f400.tar.gz
freebsd-ports-gnome-efd0dd922d2e5cd332f1aee5fdf6810814e7f400.tar.zst
freebsd-ports-gnome-efd0dd922d2e5cd332f1aee5fdf6810814e7f400.zip
Update to GNU make 3.82 after numerous -exp runs.
Diffstat (limited to 'devel')
-rw-r--r--devel/allegro/files/patch-makefile.in115
-rw-r--r--devel/cc65/Makefile4
-rw-r--r--devel/deputy/Makefile1
-rw-r--r--devel/gmake/Makefile3
-rw-r--r--devel/gmake/distinfo5
-rw-r--r--devel/gmake/files/patch-ab15
-rw-r--r--devel/gmake/files/patch-make.h12
-rw-r--r--devel/gmake/files/patch-read.c52
-rw-r--r--devel/gmake/pkg-plist5
-rw-r--r--devel/gmake381/Makefile32
-rw-r--r--devel/gmake381/distinfo2
-rw-r--r--devel/gmake381/files/patch-make.h12
-rw-r--r--devel/gmake381/pkg-descr5
-rw-r--r--devel/hyena/Makefile2
-rw-r--r--devel/psptoolchain-binutils/files/patch-gprof-Makefile.in11
15 files changed, 171 insertions, 105 deletions
diff --git a/devel/allegro/files/patch-makefile.in b/devel/allegro/files/patch-makefile.in
index 89e7e2189e73..a8df271be4ad 100644
--- a/devel/allegro/files/patch-makefile.in
+++ b/devel/allegro/files/patch-makefile.in
@@ -1,23 +1,17 @@
---- makefile.in.orig Fri Jun 15 22:52:28 2007
-+++ makefile.in Fri Jul 13 14:52:12 2007
-@@ -29,11 +29,12 @@
- INFO_DIR = $(infodir)/dir
- DESTDIR =
+--- makefile.in.orig 2007-07-22 00:55:54.000000000 -0500
++++ makefile.in 2011-03-25 17:23:23.000000000 -0500
+@@ -31,4 +31,4 @@
-ACLOCAL = aclocal
-AUTOCONF = autoconf
+ACLOCAL = true
+AUTOCONF = true
- INSTALL = @INSTALL@
+@@ -36,2 +36,3 @@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
- INSTALL_INFO = @INSTALL_INFO@
-
-@@ -352,6 +353,11 @@
- endif
-
+@@ -355,2 +356,7 @@
lib: $(ALLEGRO_LIB_TARGETS)
+ @for l in alleg alld allp; do \
+ if test -f $(LIBDIR)/lib$${l}.so.$(shared_version); then \
@@ -25,11 +19,92 @@
+ fi; \
+ done
- modules: $(ALLEGRO_MODULE_TARGETS)
-
-@@ -463,9 +469,9 @@
- fi; \
- done
+@@ -399,43 +405,43 @@
+ # -------- rules for deleting the generated files --------
+-
+-clean:
+-
+- define RM_OBJ_CLEAN_FILES
+- $(foreach file, $(OBJ_CLEAN_FILES), rm -f $(file)
+- )
+- endef
+-
+- define RM_OTHER_CLEAN_FILES
+- $(foreach file, $(OTHER_CLEAN_FILES), rm -f $(file)
+- )
+- endef
+-
+- $(RM_OBJ_CLEAN_FILES)
+- $(RM_OTHER_CLEAN_FILES)
+-
+-distclean: clean
+-
+- define RM_DISTCLEAN_FILES
+- $(foreach file, $(DISTCLEAN_FILES) $(ALLEGRO_LIB_X_EXES), rm -f $(file)
+- )
+- endef
+-
+- $(RM_DISTCLEAN_FILES)
+-
+-veryclean: distclean
+-
+- define RM_VERYCLEAN_FILES
+- $(foreach file, $(VERYCLEAN_FILES), rm -f $(file)
+- )
+- endef
+-
+- $(RM_VERYCLEAN_FILES)
+- rm -f makefile
+-
+-maintainer-clean: veryclean
+- rm -f configure include/allegro/platform/alunixac.hin
+- rm -rf autom4te*
+-
+-
+-
++# XXX: whacked out with gmake 3.82
++# clean:
++#
++# define RM_OBJ_CLEAN_FILES
++# $(foreach file, $(OBJ_CLEAN_FILES), rm -f $(file)
++# )
++# endef
++#
++# define RM_OTHER_CLEAN_FILES
++# $(foreach file, $(OTHER_CLEAN_FILES), rm -f $(file)
++# )
++# endef
++#
++# $(RM_OBJ_CLEAN_FILES)
++# $(RM_OTHER_CLEAN_FILES)
++#
++# distclean: clean
++#
++# define RM_DISTCLEAN_FILES
++# $(foreach file, $(DISTCLEAN_FILES) $(ALLEGRO_LIB_X_EXES), rm -f $(file)
++# )
++# endef
++#
++# $(RM_DISTCLEAN_FILES)
++#
++# veryclean: distclean
++#
++# define RM_VERYCLEAN_FILES
++# $(foreach file, $(VERYCLEAN_FILES), rm -f $(file)
++# )
++# endef
++#
++# $(RM_VERYCLEAN_FILES)
++# rm -f makefile
++#
++# maintainer-clean: veryclean
++# rm -f configure include/allegro/platform/alunixac.hin
++# rm -rf autom4te*
++#
++#
++#
+ # -------- rules for installing the files --------
+@@ -466,5 +472,5 @@
@for l in alleg alld allp; do \
- if test -f $(LIBDIR)/lib$${l}-$(shared_version).so; then \
- echo Installing $(LIBDIR)/lib$${l}-$(shared_version).so to $(DESTDIR)$(libdir); \
@@ -38,11 +113,7 @@
+ echo Installing $(LIBDIR)/lib$${l}.so.$(shared_version) to $(libdir); \
+ $(INSTALL_PROGRAM) $(LIBDIR)/lib$${l}.so.$(shared_version) $(libdir)/; \
$(INSTALL_DATA) $(LIBDIR)/lib$${l}_unsharable.a $(DESTDIR)$(libdir)/; \
- fi; \
- done
-@@ -479,20 +485,10 @@
- fi
- $(mkinstalldirs) $(DESTDIR)$(bindir)
+@@ -482,16 +488,6 @@
@echo Installing allegro-config to $(DESTDIR)$(bindir)
- @$(INSTALL_PROGRAM) allegro-config $(DESTDIR)$(bindir)
- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
@@ -62,5 +133,3 @@
+ if test -f $(DESTDIR)$(libdir)/lib$${l}.so.$(shared_version) -a \! -h $(DESTDIR)$(libdir)/lib$${l}.so; then \
+ (cd $(DESTDIR)$(libdir); ln -s lib$${l}.so.$(shared_version) lib$${l}.so); \
fi; \
- done
- $(mkinstalldirs) $(DESTDIR)$(prefix)/share/aclocal
diff --git a/devel/cc65/Makefile b/devel/cc65/Makefile
index 4c324d1add01..9900674725a6 100644
--- a/devel/cc65/Makefile
+++ b/devel/cc65/Makefile
@@ -45,6 +45,10 @@ post-patch:
-e "s,^(CC65_DOC[[:space:]]*=).*,\1," ${WRKSRC}/make/gcc.mak
.endif
+# XXX: gmake>=3.82 hack: beats the hell out of me. Quick fix.
+pre-install:
+ @${MKDIR} -p ${PREFIX}/lib/cc65/tgi
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
diff --git a/devel/deputy/Makefile b/devel/deputy/Makefile
index 8c87c3b26867..5ae675744254 100644
--- a/devel/deputy/Makefile
+++ b/devel/deputy/Makefile
@@ -36,6 +36,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|^use OutputFile;|use CIL::OutputFile;|' ${WRKSRC}/cil/lib/TempFile.pm
@${REINPLACE_CMD} -e 's|^use Cilly;|use CIL::Cilly;|' ${WRKSRC}/lib/Deputy.pm
@${REINPLACE_CMD} -e 's|$$::deputyhome|${PREFIX}|g; s|obj/$$::archos|libexec/deputy|g' ${WRKSRC}/lib/Deputy.pm
+# @${REINPLACE_CMD} -e '/ NATIVECAML=1/s/^/#gmake-3.82 BUG/' ${WRKSRC}/Makefile.in
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/deputy ${PREFIX}/bin/
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index 10bb1943d67b..d48342ab0494 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmake
-PORTVERSION= 3.81
-PORTREVISION= 4
+PORTVERSION= 3.82
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= make
diff --git a/devel/gmake/distinfo b/devel/gmake/distinfo
index a6410079661f..6f75d6baced1 100644
--- a/devel/gmake/distinfo
+++ b/devel/gmake/distinfo
@@ -1,3 +1,2 @@
-MD5 (make-3.81.tar.bz2) = 354853e0b2da90c527e35aabb8d6f1e6
-SHA256 (make-3.81.tar.bz2) = f3e69023771e23908f5d5592954d8271d3d6af09693cecfd29cee6fde8550dc8
-SIZE (make-3.81.tar.bz2) = 1151445
+SHA256 (make-3.82.tar.bz2) = e2c1a73f179c40c71e2fe8abf8a8a0688b8499538512984da4a76958d0402966
+SIZE (make-3.82.tar.bz2) = 1242186
diff --git a/devel/gmake/files/patch-ab b/devel/gmake/files/patch-ab
index 4d7d9551e18b..f4bcc7661b0c 100644
--- a/devel/gmake/files/patch-ab
+++ b/devel/gmake/files/patch-ab
@@ -1,14 +1,7 @@
---- doc/make.texi.orig Mon Oct 7 22:57:59 2002
-+++ doc/make.texi Mon Oct 7 22:58:03 2002
-@@ -25,9 +25,9 @@
- @c Combine the program and concept indices:
- @syncodeindex pg cp
-
--@dircategory GNU Packages
-+@dircategory Programming & development tools
+--- doc/make.texi.orig 2010-07-19 02:10:54.000000000 -0500
++++ doc/make.texi 2011-03-02 17:01:58.000000000 -0600
+@@ -54,3 +54,3 @@
@direntry
-* Make: (make). Remake files automatically.
-+* GNU make: (make). Remake files automatically.
++* GNU Make: (make). Remake files automatically.
@end direntry
-
- @ifinfo
diff --git a/devel/gmake/files/patch-make.h b/devel/gmake/files/patch-make.h
deleted file mode 100644
index 28a63d2eb076..000000000000
--- a/devel/gmake/files/patch-make.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- make.h.orig Wed Sep 11 18:55:44 2002
-+++ make.h Mon Oct 21 22:05:11 2002
-@@ -33,7 +33,7 @@
- # ifdef _AIX
- #pragma alloca
- # else
--# ifndef alloca /* predefined by HP cc +Olibcalls */
-+# if !defined (alloca) && !defined (__FreeBSD__) /* predefined by HP cc +Olibcalls, part of stdlib.h on FreeBSD */
- char *alloca ();
- # endif
- # endif
-
diff --git a/devel/gmake/files/patch-read.c b/devel/gmake/files/patch-read.c
new file mode 100644
index 000000000000..4ca91c48663c
--- /dev/null
+++ b/devel/gmake/files/patch-read.c
@@ -0,0 +1,52 @@
+Add a fix for bug #30612 (http://savannah.gnu.org/bugs/index.php?30612)
+from GNU make's CVS repository (revision 1.194).
+
+Taken from pkgsrc repository: devel/gmake/patches/patch-ah
+
+--- read.c.orig 2010-07-13 01:20:42.000000000 +0000
++++ read.c
+@@ -3028,7 +3028,7 @@ parse_file_seq (char **stringp, unsigned
+ {
+ /* This looks like the first element in an open archive group.
+ A valid group MUST have ')' as the last character. */
+- const char *e = p + nlen;
++ const char *e = p;
+ do
+ {
+ e = next_token (e);
+@@ -3084,19 +3084,19 @@ parse_file_seq (char **stringp, unsigned
+ Go to the next item in the string. */
+ if (flags & PARSEFS_NOGLOB)
+ {
+- NEWELT (concat (2, prefix, tp));
++ NEWELT (concat (2, prefix, tmpbuf));
+ continue;
+ }
+
+ /* If we get here we know we're doing glob expansion.
+ TP is a string in tmpbuf. NLEN is no longer used.
+ We may need to do more work: after this NAME will be set. */
+- name = tp;
++ name = tmpbuf;
+
+ /* Expand tilde if applicable. */
+- if (tp[0] == '~')
++ if (tmpbuf[0] == '~')
+ {
+- tildep = tilde_expand (tp);
++ tildep = tilde_expand (tmpbuf);
+ if (tildep != 0)
+ name = tildep;
+ }
+@@ -3152,7 +3152,10 @@ parse_file_seq (char **stringp, unsigned
+ else
+ {
+ /* We got a chain of items. Attach them. */
+- (*newp)->next = found;
++ if (*newp)
++ (*newp)->next = found;
++ else
++ *newp = found;
+
+ /* Find and set the new end. Massage names if necessary. */
+ while (1)
diff --git a/devel/gmake/pkg-plist b/devel/gmake/pkg-plist
index 596ac18a9553..d2135903549e 100644
--- a/devel/gmake/pkg-plist
+++ b/devel/gmake/pkg-plist
@@ -10,17 +10,16 @@ bin/gmake
%%NLS%%share/locale/he/LC_MESSAGES/make.mo
%%NLS%%share/locale/hr/LC_MESSAGES/make.mo
%%NLS%%share/locale/id/LC_MESSAGES/make.mo
+%%NLS%%share/locale/it/LC_MESSAGES/make.mo
%%NLS%%share/locale/ja/LC_MESSAGES/make.mo
%%NLS%%share/locale/ko/LC_MESSAGES/make.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/make.mo
%%NLS%%share/locale/nl/LC_MESSAGES/make.mo
%%NLS%%share/locale/pl/LC_MESSAGES/make.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/make.mo
%%NLS%%share/locale/ru/LC_MESSAGES/make.mo
-%%NLS%%share/locale/rw/LC_MESSAGES/make.mo
%%NLS%%share/locale/sv/LC_MESSAGES/make.mo
%%NLS%%share/locale/tr/LC_MESSAGES/make.mo
%%NLS%%share/locale/uk/LC_MESSAGES/make.mo
%%NLS%%share/locale/vi/LC_MESSAGES/make.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/make.mo
-%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/rw
diff --git a/devel/gmake381/Makefile b/devel/gmake381/Makefile
deleted file mode 100644
index a6f05464a21e..000000000000
--- a/devel/gmake381/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-# New ports collection makefile for: GNU make
-# Date created: 11 September 1994
-# Whom: jkh
-#
-# $FreeBSD$
-#
-
-PORTNAME= gmake381
-PORTVERSION= 3.81
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= make
-DISTNAME= make-${PORTVERSION}
-
-MAINTAINER= autotools@FreeBSD.org
-COMMENT= GNU version of 'make' utility (3.81 legacy version)
-
-IGNORE= Internal infrastructure usage only. Do _not_ use directly.
-
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-nls
-PLIST_FILES= bin/gmake381
-
-.ifdef USE_GMAKE
-.error You have `USE_GMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/make ${PREFIX}/bin/gmake381
-
-.include <bsd.port.mk>
diff --git a/devel/gmake381/distinfo b/devel/gmake381/distinfo
deleted file mode 100644
index f43fc5ab1aa3..000000000000
--- a/devel/gmake381/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (make-3.81.tar.bz2) = f3e69023771e23908f5d5592954d8271d3d6af09693cecfd29cee6fde8550dc8
-SIZE (make-3.81.tar.bz2) = 1151445
diff --git a/devel/gmake381/files/patch-make.h b/devel/gmake381/files/patch-make.h
deleted file mode 100644
index 28a63d2eb076..000000000000
--- a/devel/gmake381/files/patch-make.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- make.h.orig Wed Sep 11 18:55:44 2002
-+++ make.h Mon Oct 21 22:05:11 2002
-@@ -33,7 +33,7 @@
- # ifdef _AIX
- #pragma alloca
- # else
--# ifndef alloca /* predefined by HP cc +Olibcalls */
-+# if !defined (alloca) && !defined (__FreeBSD__) /* predefined by HP cc +Olibcalls, part of stdlib.h on FreeBSD */
- char *alloca ();
- # endif
- # endif
-
diff --git a/devel/gmake381/pkg-descr b/devel/gmake381/pkg-descr
deleted file mode 100644
index d7f5370aeb8b..000000000000
--- a/devel/gmake381/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-GNU make is a tool that controls the generation of executables and other
-non-source files from source files. Its purpose is the same as that
-of the utility make(1).
-
-WWW: http://www.gnu.org/software/make/make.html
diff --git a/devel/hyena/Makefile b/devel/hyena/Makefile
index 9a94b27336c1..bfd0ade4516f 100644
--- a/devel/hyena/Makefile
+++ b/devel/hyena/Makefile
@@ -22,5 +22,7 @@ USE_GNOME= gtksharp20
post-patch:
@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(libdir)/../libdata/pkgconfig|g' \
${WRKSRC}/build/pkg-config/Makefile.in
+ @${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
+ ${REINPLACE_CMD} -e 's/^dnl/# dnl/'
.include <bsd.port.mk>
diff --git a/devel/psptoolchain-binutils/files/patch-gprof-Makefile.in b/devel/psptoolchain-binutils/files/patch-gprof-Makefile.in
new file mode 100644
index 000000000000..b9375e17b5c3
--- /dev/null
+++ b/devel/psptoolchain-binutils/files/patch-gprof-Makefile.in
@@ -0,0 +1,11 @@
+--- gprof/Makefile.in.orig 2004-11-30 11:20:48.000000000 -0600
++++ gprof/Makefile.in 2011-03-26 14:42:27.000000000 -0500
+@@ -231,3 +231,2 @@
+ AUTOMAKE_OPTIONS = cygnus
+-SUFFIXES = .m
+ SUBDIRS = po
+@@ -264,4 +263,2 @@
+
+-.SUFFIXES:
+-.SUFFIXES: .m .c .dvi .html .info .lo .o .obj .pdf .ps .texi
+ am--refresh: