aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2014-05-05 08:59:29 +0800
committermi <mi@FreeBSD.org>2014-05-05 08:59:29 +0800
commitf80e445fea815f81675ef1d3acf9f72489e6585a (patch)
tree4cb1f4b5b20115e64fe84887745cf8a3278f9e00 /devel
parentb0cab3c875c72e5a21ccd526815aba9c0e18c004 (diff)
downloadfreebsd-ports-gnome-f80e445fea815f81675ef1d3acf9f72489e6585a.tar.gz
freebsd-ports-gnome-f80e445fea815f81675ef1d3acf9f72489e6585a.tar.zst
freebsd-ports-gnome-f80e445fea815f81675ef1d3acf9f72489e6585a.zip
Upgrade from 0.21 to 0.22. This introduces an API-incompatibility, but,
because the ABI remains the same, I am not upping shared library version. Notified by: portscout
Diffstat (limited to 'devel')
-rw-r--r--devel/jech-dht/Makefile2
-rw-r--r--devel/jech-dht/distinfo4
-rw-r--r--devel/jech-dht/files/BSDmakefile2
-rw-r--r--devel/jech-dht/files/patch-warns7
4 files changed, 4 insertions, 11 deletions
diff --git a/devel/jech-dht/Makefile b/devel/jech-dht/Makefile
index 2d2697464d33..5dc9a955d993 100644
--- a/devel/jech-dht/Makefile
+++ b/devel/jech-dht/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dht
-PORTVERSION= 0.21
+PORTVERSION= 0.22
CATEGORIES= devel
MASTER_SITES= http://www.pps.univ-paris-diderot.fr/~jch/software/files/
diff --git a/devel/jech-dht/distinfo b/devel/jech-dht/distinfo
index 87d93eb60992..e64a8de0ff49 100644
--- a/devel/jech-dht/distinfo
+++ b/devel/jech-dht/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dht-0.21.tar.gz) = edf8fd9bf6225bbced38a74bb40592d46876fdfb74e9ebddecbdc1e805bdf44f
-SIZE (dht-0.21.tar.gz) = 27578
+SHA256 (dht-0.22.tar.gz) = a3452322648660da43cabd34cff8505d8f655e988f31c467535ad1992c29ac3d
+SIZE (dht-0.22.tar.gz) = 27380
diff --git a/devel/jech-dht/files/BSDmakefile b/devel/jech-dht/files/BSDmakefile
index 46fe58b06d22..5b5f554da8af 100644
--- a/devel/jech-dht/files/BSDmakefile
+++ b/devel/jech-dht/files/BSDmakefile
@@ -1,6 +1,6 @@
LIB= dht
SHLIB_MAJOR= 0
-SHLIB_MINOR= 21
+SHLIB_MINOR= 22
NO_PROFILE= yes
SRCS= dht.c
diff --git a/devel/jech-dht/files/patch-warns b/devel/jech-dht/files/patch-warns
index a2a8c2c737b1..4aa08286a205 100644
--- a/devel/jech-dht/files/patch-warns
+++ b/devel/jech-dht/files/patch-warns
@@ -14,13 +14,6 @@
+ const struct sockaddr_in6 *sin6 = (const struct sockaddr_in6*)sa;
const unsigned char *address = (const unsigned char*)&sin6->sin6_addr;
return sin6->sin6_port == 0 ||
-@@ -687,5 +687,5 @@
- int i;
-
-- if(salen > sizeof(struct sockaddr_storage))
-+ if((unsigned)salen > sizeof(struct sockaddr_storage))
- abort();
-
@@ -1281,13 +1281,13 @@
int i, len;
struct storage *st;