aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-06-05 16:29:18 +0800
committerbsam <bsam@FreeBSD.org>2009-06-05 16:29:18 +0800
commit07191d0e09b1203e028d317a9c868dc73b84e3fb (patch)
tree7e8bff3c19a090c6f30117f6ad12c3b6585545d6 /devel
parent8c13cb85d363f83b44de0a015b1ccd3c81887c6f (diff)
downloadfreebsd-ports-gnome-07191d0e09b1203e028d317a9c868dc73b84e3fb.tar.gz
freebsd-ports-gnome-07191d0e09b1203e028d317a9c868dc73b84e3fb.tar.zst
freebsd-ports-gnome-07191d0e09b1203e028d317a9c868dc73b84e3fb.zip
Fix the port building/installing with non default LOCALBASE.
Pointed out by: QAT Reviewed by: itetcu@
Diffstat (limited to 'devel')
-rw-r--r--devel/eric4/Makefile1
-rw-r--r--devel/eric4/files/config2
2 files changed, 2 insertions, 1 deletions
diff --git a/devel/eric4/Makefile b/devel/eric4/Makefile
index 80b8f677aa10..5b8b131c0c97 100644
--- a/devel/eric4/Makefile
+++ b/devel/eric4/Makefile
@@ -21,6 +21,7 @@ PLIST_FILES=
do-configure:
${SED} -e 's,PYTHON_SITELIBDIR,${PYTHON_SITELIBDIR},' \
-e 's,PREFIX,${PREFIX},' \
+ -e 's,LOCALBASE,${LOCALBASE},' \
-e 's,DOCSDIR,${DOCSDIR},' \
-e 's,EXAMPLESDIR,${EXAMPLESDIR},' \
< ${FILESDIR}/config > ${WRKSRC}/eric4config.freebsd
diff --git a/devel/eric4/files/config b/devel/eric4/files/config
index d9bec3fef2c4..17a30c94e942 100644
--- a/devel/eric4/files/config
+++ b/devel/eric4/files/config
@@ -18,5 +18,5 @@ cfg = {
'ericOthersDir' : 'PYTHON_SITELIBDIR/eric4',
'bindir' : 'PREFIX/bin',
'mdir' : 'PYTHON_SITELIBDIR',
- 'apidir' : '/usr/local/share/qt4/qsci/api',
+ 'apidir' : 'LOCALBASE/share/qt4/qsci/api',
}