aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2018-01-12 08:19:21 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:22:53 +0800
commit0d9663873dc34442416aeeb76f7d5bb75525cc9c (patch)
treefd6b21f669d767eb18a9b884e7f5b54d97ba6a49 /devel
parentf1980cb8d9797d6dc04353245bb4274a4540b30e (diff)
downloadfreebsd-ports-gnome-0d9663873dc34442416aeeb76f7d5bb75525cc9c.tar.gz
freebsd-ports-gnome-0d9663873dc34442416aeeb76f7d5bb75525cc9c.tar.zst
freebsd-ports-gnome-0d9663873dc34442416aeeb76f7d5bb75525cc9c.zip
Add Lua 5.1 version of lua-bitop.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lua-bitop-51/Makefile13
-rw-r--r--devel/lua-bitop/Makefile2
3 files changed, 15 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d03a77aa7abe..567506b576b8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1658,6 +1658,7 @@
SUBDIR += lua-alien
SUBDIR += lua-bitlib
SUBDIR += lua-bitop
+ SUBDIR += lua-bitop-51
SUBDIR += lua-cjson
SUBDIR += lua-gettext
SUBDIR += lua-lgi
diff --git a/devel/lua-bitop-51/Makefile b/devel/lua-bitop-51/Makefile
new file mode 100644
index 000000000000..a6b97968a865
--- /dev/null
+++ b/devel/lua-bitop-51/Makefile
@@ -0,0 +1,13 @@
+# Created by: lx
+# $FreeBSD$
+
+COMMENT= lua-bitop for Lua 5.1
+
+SLAVE_PORT= lua-bitop
+
+USES= gmake lua:51
+
+MASTERDIR= ${.CURDIR}/../lua-bitop
+PLIST= ${MASTERDIR}/pkg-plist
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/lua-bitop/Makefile b/devel/lua-bitop/Makefile
index 15ee24b6c7b8..f7c2ed257b2e 100644
--- a/devel/lua-bitop/Makefile
+++ b/devel/lua-bitop/Makefile
@@ -17,7 +17,7 @@ LICENSE= MIT
CFLAGS+= -DLUA_NUMBER_LONG_LONG -I${LUA_INCDIR}
MAKE_ARGS= CC=${CC} LUA=${LUA_CMD}
TEST_TARGET= test
-USES= gmake lua
+USES?= gmake lua
PLIST_FILES= %%LUA_MODLIBDIR%%/bit.so