aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-06-30 02:50:38 +0800
committermiwi <miwi@FreeBSD.org>2007-06-30 02:50:38 +0800
commit0f7738a5578c91268ade3823850c3dd04f6b4add (patch)
treed690e449ebc12680e4b2394f3b39d3502524a005 /devel
parent5f8b802dd1d4d8d30e06f38058b7889735cabf17 (diff)
downloadfreebsd-ports-gnome-0f7738a5578c91268ade3823850c3dd04f6b4add.tar.gz
freebsd-ports-gnome-0f7738a5578c91268ade3823850c3dd04f6b4add.tar.zst
freebsd-ports-gnome-0f7738a5578c91268ade3823850c3dd04f6b4add.zip
C++/QT Editor with hightlight, project managment. Writed with Qt V4
WWW: http://sourceforge.net/projects/alabastra/ PR: ports/113872 Submitted by: Yinghong.Liu <liu_yinghong at yahoo.com.cn>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/alabastra/Makefile32
-rw-r--r--devel/alabastra/distinfo3
-rw-r--r--devel/alabastra/pkg-descr3
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e0bf648bdafa..94a94844e4a4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -29,6 +29,7 @@
SUBDIR += afay
SUBDIR += agide
SUBDIR += aifad
+ SUBDIR += alabastra
SUBDIR += ald
SUBDIR += alf
SUBDIR += allegro
diff --git a/devel/alabastra/Makefile b/devel/alabastra/Makefile
new file mode 100644
index 000000000000..b261a13cbc85
--- /dev/null
+++ b/devel/alabastra/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: alabastra
+# Date created: 20 Jun 2007
+# Whom: Yinghong.Liu <liu_yinghong@yahoo.com.cn>
+#
+# $FreeBSD$
+
+PORTNAME= alabastra
+PORTVERSION= 0.2b
+CATEGORIES= devel
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=${PORTNAME}
+DISTNAME= Alabastra-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= C++ Editor writed with QT4
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc gui xml
+
+WRKSRC= ${WRKDIR}/Alabastra-${PORTVERSION}
+
+PLIST_FILES= bin/alabastra
+
+do-configure:
+ ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} Alabastra.pro )
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Alabastra ${PREFIX}/bin/alabastra
+
+.include <bsd.port.mk>
diff --git a/devel/alabastra/distinfo b/devel/alabastra/distinfo
new file mode 100644
index 000000000000..d64c45dcf57a
--- /dev/null
+++ b/devel/alabastra/distinfo
@@ -0,0 +1,3 @@
+MD5 (Alabastra-0.2b.tgz) = 94f891e59c7ae19125d9017e9066e4f1
+SHA256 (Alabastra-0.2b.tgz) = e0cc0460a4aad5ec8edb6f42525143bfdb3b0057721fa1b5e6a92b72f3465b60
+SIZE (Alabastra-0.2b.tgz) = 505229
diff --git a/devel/alabastra/pkg-descr b/devel/alabastra/pkg-descr
new file mode 100644
index 000000000000..59d6d2ddfdb0
--- /dev/null
+++ b/devel/alabastra/pkg-descr
@@ -0,0 +1,3 @@
+C++/QT Editor with hightlight, project managment. Writed with Qt V4
+
+WWW: http://sourceforge.net/projects/alabastra/