aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-13 11:50:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-13 11:50:28 +0800
commit150d7f72b2526aa4d113c69a3713a93d6276bbcf (patch)
tree7fda793464a1a7356e78b3e1b38d098995cbb22e /devel
parent69a34bf358c4721fc6371639a55aca7efd13a7c7 (diff)
downloadfreebsd-ports-gnome-150d7f72b2526aa4d113c69a3713a93d6276bbcf.tar.gz
freebsd-ports-gnome-150d7f72b2526aa4d113c69a3713a93d6276bbcf.tar.zst
freebsd-ports-gnome-150d7f72b2526aa4d113c69a3713a93d6276bbcf.zip
- Don't specify protocol in socketpair(AF_UNIX, SOCK_DGRAM, ...), otherwise it fails with EPROTONOSUPPORT. This unbreaks games/super_methane_brothers
MFH: 2015Q4
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib/Makefile2
-rw-r--r--devel/clanlib/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index c6311016dc98..32c1a9d7ca84 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= clanlib
PORTVERSION= 2.3.7
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
diff --git a/devel/clanlib/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp b/devel/clanlib/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp
new file mode 100644
index 000000000000..d33ae67cfa9f
--- /dev/null
+++ b/devel/clanlib/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp
@@ -0,0 +1,11 @@
+--- Sources/Core/System/Unix/event_provider_socketpair.cpp.orig 2011-01-13 11:17:34 UTC
++++ Sources/Core/System/Unix/event_provider_socketpair.cpp
+@@ -45,7 +45,7 @@ CL_EventProvider_Socketpair::CL_EventPro
+ // Not sure if its better to use 0 or PF_UNIX for Linux then. The
+ // documentation for socketpair is not that clear about the
+ // difference. -- mbn 15 april 2005
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ int result = socketpair(AF_UNIX, SOCK_DGRAM, 0, wait_sockets);
+ #else
+ int result = socketpair(AF_UNIX, SOCK_DGRAM, PF_UNIX, wait_sockets);