aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-03-24 20:32:08 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-03-24 20:32:08 +0800
commit167d91edc3ae2a6c2b74e57aef8ecc0aa485a086 (patch)
tree341269b1f71f1386a56d6a970907efb8a6743d89 /devel
parente8ce22ac94f275015db2a5934e0a3205917971e7 (diff)
downloadfreebsd-ports-gnome-167d91edc3ae2a6c2b74e57aef8ecc0aa485a086.tar.gz
freebsd-ports-gnome-167d91edc3ae2a6c2b74e57aef8ecc0aa485a086.tar.zst
freebsd-ports-gnome-167d91edc3ae2a6c2b74e57aef8ecc0aa485a086.zip
- Add pecl-qb 2.1.1
QB stands for Quick Binary. It's a PHP extension designed to enable faster handling of binary data. It takes a function written in PHP and translate it for a specialized virtual machine. The use of static type information leads significantly higher performance than under PHP regular dynamic type system. A PHP+QB function can run anywhere from five to twenty times faster than regular PHP code. For even higher level of performance, one can compile PHP+QB functions to native code (on supported platforms). QB performs code translation on a per-function basis. It does not affect in anyway code not specially marked. Interaction between PHP+QB functions and regular PHP code is basically seamless. A key design objective of QB is to let developers harness greater processing power than what baseline PHP offers without the risk involved in adopting a brand new platform. WWW: http://pecl.php.net/package/qb/ PR: ports/187651 Submitted by: Gasol Wu <gasol.wu@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-qb/Makefile22
-rw-r--r--devel/pecl-qb/distinfo2
-rw-r--r--devel/pecl-qb/pkg-descr15
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 63c173b6f665..68274af0562b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3332,6 +3332,7 @@
SUBDIR += pecl-params
SUBDIR += pecl-parsekit
SUBDIR += pecl-pthreads
+ SUBDIR += pecl-qb
SUBDIR += pecl-runkit
SUBDIR += pecl-scream
SUBDIR += pecl-shape
diff --git a/devel/pecl-qb/Makefile b/devel/pecl-qb/Makefile
new file mode 100644
index 000000000000..164c1da448cf
--- /dev/null
+++ b/devel/pecl-qb/Makefile
@@ -0,0 +1,22 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= qb
+PORTVERSION= 2.1.1
+CATEGORIES= devel
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DIST_SUBDIR= PECL
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= PHP Accelerator designed mainly for graphic work
+
+LICENSE= PHP301
+
+CONFIGURE_ARGS= --with-cpu=native
+NO_WRKSUBDIR= yes
+USE_PHP= yes
+USE_PHPEXT= yes
+USES= tar:tgz
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-qb/distinfo b/devel/pecl-qb/distinfo
new file mode 100644
index 000000000000..dd40c448c2d5
--- /dev/null
+++ b/devel/pecl-qb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/qb-2.1.1.tgz) = af93d2deeb0cfbbd61e961dc53b9ad2aa41228567cad7033fb2b1740b6e0b0f9
+SIZE (PECL/qb-2.1.1.tgz) = 1084826
diff --git a/devel/pecl-qb/pkg-descr b/devel/pecl-qb/pkg-descr
new file mode 100644
index 000000000000..793dc36934a1
--- /dev/null
+++ b/devel/pecl-qb/pkg-descr
@@ -0,0 +1,15 @@
+QB stands for Quick Binary. It's a PHP extension designed to enable faster
+handling of binary data. It takes a function written in PHP and translate it
+for a specialized virtual machine. The use of static type information leads
+significantly higher performance than under PHP regular dynamic type system.
+A PHP+QB function can run anywhere from five to twenty times faster than
+regular PHP code. For even higher level of performance, one can compile PHP+QB
+functions to native code (on supported platforms).
+
+QB performs code translation on a per-function basis. It does not affect in
+anyway code not specially marked. Interaction between PHP+QB functions and
+regular PHP code is basically seamless. A key design objective of QB is to
+let developers harness greater processing power than what baseline PHP offers
+without the risk involved in adopting a brand new platform.
+
+WWW: http://pecl.php.net/package/qb/