aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2010-02-18 04:40:31 +0800
committerlwhsu <lwhsu@FreeBSD.org>2010-02-18 04:40:31 +0800
commit17fbbdae8bd5a8e62ab1a47830073d62616de8f6 (patch)
tree55b8df3d17d0d772e4c4bb18ab8dcfded88030dd /devel
parent12f780519ee9837eea11da6c20ae249c7b3d2384 (diff)
downloadfreebsd-ports-gnome-17fbbdae8bd5a8e62ab1a47830073d62616de8f6.tar.gz
freebsd-ports-gnome-17fbbdae8bd5a8e62ab1a47830073d62616de8f6.tar.zst
freebsd-ports-gnome-17fbbdae8bd5a8e62ab1a47830073d62616de8f6.zip
- Update to 1.13
PR: ports/144048 Submitted by: bf <bf1783 AT gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/abi-compliance-checker/Makefile7
-rw-r--r--devel/abi-compliance-checker/distinfo6
-rw-r--r--devel/abi-compliance-checker/files/patch-abi-compliance-checker.pl33
-rw-r--r--devel/abi-compliance-checker/pkg-descr20
4 files changed, 39 insertions, 27 deletions
diff --git a/devel/abi-compliance-checker/Makefile b/devel/abi-compliance-checker/Makefile
index 1ef29d33b917..0dfdeb5fe86f 100644
--- a/devel/abi-compliance-checker/Makefile
+++ b/devel/abi-compliance-checker/Makefile
@@ -6,14 +6,16 @@
#
PORTNAME= abi-compliance-checker
-PORTVERSION= 1.10
+PORTVERSION= 1.13
CATEGORIES= devel perl5
-MASTER_SITES= http://ispras.linux-foundation.org/images/3/34/
+MASTER_SITES= http://ispras.linux-foundation.org/images/b/ba/
DISTFILES= ${PORTNAME:S/^a/A/}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= bf1783@gmail.com
COMMENT= Checks binary compatibility of two versions of a C/C++ shared library
+RUN_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
+
NO_BUILD= yes
USE_PERL5_RUN= yes
@@ -26,6 +28,7 @@ post-patch:
${REINPLACE_CMD} -e "s|c++filt|${CPPFILT}|g" \
-e "s|readelf|${READELF}|g" -e "s|g++|${CXX}|g" \
-e "s|\"gcc|\"${CC}|g" -e "s|-shared|& -fPIC|g" \
+ -e "s|gsed|${LOCALBASE}/bin/gsed|g" \
${WRKSRC}/${PORTNAME}.pl
do-install:
diff --git a/devel/abi-compliance-checker/distinfo b/devel/abi-compliance-checker/distinfo
index 2431fb631657..734ae6485355 100644
--- a/devel/abi-compliance-checker/distinfo
+++ b/devel/abi-compliance-checker/distinfo
@@ -1,3 +1,3 @@
-MD5 (Abi-compliance-checker-1.10.tar.gz) = 2e591097462d4fa60460ee7ddf023325
-SHA256 (Abi-compliance-checker-1.10.tar.gz) = 8b54c500745b333ae8db69d2d81236f8676d21e9195ad041a27b82af40e7abe0
-SIZE (Abi-compliance-checker-1.10.tar.gz) = 49323
+MD5 (Abi-compliance-checker-1.13.tar.gz) = 9c21a3dae0cfbc5ea2c3636551a52b49
+SHA256 (Abi-compliance-checker-1.13.tar.gz) = a2bb611b24754c7e0b3ea406911f79ed6c8b12e07a719f83b5d0740aef3efba3
+SIZE (Abi-compliance-checker-1.13.tar.gz) = 51118
diff --git a/devel/abi-compliance-checker/files/patch-abi-compliance-checker.pl b/devel/abi-compliance-checker/files/patch-abi-compliance-checker.pl
index 0c67891dc73e..6f35ed330584 100644
--- a/devel/abi-compliance-checker/files/patch-abi-compliance-checker.pl
+++ b/devel/abi-compliance-checker/files/patch-abi-compliance-checker.pl
@@ -1,14 +1,23 @@
---- abi-compliance-checker.pl.orig 2009-11-08 14:27:20.000000000 -0500
-+++ abi-compliance-checker.pl 2009-11-08 14:33:06.000000000 -0500
-@@ -6673,9 +6673,9 @@
- }
- else
+--- abi-compliance-checker.pl.orig 2010-02-16 07:13:09.000000000 -0500
++++ abi-compliance-checker.pl 2010-02-17 13:20:46.000000000 -0500
+@@ -481,7 +481,7 @@
+ return if(not $InfoPath or not -f $InfoPath);
+ my $InfoPath_New = $InfoPath.".1";
+ #my $Keywords = join("\\|", keys(%check_node));#|grep "$Keywords"
+- system("sed ':a;N;\$!ba;s/\\n[^\@]//g' ".esc($InfoPath)."|sed 's/ [ ]\\+/ /g' > ".esc($InfoPath_New));
++ system("gsed ':a;N;\$!ba;s/\\n[^\@]//g' ".esc($InfoPath)."|gsed 's/ [ ]\\+/ /g' > ".esc($InfoPath_New));
+ system("rm", "-fr", $InfoPath);
+ #getting info
+ open(INFO, $InfoPath_New) || die ("can't open file '\$InfoPath_New\': $!\n");
+@@ -7123,9 +7123,9 @@
+
+ sub get_solib_default_paths()
+ {
+- foreach my $Line (split("\n", `ldconfig -p`))
++ foreach my $Line (split("\n", `ldconfig -r`))
{
-- foreach my $Line (split("\n", `ldconfig -p`))
-+ foreach my $Line (split("\n", `ldconfig -r`))
+- if($Line=~/\A[ \t]*([^ \t]+) .* \=\> (.+)\Z/)
++ if($Line=~/\A\t[0-9]*:(.+) \=\> (.+)\Z/)
{
-- if($Line=~/\A[ \t]*([^ \t]+) .* \=\> (.+)\Z/)
-+ if($Line=~/\A\t[0-9]*:(.+) \=\> (.+)\Z/)
- {
- my ($SoCandidate, $Path) = ($1, $2);
-
+ $SoLib_DefaultPath{$1} = $2;
+ }
diff --git a/devel/abi-compliance-checker/pkg-descr b/devel/abi-compliance-checker/pkg-descr
index 15c48f9183fe..22efe86bbb1e 100644
--- a/devel/abi-compliance-checker/pkg-descr
+++ b/devel/abi-compliance-checker/pkg-descr
@@ -3,18 +3,18 @@ library versions, and a simple description of each of the shared libraries in
XML format, abi-compliance-checker searches for the following kinds of binary
compatibility problems:
---Added/withdrawn interfaces (functions, global variables)
---Problems in Data Types:
- --Classes: added/withdrawn virtual functions (changes in layout of
+--added/withdrawn interfaces (functions, global variables)
+--changes to constants
+--problems in data types:
+ --classes: added/withdrawn virtual functions (changes in layout of
virtual table), virtual function positions, virtual function
redefinitions
- --Structural data types: added/withdrawn members (changes in layout of
- type structure),
- changes in members, size changes
- --Enumerations: member value changes
---Interface problems:
- --Parameters and return type changes
- --Static property changes
+ --structural data types: added/withdrawn members (changes in layout of
+ type structure), changes in members, size changes
+ --enumerations: member value changes
+--interface problems:
+ --parameter and return type changes
+ --incorrect symbol versions
The checker then generates a report that assesses the risks of any potential
problems detected.