aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2012-12-16 13:20:17 +0800
committereadler <eadler@FreeBSD.org>2012-12-16 13:20:17 +0800
commit1adc518277bf3d27d1e44f39770b1340a3919a3a (patch)
tree9ff809d1c6cf46423356fad967ee931aeef9e63e /devel
parent1f666a8369d47a32878dcb4f5a6e6894cbfac64c (diff)
downloadfreebsd-ports-gnome-1adc518277bf3d27d1e44f39770b1340a3919a3a.tar.gz
freebsd-ports-gnome-1adc518277bf3d27d1e44f39770b1340a3919a3a.tar.zst
freebsd-ports-gnome-1adc518277bf3d27d1e44f39770b1340a3919a3a.zip
Update to 0.21
Changes: * Support for flat binary files. * Various bug fixes, including many disassembly fixes, an issue causing FRAM reset-vector corruption and refactoring of drivers. * Support for UIF BSL access via USB. * Support for Olimex MSP430-JTAG-ISO-MK2, including power profiling. * Support for parallel JTAG. * Support for many new chips when using Olimex drivers. * Add new interface mode for use with front-ends. * Support for new chips: MSP430F6736, MSP430F2252, MSP430G2403, MSP430F6435. * Support for watchpoints using MSP430.DLL (tilib) driver. * Support for GoodFET (memory access/programming only). * Basic C++ demangling support. * New commands: "fill" and "verify". * Erase requests are now ignored when using FRAM chips. PR: ports/174468 Submitted by: peterj (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/mspdebug/Makefile2
-rw-r--r--devel/mspdebug/distinfo4
-rw-r--r--devel/mspdebug/files/patch-Makefile20
3 files changed, 13 insertions, 13 deletions
diff --git a/devel/mspdebug/Makefile b/devel/mspdebug/Makefile
index ba31fd46f479..f8b69a65800d 100644
--- a/devel/mspdebug/Makefile
+++ b/devel/mspdebug/Makefile
@@ -7,7 +7,7 @@
# Based on the OpenBSD port by: Jasper Lievisse Adriaanse <jasper@openbsd.org>
PORTNAME= mspdebug
-PORTVERSION= 0.19
+PORTVERSION= 0.21
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}
diff --git a/devel/mspdebug/distinfo b/devel/mspdebug/distinfo
index 2c3a466bc80d..c487186a2879 100644
--- a/devel/mspdebug/distinfo
+++ b/devel/mspdebug/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mspdebug-0.19.tar.gz) = 0410ee3c30ae50d028bacee0fe27ec0d0b6cda3163cae51d02cda9aaa8814b6a
-SIZE (mspdebug-0.19.tar.gz) = 174126
+SHA256 (mspdebug-0.21.tar.gz) = 37c0c83851e1ff7048012c733e21cd2fe5bef21f67814a462c6a7049dc709988
+SIZE (mspdebug-0.21.tar.gz) = 228413
diff --git a/devel/mspdebug/files/patch-Makefile b/devel/mspdebug/files/patch-Makefile
index 766e4d4c7cb1..a67f609c01a3 100644
--- a/devel/mspdebug/files/patch-Makefile
+++ b/devel/mspdebug/files/patch-Makefile
@@ -1,16 +1,16 @@
---- Makefile.orig 2011-11-08 08:11:49.000000000 +1100
-+++ Makefile 2012-02-25 09:33:44.098219483 +1100
-@@ -43,8 +43,14 @@
- PORTS_CFLAGS = `pkg-config --cflags libusb`
- PORTS_LDFLAGS = `pkg-config --libs libusb` -ltermcap -pthread
+--- Makefile.orig 2012-11-26 10:27:48.000000000 +1100
++++ Makefile 2012-12-16 15:13:34.359453238 +1100
+@@ -45,8 +45,14 @@
+ PORTS_CFLAGS := $(shell pkg-config --cflags libusb)
+ PORTS_LDFLAGS := $(shell pkg-config --libs libusb) -ltermcap -pthread
else
-+ ifeq ($(UNAME),FreeBSD) # FreeBSD Ports stuff
++ ifeq ($(UNAME_S),FreeBSD) # FreeBSD Ports stuff
+# This is only needed prior to FreeBSD 8.x to find libusb
-+ PORTS_CFLAGS = -I${LOCALBASE}/include
-+ PORTS_LDFLAGS = -L${LOCALBASE}/lib
++ PORTS_CFLAGS := -I${LOCALBASE}/include
++ PORTS_LDFLAGS := -L${LOCALBASE}/lib
+ else
- PORTS_CFLAGS =
- PORTS_LDFLAGS =
+ PORTS_CFLAGS :=
+ PORTS_LDFLAGS :=
+ endif
endif
endif